Turn bluetooth off as default during boot

Since 11.2 bluetooth is defaulted to always turned on during boot. Is there any way to have bluetooth off as default during boot? I don’t want it completely disabled as I sometimes require it but I’d prefer if the BT radio was in the off state as default.

Really the bluetooth state should be persistent across boots - i.e. remember the last state.

suse tpx60s wrote:
> Since 11.2 bluetooth is defaulted to always turned on during boot. Is
> there any way to have bluetooth off as default during boot?

works here, but mine may be different from yours:

YaST > Hardware > Blue Tooth > click “Disable Blue Tooth Services”

explore a little…


palladium

I don’t have bluetooth under hardware in yast. I’ll see if I can install the yast module.

I can’t find the package to install to manage bluetooth from yast. After some googling it seems that it is no longer controlled from yast since oS11.0.

I turn it off manually by either

echo disable >/proc/acpi/ibm/bluetooth

when docked or Fn F5 when undocked.

But neither of these remain persistent and BT always starts-up during boot. What would be the best way to switch it to default not to start BT? I still want the modules loaded so they are ready for when I want BT but I don’t want it started be default.

Read “/etc/init.d/boot.local”.

Thanks. I could put a command in there but that wouldn’t stop the BT coming on by default and then being turned off by the command in boot.local. Not very elegant.

It’s not a big deal but I think it’s just messy and unnecessary to not have the BT and WiFi states persistent (remembered) across boots. It’s possible because XP does it correctly so it’s something in how oS controls the devices.

I agree with the need for this to be configurable. I have been wondering about this myself for a while. To save battery power it would for me also be a good idea to not have it started at boot. Using laptop-mode is not an option because it disables bluetooth during battery operation. To have bluetooth disabled by default (as used to be in earlier versions) is more convenient because then I just press the bluetooth switch and it works, in the case I need a bluetooth app connected.
The hack in init.d is a good workaround for the time being, but I also prefer to know how to fix it nicer.

Just discovered that I don’t have /proc/acpi/ibm/bluetooth so it will probably not work in my case. Maybe because my inbuilt bluetooth is an usb device?

I did some further investigation of the issue and found that when I add rfkill.default_state=0 to the kernel parameters in grub, bluetooth will be off when I boot.
Only problem for me was that wifi was also disabled. Some more googling gave me an idea, which after some trial and error worked:
I created an init.d/boot.wifibutton file that is started with B where I run the folowing commands:

echo 1 > /sys/devices/platform/acer-wmi/rfkill/rfkill0/state
echo 1 > ls /sys/class/ieee80211/phy0/rfkill*/state

The first one may be different on different systems, but when I do this my bluetooth is off and wifi is on!

Btw I added an option to grub which is read via cat /proc/cmdline by boot.wifibutton, which then looks if I want to start in flightmode, in which case wifi remains disabled, of not, which enables only bluetooth. How I love Linux!