TUMBLEWEED XFCE: External monitor causes an interupt every 5 minutes.

Hi, there is plenty of backstory I could toss in here, but the bottom line is that on my Acer Aspire 5 Thin laptop (AMD Ryzen 3 cpu and a Radeon gpu), every time I have my external monitor (An Acer Monitor as well, both it and my laptop’s monitor are set at 1920x1080 resolution) that is generally connected to this laptop, I have experienced some problems once I installed openSUSE XFCE on it. Most of those I’ve solved or hacked around, but one issue continues to plague me: my monitor goes blank every five minutes when it is left idle. It takes several seconds for the screen to return to normal, around 5 to 7.

Now, I at first thought it might be the power settings for the display (which for all I know, it is that), but I’ve only got it set for battery in the Power Manager and all those settings are set higher than 5 minutes (I timed it from the last time I did anything on the screen until it reset) and besides that, it generally stays plugged in and I have everything set for "never’ there. Additionally I tried it with the power management turned off–still did it. I’ve tried all sorts of things based on my research on the web from tuning off the compositor to unplugging the monitor from the laptop–the only thing that will work.

I’m still able to operate, but only because I solved a potentially related problem with a “hack” of sorts. But it may be a clue for someone to know what is going on. So I’ll include what happened with it and what I did to “solve” it. It has always had this problem from the time I installed OS as well. Every time I rebooted, or opened/turned on the monitor, or when it did reset, it would lose the prior settings I had and would default to a mirrored state. On the first install, it showed a “blank” box where you enabled mirrored displays in the display settings, and I couldn’t turn it off, except it would work if I drug the top screen off the other one. Still nothing changed in the check box. But it would of course only stay set for 5 minutes. Then it would blank out, and and everything I put in would change back to different resolution settings and become mirrored again. So the first thing I tried was I generally install without the external monitor plugged in but had forgot to disconnect it out, so I disconnected the monitor and reinstalled openSUSE. That at least allowed me to change the mirrored checkbox on and off, but it still did everything else. To make a long story shorter, I ended up solving the loss of settings by going to the advanced tab of the display settings, once I had things set up as I liked them, create a new profile, updated it, then turned on the top two switches dealing with “when a new monitor” is connected. So that effectively kept my settings in place through the various and sundry resets to my displays that I’m getting. Now the only problem I have is the occasional blanking of the screen every 5 minutes that I leave it idle. It doesn’t turn off any programs, my music will continue to play through the reset if I’m playing music. I’m, in fact using it now to type this.


Another factoid is, as far as I can recall, this is the first XFCE desktop I’ve ever run on this computer, so it could also be a driver conflicting somewhere with XFCE, which I’ve read has had a history of not playing nicely with external monitors.

So, am I destined to be stuck with a monitor that blanks out every five minutes when it is idle for as long as I have this distro on it, or does anyone have any ideas what could be causing this, and any potential fixes. Thanks for reading this post and any answers you may have. Let me know if you want me to provide anything more about my system, cli commands to run, etc.

I believe I’ve discovered my problem. I was sitting at my desk, doing something on my framework notebook last night (almost right after I typed the original post, of course) when my monitor blanked out again, only it was not connected to any external monitor! That was the first time I recall seeing it do that without being connected to an external monitor. Well, that discovery eliminated several possibilities, which sent me back to examining the power settings. I carefully checked all those. So then I went to the Screensaver settings to confirm that I had it turned off, which I did. However, I noticed a “5” entered in the greyed out box for how long of a delay before the screen saver kicks in. “Hum”, I wondered. So I turned the screen saver on and entered 421 minute delay (around 7 hours). And guess what? It solved the every 5 minute reset of my screen. No more blanking out for a few seconds every 5 minutes!

This is obviously a bug in that it shouldn’t do nothing at all, no matter the settings. But apparently the program was still checking every 5 minutes to check it it should do something, then when it determined it didn’t need to do anything, it returned control back to the system. Even when it is disabled. To ensure that it was the case, i changed it to reflect a 1 minute delay, the lowest possible setting. And though the screen blanked out when it hit one minute, it never came back like it did when set to 5 minutes. So I returned it to the max # of minutes (1440 or 24hours/2days) and left the screen saver on. That would mean if i had my screen on but didn’t use it for 2 days, it would at the most, start the screen saver and I would return to watching little mice fly around on the screen.

So for me at least, my problem was solved. I’m now a happy camper. I do love several features of openSUSE and am glad I waded through these initial setup issues. Also, at least this will be here to help others with the same or similar issues, as I couldn’t find anything on the web addressing this specifci issue. Probably because this “bug” affects so few computers.

Rick C.

Create bug report.