Tumbleweed with 12.1 as base

Upgrading: after adjusting my repo`s to point at 12.1 the upgrade process was started, over 2500 packages where downloaded and installed with no issues. Packman still moves slow so if you wanna do a system update or upgrade i suggest you start it at 7 or 8 am local time.

Booting: the bootloader offers both systemd and sysvinit for me because i cant remove sysvinit due to dependencies with other packages installed. The default option uses systemd. **First issue** for me is while the system boots up using systemd and at a moment the process stalls for 10-20 seconds and i notice that my LEDs from my router blink, especially the one for LAN connection; i`m using ifup here not network manager and in var/log/messages i have this line:

dbus[1018]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.NetworkManager.service': Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.

Should i use network manager instead of ifup? Can this be the reason why the boot process stalls for a few seconds ?

After this stall the system eventually loads and i can login to my desktop of choice.

Logging and using the desktop:
I have both Gnome3 and KDE 4.7 installed; the default is KDE. First issue i get is while logging in to KDE at first i type my username and password and it appers like its a wrong login. If i repeat the steps same username and password kde desktop loads(both the user and password are correctly spelled at first time at the login prompt). Here is what i get in var/log/messages:

Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.32 [/usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)

Can this be a bug ?
After a system reboot to have a fresh start at the login prompt if i use Gnome the login process works without any issues… Weird… under Tumbleweed with 11.4 as base all was working as it should at the login prompt.
Issue number 2: Apper fails to load, it complains about a missing library; under Tumbleweed with 11.4 as base KpackageKit worked better so why Kpackagekit was removed from 12.1 ?

General impressions: Thumbs up for the upgrade process. Curios about the boot process, can understand why it stalls for several seconds before continuing to load services? Thumbs down for Apper, Goodbye once more to packagekit. Dolphin still has issues for me while activating the menubar but thats a known bug use CTRL+M to activate the menubar if you need it. :slight_smile:

Feedback from Vbox: Running 12.1 under Vbox here same 2 desktops Gnome 3.2 and KDE 4.7, same thing happens while logging first in to kde but gnome works fine. Can someone confirm if this is a bug ?

Apper issue solved: use Version 0.7.0-1.3.1 and don`t upgrade to 0.7.60git from KDE Unstable.

Packman still moves slow so if you wanna do a system update or upgrade i suggest you start it at 7 or 8 am local time.

You assume that everybody is asleep when it is 19:00 or 20:00 in Romania? :wink:

No i did not, that interval was good for me while downloading upgrades from Packman maybe it is for others, but i belive that in a few days all things will be back to normal in means of traffic to and from Packman Repo.

It seems to be a bug. The first login after boot, if done too soon after the prompt shows, loses one character of the password. I think it’s the second character.

I have not reported it as a bug. I might eventually, but feel free to report it yourself and then post the bug report number.

Oops! It is not a Tumbleweed bug. It is a 12.1 bug. I am not using Tumbleweed, but I do see this problem.

Here is the bug: https://bugzilla.novell.com/show_bug.cgi?id=728554
It is present under 12.1 and Tumbleweed with 12.1 as base.

Thanks for posting that bug number.

It’s a password “stroke delay”. Solution: ***Type slower ***rotfl! Until the bug is fixed.

That too, or press backspace before typing the password. So i only have one issue: systemd hanging. I fixed Apper by using an older version , login issue to KDE has a workaround :slight_smile:

I had trouble installing the openSUSE Current OSS repo according to this
I noticed that there was no space between refresh and the \
I believe that is a bug in the documentation since the space is there for the other repos to add.
After adding the space -it works!:slight_smile:

Yes, it may be a typo error there, since the other repo`s have a space between refresh and
Well i had corrected the little “bug” on the wiki page. :slight_smile:

It happens:)
But I cannot see that it is corrected on the wiki yet.
The code is still

sudo zypper ar --refresh\
http://download.opensuse.org/distribution/openSUSE-current/repo/oss/ \
'openSUSE Current OSS'

Copying and pasting that code into a terminal will confuse puzzled penguins even more. :beat-up:

And the working code is:

sudo zypper ar --refresh \
http://download.opensuse.org/distribution/openSUSE-current/repo/oss/ \
'openSUSE Current OSS'

That goes directly to the function here - not only cosmetics. The first code does not work.
I am talking about Portal:Tumbleweed - openSUSE

Its corrected now :slight_smile:

Yes it is!

On the Portal:Tumbleweed - openSUSE web page the the typo remains unedited.

- Add the current openSUSE repositories with enabled autorefresh:

sudo zypper ar --refresh\   <-- Typo, space required, **--refresh \ **
[Index of /distribution/openSUSE-current/repo/oss](http://download.opensuse.org/distribution/openSUSE-current/repo/oss/) \
'openSUSE Current OSS'

sudo zypper ar --refresh \
[Index of /distribution/openSUSE-current/repo/non-oss](http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/) \
'openSUSE Current non-OSS'

sudo zypper ar --refresh \
[Index of /update/openSUSE-current](http://download.opensuse.org/update/openSUSE-current/) \
'openSUSE Current updates'

Its updated already, reload the browser page and you will see.

Thank you, now it’s correct.
FYI: I booted my computer up with a “Live-CD” OS (no refresh necessary), and the error was there at that time, hence my comment on it. :wink: