Tumbleweed will not start on MSI G73 Laptop

I downloaded the Tumbleweed ISO, did all the checksumming and dd-ed it to a USB stick (8gb USB3).

It boots to the first option screen and goes through all the bootstuff and onto the three different shades of green thingy. It takes forever until they’re all the same shade of green and then it just sits there and does nothing.

I tried changing boot modes - UEFI, UEFI Secure boot, and finally Legacy. All had the exact same result.

I then tried the same stick on my old Alienware M17x2 and it booted perfectly, so I don’t think it’s the stick or the copy.

Anyone have any ideas of what to try?

Yes I know, I tried the search but it’s extremely annoying - it always takes me to another screen and then complains that “MSI” is too short and searching for boot" brings up far too many pages for a mere human to wade through.

Thanks.

…and just FYI - the answer “too many” to the Random Question - “how many hours in a typical Thursday” is NOT incorrect! ;).

OK, removed “splash=silent” & “set gfxpayload=keep” from the boot line which removes the groovy green linss boot thingo, and it’s stalling at -

Starting udev… ok
Loading basic drivers… ok
Starting hardware detection…

…and that’s it.

I also removed ALL external devices (mouse incl), but no change.

SOLVED

Ok, forget it, it was an acpi problem, acpi=off fixed it :grinning:

An update just to help anyone else who might find this info useful -

  1. My laptop is actually an MSI model GS73VR 7RG.

  2. After standard installation the touchpad (Elantech) was not even detected, brightness/volume/FN keys were not working, and the laptop would not turn off (had to hold the power switch down.

All these problems were solved once I installed the non-free Nvidia drivers and removed “acpi=off” from grub’s boot line. Even though it spits out acpi errors on boot, everything is now working perfectly.

Thanks :).