Tumbleweed very slow boot

I’ve been using OpenSuse Tumbleweed for about 14 months now with KDE Plasma. What I have noticed over the past 3-4 months is that the system (boot) is taking so long to boot up with about 3 minutes until the KDE login manager popup and about 1 minute until KDE Plasma loads. With each upgrade the boot time takes longer and longer, I couldn’t find a way to fix it.

Also, when I’m on KDE, some apps sometimes hang for about 20-30 seconds before returning to their normal state.

My tumbleweed version:

$bat /etc/os-release

output;

───────┬────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
│ File: /etc/os-release
│ Size: 395 B
───────┼────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
1 │ NAME=“openSUSE Tumbleweed”
2 │ # VERSION=“20220502”
3 │ ID=“opensuse-tumbleweed”
4 │ ID_LIKE=“opensuse suse”
5 │ VERSION_ID=“20220502”
6 │ PRETTY_NAME=“openSUSE Tumbleweed”
7 │ ANSI_COLOR=“0;32”
8 │ CPE_NAME=“cpe:/o:opensuse:tumbleweed:20220502”
9 │ BUG_REPORT_URL=“https://bugs.opensuse.org
10 │ HOME_URL=“https://www.opensuse.org/
11 │ DOCUMENTATION_URL=“https://en.opensuse.org/Portal:Tumbleweed
12 │ LOGO=“distributor-logo-Tumbleweed”

$[FONT=monospace]systemd-analyze blame

output:


43.592s docker.service 
33.591s smartd.service 
25.998s systemd-journal-flush.service 
18.352s postfix.service 
16.370s apparmor.service 
14.725s polkit.service 
14.662s avahi-daemon.service 
14.646s bluetooth.service 
14.620s dbus.service 
14.064s mariadb.service 
13.331s systemd-logind.service 
11.644s firewalld.service 
 8.255s initrd-switch-root.service 
 8.003s display-manager.service 
 7.476s ModemManager.service 
 7.407s augenrules.service 
 6.242s plymouth-quit-wait.service 
 5.796s apache2.service 
 5.543s systemd-udevd.service 
 5.253s systemd-fsck@dev-disk-by\x2duuid-DCBB\x2dFE38.service 
 5.033s vboxautostart-service.service 
 4.823s cups.service 
 4.099s wpa_supplicant.service 
 3.086s rsyslog.service 
 2.635s klog.service 
 1.908s vboxdrv.service 
 1.809s kbdsettings.service 
 1.717s boot-efi.mount 
 1.630s dracut-initqueue.service 
 1.543s lvm2-monitor.service 
 1.440s systemd-random-seed.service 
 1.188s nscd.service 
 1.165s modprobe@fuse.service 
 1.100s plymouth-read-write.service 
  934ms NetworkManager.service 
  900ms modprobe@configfs.service 
  880ms modprobe@drm.service 
  848ms systemd-journald.service
[FONT=monospace]844ms user@1000.service 
  612ms var.mount 
  612ms kmod-static-nodes.service 
  602ms systemd-udev-trigger.service 
  589ms dev-disk-by\x2duuid-e4bee8ca\x2d9cdd\x2d41f8\x2d86e2\x2dc77290b27d38.swap 
  576ms udisks2.service 
  572ms systemd-user-sessions.service 
  459ms systemd-backlight@backlight:intel_backlight.service 
  451ms plymouth-switch-root.service 
  434ms dracut-shutdown.service 
  385ms dracut-pre-udev.service 
  384ms systemd-sysctl.service 
  383ms systemd-modules-load.service 
  253ms usr-local.mount 
  252ms systemd-remount-fs.service 
  229ms initrd-parse-etc.service 
  220ms upower.service 
  219ms auditd.service 
  216ms dev-hugepages.mount 
  216ms dev-mqueue.mount 
  215ms sys-kernel-debug.mount 
  215ms sys-kernel-tracing.mount 
  210ms srv.mount 
  209ms systemd-tmpfiles-setup-dev.service 
  207ms plymouth-start.service 
  200ms power-profiles-daemon.service 
  198ms root.mount 
  178ms systemd-fsck-root.service 
  167ms opt.mount 
  164ms systemd-tmpfiles-setup.service 
  150ms home.mount 
  137ms rtkit-daemon.service 
  136ms mcelog.service 
  127ms alsa-restore.service 
  117ms redis@default.service 
  106ms boot-grub2-x86_64\x2defi.mount 
   87ms boot-grub2-i386\x2dpc.mount 
   87ms issue-generator.service
[FONT=monospace]70ms sound-extra.service 
   68ms dracut-cmdline.service 
   53ms kernel-sysctl.service 
   52ms systemd-update-utmp.service 
   43ms \x2esnapshots.mount 
   43ms systemd-tmpfiles-clean.service 
   33ms user-runtime-dir@1000.service 
   27ms systemd-vconsole-setup.service 
   21ms initrd-cleanup.service 
   20ms systemd-rfkill.service 
   20ms initrd-udevadm-cleanup-db.service 
   13ms systemd-backlight@leds:dell::kbd_backlight.service 
   10ms tmp.mount 
   10ms sys-fs-fuse-connections.mount 
    9ms systemd-update-utmp-runlevel.service 
    5ms sys-kernel-config.mount
[/FONT][/FONT]

$systemd-analyze critical-chain

output:

graphical.target @2min 5.041s
└─multi-user.target @2min 5.041s
└─docker.service @1min 21.448s +43.592s
└─network.target @1min 21.390s
└─NetworkManager.service @1min 20.453s +934ms
└─network-pre.target @1min 20.423s
└─wpa_supplicant.service @1min 23.549s +4.099s
└─dbus.service @35.100s +14.620s
└─basic.target @35.026s
└─sockets.target @35.026s
└─pcscd.socket @35.024s
└─sysinit.target @34.917s
└─systemd-update-utmp.service @34.863s +52ms
└─auditd.service @34.614s +219ms
└─systemd-tmpfiles-setup.service @34.405s +164ms
└─systemd-journal-flush.service @8.383s +25.998s
└─var.mount @7.691s +612ms
└─local-fs-pre.target @7.622s
└─lvm2-monitor.service @6.077s +1.543s
└─dm-event.socket @6.039s
└─system.slice
└─-.slice

PS: I’m dual booting with Windows10 and it boots in 30 seconds or less while SUSE 4-4.5 minutes (I don’t have SSD).

[/FONT]

First thing to look at is docker. You can either:

a) Disable automatic startup:

$ sudo systemctl disable docker

b) Stop and remove all existing containers

$ docker stop <type every container id here>
$ docker system prune

Thanks for the reply, I disabled Apache, Docker and MariaDB service startup time cut in half but KDE still loads slowly. Is it possible to speed up the startup? I mean what services I can disable without interfering with the OS’s core services.

Check size of journal and reduce it to a minimum. Consider using Storage=volatile. Replacing the HDD by a SSD can result in a large performance gain.