Tumbleweed upgrade problems

Yesterday and today I tried upgrading tumbleweed and I get the following problems:

3 Problems:
Problem: perl-DateTime-Format-ISO8601-0.08-1.6.noarch requires perl(:MODULE_COMPAT_5.24.0), but this requirement cannot be provided
Problem: perl-Gtk2-1.2498-1.3.i586 requires perl(:MODULE_COMPAT_5.22.1), but this requirement cannot be provided
Problem: mpi-selector-1.0.3-13.4.noarch requires perl(:MODULE_COMPAT_5.24.0), but this requirement cannot be provided

Problem: perl-DateTime-Format-ISO8601-0.08-1.6.noarch requires perl(:MODULE_COMPAT_5.24.0), but this requirement cannot be provided
  uninstallable providers: perl-5.24.0-1.1.i586[http-download.opensuse.org-304a31c8]

The first solution for all those problems is to keep approximately 50 obsolete packages, the second solution is to uninstall those packages and the third solution is to break them. Will the MODULE_COMPAT_5.24.0 be provided soon or what would be the best solution? For your information - here are my repositories:

zypper lr
# | Alias                               | Name             | Enabled | GPG Check | Refresh
1 | http-download.opensuse.org-12779cf9 | security         | Yes     | (r ) Yes  | Yes    
2 | http-download.opensuse.org-304a31c8 | openSUSE:Factory | Yes     | (r ) Yes  | Yes    
3 | packman                             | packman          | Yes     | (r ) Yes  | Yes    
4 | repo-debug                          | repo-debug       | Yes     | (r ) Yes  | Yes    
5 | repo-non-oss                        | repo-non-oss     | Yes     | (r ) Yes  | Yes    
6 | repo-oss                            | repo-oss         | Yes     | (r ) Yes  | Yes    
7 | repo-update                         | repo-update      | No      | ----      | Yes   


Mine are like this

openSUSE-20160408-0 | openSUSE-20160408-0         | No      | ----      | No      
packman             | packman                     | Yes     | (r ) Yes  | Yes     
repo-debug          | openSUSE-Tumbleweed-Debug   | No      | ----      | Yes     
repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     
repo-oss            | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     
repo-source         | openSUSE-Tumbleweed-Source  | No      | ----      | Yes     
repo-update         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes    

Why is your update repo set to No?

Thanks caf4926

I am not sure - but I changed them like yours so that the update is yes and the debug is no and I got the same response with zypper dup. So I presume I have a different URL for the update than you. Where did you get the "perl(:MODULE_COMPAT_5.22.1) " from?

linux-top:~ # zypper lr -u
# | Alias                               | Name             | Enabled | GPG Check | Refresh | URI                                                                   
1 | http-download.opensuse.org-12779cf9 | security         | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/security/openSUSE_Tumbleweed
2 | http-download.opensuse.org-304a31c8 | openSUSE:Factory | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss/                     
3 | packman                             | packman          | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/   
4 | repo-debug                          | repo-debug       | No      | ----      | Yes     | http://download.opensuse.org/tumbleweed/repo/debug                    
5 | repo-non-oss                        | repo-non-oss     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss                  
6 | repo-oss                            | repo-oss         | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss                      
7 | repo-update                         | repo-update      | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/tumbleweed/

It is the third day that zypper dup coms with the error message as above. I tried to skip these perl upgrades to at least upgrade other packages but even after trying to press skip more than 10 times the same message always appears:

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): s

Problem: perl-Gtk2-1.2498-1.3.i586 requires perl(:MODULE_COMPAT_5.22.1), but this requirement cannot be provided
  deleted providers: perl-5.22.1-1.40.i586
 Solution 1: Following actions will be done:
  keep obsolete perl-5.22.1-1.40.i586
  keep obsolete perl-File-Find-Rule-0.34-1.2.noarch
  keep obsolete perl-Number-Compare-0.03-10.3.noarch
  keep obsolete perl-Text-Glob-0.09-14.3.i586
  keep obsolete claws-mail-3.13.2-1.3.i586
  keep obsolete gfxboot-4.5.12-1.3.i586
  keep obsolete gnumeric-1.12.29-1.1.i586
  keep obsolete perl-Clone-0.38-1.7.i586
  keep obsolete perl-Crypt-DES-2.07-5.7.i586
  keep obsolete perl-Crypt-Rijndael-1.13-1.6.i586
  keep obsolete perl-Crypt-SSLeay-0.72-1.6.i586
  keep obsolete perl-Crypt-SmbHash-0.12-158.3.i586
  keep obsolete perl-DBD-SQLite-1.50-1.2.i586
  keep obsolete perl-DBI-1.634-1.4.i586
  keep obsolete perl-DateTime-1.28-1.1.i586
  keep obsolete perl-Digest-MD4-1.9-5.7.i586
  keep obsolete perl-Digest-SHA1-2.13-19.7.i586
  keep obsolete perl-File-Next-1.12-5.4.i586
  keep obsolete perl-Glib-1.321-1.3.i586
  keep obsolete perl-HTML-Parser-3.72-1.3.i586
  keep obsolete perl-HTML-Tidy-1.56-3.6.i586
  keep obsolete perl-JSON-XS-3.02-1.1.i586
  keep obsolete perl-List-MoreUtils-0.415-1.1.i586
  keep obsolete perl-Net-DBus-1.1.0-1.6.i586
  keep obsolete perl-Net-SSLeay-1.69-1.5.i586
  keep obsolete perl-Package-Stash-XS-0.28-5.7.i586
  keep obsolete perl-Params-Util-1.07-9.6.i586
  keep obsolete perl-Params-Validate-1.24-1.1.i586
  keep obsolete perl-Parse-RecDescent-1.967013-1.2.i586
  keep obsolete perl-PlRPC-0.2020-25.3.i586
  keep obsolete perl-Socket6-0.25-3.7.i586
  keep obsolete perl-Sub-Identify-0.12-1.4.i586
  keep obsolete perl-Sub-Name-0.15-1.1.i586
  keep obsolete perl-Task-Weaken-1.04-21.3.i586
  keep obsolete perl-Term-ReadKey-2.32-3.19.i586
  keep obsolete perl-TermReadLine-Gnu-1.20-8.7.i586
  keep obsolete perl-Text-Soundex-3.05-1.3.i586
  keep obsolete perl-Variable-Magic-0.59-1.4.i586
  keep obsolete perl-X11-Protocol-0.56-14.3.i586
  keep obsolete perl-X500-DN-0.29-108.3.i586
  keep obsolete perl-XML-LibXML-2.0124-1.2.i586
  keep obsolete perl-XML-NamespaceSupport-1.11-23.3.i586
  keep obsolete perl-XML-Parser-2.44-1.83.i586
  keep obsolete perl-XML-SAX-0.99-24.3.i586
  keep obsolete perl-YAML-LibYAML-0.59-2.7.i586
  keep obsolete perl-apparmor-2.10.1-2.1.i586
  keep obsolete perl-common-sense-3.74-1.17.i586
  keep obsolete perl-gettext-1.05-165.83.i586
  keep obsolete whois-5.2.12-1.1.i586
  keep obsolete yast2-core-3.1.22-1.3.i586
  keep obsolete yast2-perl-bindings-3.1.2-3.8.i586
  keep obsolete apparmor-utils-2.10.1-2.1.noarch
  keep obsolete perl-Archive-Zip-1.57-1.1.noarch
  keep obsolete perl-B-Hooks-EndOfScope-0.21-1.1.noarch
  keep obsolete perl-CPAN-Changes-0.400002-1.3.noarch
  keep obsolete perl-Class-Factory-Util-1.7-14.3.noarch
  keep obsolete perl-Class-Singleton-1.5-1.3.noarch
  keep obsolete perl-Config-Crontab-1.40-3.3.noarch
  keep obsolete perl-Data-Dump-1.23-1.3.noarch
  keep obsolete perl-DateTime-Format-Builder-0.81-5.4.noarch
  keep obsolete perl-DateTime-Format-Strptime-1.68-1.1.noarch
  keep obsolete perl-DateTime-Locale-1.030000-1.1.noarch
  keep obsolete perl-DateTime-TimeZone-1.98-1.1.noarch
  keep obsolete perl-Devel-Symdump-2.17-1.1.noarch
  keep obsolete perl-Digest-HMAC-1.03-20.4.noarch
  keep obsolete perl-Dist-CheckConflicts-0.11-1.3.noarch
  keep obsolete perl-Encode-Locale-1.05-1.3.noarch
  keep obsolete perl-Exporter-Tiny-0.042-1.3.noarch
  keep obsolete perl-ExtUtils-Depends-0.405-1.2.noarch
  keep obsolete perl-ExtUtils-PkgConfig-1.150000-1.3.noarch
  keep obsolete perl-File-Listing-6.04-9.3.noarch
  keep obsolete perl-File-Which-1.19-1.3.noarch
  keep obsolete perl-HTML-Tagset-3.20-73.3.noarch
  keep obsolete perl-HTTP-Cookies-6.01-9.3.noarch
  keep obsolete perl-HTTP-Daemon-6.01-9.3.noarch
  keep obsolete perl-HTTP-Date-6.02-9.3.noarch
  keep obsolete perl-HTTP-Message-6.11-1.2.noarch
  keep obsolete perl-HTTP-Negotiate-6.01-9.3.noarch
  keep obsolete perl-IO-HTML-1.001-1.3.noarch
  keep obsolete perl-IO-Socket-INET6-2.72-3.3.noarch
  keep obsolete perl-IO-Socket-SSL-2.025-1.1.noarch
  keep obsolete perl-IPC-Run3-0.048-1.3.noarch
  keep obsolete perl-Image-ExifTool-10.15-1.1.noarch
  keep obsolete perl-JSON-2.90-4.3.noarch
  keep obsolete perl-LWP-MediaTypes-6.02-9.3.noarch
  keep obsolete perl-LWP-Protocol-https-6.06-1.3.noarch
  keep obsolete perl-List-AllUtils-0.09-1.3.noarch
  keep obsolete perl-MLDBM-2.05-5.4.noarch
  keep obsolete perl-Math-Base-Convert-0.11-1.15.noarch
  keep obsolete perl-Module-Implementation-0.09-1.3.noarch
  keep obsolete perl-Module-Runtime-0.014-3.3.noarch
  keep obsolete perl-Net-DNS-1.05-1.1.noarch
  keep obsolete perl-Net-Daemon-0.48-13.3.noarch
  keep obsolete perl-Net-HTTP-6.09-1.3.noarch
  keep obsolete perl-Net-SNMP-6.0.1-20.4.noarch
  keep obsolete perl-Package-DeprecationManager-0.16-1.1.noarch
  keep obsolete perl-Package-Stash-0.37-1.3.noarch
  keep obsolete perl-Pod-Coverage-0.23-5.4.noarch
  keep obsolete perl-Probe-Perl-0.03-3.3.noarch
  keep obsolete perl-RPC-XML-0.79-1.1.noarch
  keep obsolete perl-SQL-Statement-1.410-1.1.noarch
  keep obsolete perl-Sub-Exporter-Progressive-0.001011-3.3.noarch
  keep obsolete perl-Sub-Install-0.928-1.4.noarch
  keep obsolete perl-Test-Manifest-2.02-1.3.noarch
  keep obsolete perl-Test-Pod-1.51-1.3.noarch
  keep obsolete perl-Test-Pod-Coverage-1.10-3.3.noarch
  keep obsolete perl-Test-Script-1.12-1.1.noarch
  keep obsolete perl-Text-Wrapper-1.05-3.3.noarch
  keep obsolete perl-Tie-IxHash-1.23-5.4.noarch
  keep obsolete perl-TimeDate-1.20-26.3.noarch
  keep obsolete perl-Try-Tiny-0.24-1.2.noarch
  keep obsolete perl-Types-Serialiser-1.0-3.3.noarch
  keep obsolete perl-URI-1.71-1.2.noarch
  keep obsolete perl-WWW-RobotRules-6.02-9.3.noarch
  keep obsolete perl-XML-SAX-Base-1.08-10.4.noarch
  keep obsolete perl-XML-SAX-Expat-0.51-3.3.noarch
  keep obsolete perl-XML-Simple-2.22-1.2.noarch
  keep obsolete perl-XML-Twig-3.49-1.3.noarch
  keep obsolete perl-XML-XPath-1.36-1.1.noarch
  keep obsolete perl-XML-XPathEngine-0.14-5.4.noarch
  keep obsolete perl-libwww-perl-6.15-1.2.noarch
  keep obsolete perl-namespace-autoclean-0.28-1.2.noarch
  keep obsolete perl-namespace-clean-0.27-1.1.noarch
  keep obsolete yast2-apparmor-3.1.3-1.4.noarch
 Solution 2: deinstallation of perl-Gtk2-1.2498-1.3.i586
 Solution 3: break perl-Gtk2-1.2498-1.3.i586 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):

The online update through YAST shows no updates. No idea what to do next except wait if someone more knowledgeable in this forum knows what to do or where to get the missing file or that it turns up in one of these repositories.

Well I don’t really run zypper dup
Because my system is all setup from install, but I use Yast Software Manager > View by repos and Update all in this list (system) if newer version avail
Of course Packman packages have been switched

I don’t have: perl-Gtk2

I’m wondering why you have a 32 bit version installed though?

And I tried zypper dup and of course don’t have the error you have.

Thank you caf4926, my computer is a 32 bit machine hence the 32 bit version. Further since the computer runs Tumbleweed I use zypper dup. I was told in this forum that upgrades of Tumbleweed should be done with zypper dup. And I don’t know why it looks for perl-Gtk2 - I am no computer specialist and I don’t know why certain packages are needed to run the computer and others don’t. I just use the computers privately and for my little business and I use Linux for more than 15 years and most of the time I can - often with help from the excellent people of the forum - sort out problems. BTW if I use zypper up which is probably the equivalent what software manager does I run into problems too:

File './Essentials/i586/phonon-backend-vlc-0.9.0-3.1.i586.rpm' not found on medium 'http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/'

Several of the packages required are not found in the repo and in the end after caching over 600 packages it says

Installation has completed with error.

but nothing of those packages is installed.

Well, apparently you installed some application at one point that requires perl-Gtk2.

Recently, perl has been upgraded to 5.24, but some packages fail to build now and therefore still require the old version.

So you can either wait until this is fixed, or uninstall perl-Gtk2.
Apparently it is not needed by anything on your system.

BTW if I use zypper up which is probably the equivalent what software manager does I run into problems too:

File './Essentials/i586/phonon-backend-vlc-0.9.0-3.1.i586.rpm' not found on medium 'http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/'

This is unrelated, and probably just means that zypper’s cache is outdated.
I.e. the package has been updated, but zypper tries to install the older version that is no longer in the repo.

Refresh the repos (“zypper ref”) and this should not happen.
zypper will do that itself if it detects an outdated cache, but only if it didn’t do so in the last 10 minutes.

The reason could also be that the package has been updated in the repo while you were already installing the updates.
I.e. bad luck/timing…
In this case there’s not much you can do about it, except for updating again (and maybe run “zypper ref” before as mentioned, to force a cache refresh).

Thank you wolfi323, I tried to find out what these 3 perl packages are for. I couldn’t find out much about perl-Gtk2 but perl-Pango seems to have something to do with the alignment of text and perl-Cairo with drawing operations. Now I used to have Lyx and Latex installed here - not any more - and I suspect the perl-Pango is from there. But I was not sure if it is required by LibreOffice. With perl-Cairo I am even less sure since I use Gimp quite a lot and didn’t want to break it by uninstalling. That’s why I wrote to the forum to find out more but since I seem to be the only one having problems with the update I will just uninstall them and if something is broken I will come back. The upgrade seems to be running OK so far and I will come back later to report if everything is OK.

Yes, the update went without problems and I quickly checked LibreOffice and Gimp and they seem to wok as before. No other problems, the packages which could not be retrieved from the packman repository were either related to those 3 perl packages or they were not yet there yesterday when I tried. So everything is fine now. Thank you wolfi323 and caf4926 for your assistance.

I cheated. Fedora rpms are (mostly) very close to openSUSE native packages. try:

Hi and welcome to the Forum :slight_smile:
Your posting to an eight month old thread, plus installing rpm’s from other distro’s is not a good idea, especially with the likes of Tumbleweed. If a package is not installing better to check on the Factory Mailing lists for issues or raise a bug and be patient… perhaps skip those updates until packages can be rebuilt.

I also find Fedora rpm’s somewhat lacking in their checks compared to openSUSE builds…