Tumbleweed Update Fails

Hello,
I have 95 Updates waiting, when I start the update, it hangs with the message

problem with the installed libcgns4_1-4.1.2-15.72.x86_64 

Should I remove libcgns4…, or wait for the next update?
Further effects of the problem: Thunderbird hangs until restarted.

General question: Could the message ‘Update Error, problem with …’ augmented with some suggestions?

Thanks,
Jan Christian

Please do not expect that we are looking over your shoulder or are clairvoyant. What did you do?
You only posted (some of the) output you got, bit you should post complete: the line with the prompt and the command, all the output lines and the line with the new prompt. All in one CODE section.

And I can already tell you that the only way to “update” Tumbleweed is

zypper dup

I pushed the ‘update button’ at the task line, sorry for not mentioning that!

And - for the statistics - I can tell you that ‘zypper dup’ is not the only way. Pushing the little round button with the arrow when you get with the notification that there are updates will start updating. Today there are 95 updates in the pipeline (the daily updates are typically between 1 and 200).

“Pushing a button” (probably in a Desktop Environment that you do not explain) is not what many here trust for updating Tumbleweed.

There is general consensus here that the best way to update to a new Tumbleweed snapshot is by using (as root):

zypper dup

Also it is the best way to copy/paste here when you want to show that you have a problem.

While that is true that it is now possible to use PackageKit based software to update Tumbleweed, zypper simply provides much better visibility into issues. You are free to use whatever you like, but nobody can help you if the only error you show is “something has gone wrong”.

Hi
Just because a button tells you to do X, should you do X? The only way to ensure Tumbleweed moves to the next snapshot is via zypper dup [zypper -vvv dup is better as provides more info]… :wink: (Ref: SDB:Upgrade Tumbleweed - openSUSE Wiki)

I suspect you have a non standard repo active for Thunderbird?

The release in Tumbleweed is version 4.1.2-1.8, your version is different, Likely the non standard repo build has issues.

Oh, please, not again. PackageKit zypper backend performs equivalent of “zypper dup” on Tumbleweed since years.

Hi
Sure, with just the default repositories active, there should not be issues I would imagine.

You wrote:

"Pushing a button"  (probably in a Desktop Environment that you do not  explain) is not what many here trust for updating Tumbleweed.

I interpret this as you do not trust the Tumbleweed ‘rolling release’. Reason? For me, it has worked beautifully in the past (guesstimated: some 500 to 1000 updates).

The only message I am getting is

problem with the installed libcgns4_1-4.1.2-15.72.x86_64
Also it is the best way to copy/paste here when you want to show that you have a problem.

A screenshot would be better in this case, but Spectacle was killed in the failed update.

I now have 105 updates waiting.
Would you recommend removing libcgns4_1-4.1.2-15.72.x86_64

 and give the update another try?

Good news: There are no available updates at the moment!
Bad news: There was an update to openFOAM that I could use!

First interpretation to my first remark should be something like: Oh, I forgot to mention that I run … as desktop and that I clicked on …

Never mind.

If you use zypper dup, no spectacle or other screenshot program must be used…
Just copy/paste.

If you use a screenshot Programm, you have to upload the screen to an paster or to your Web Server and copy the link into the Image Code Block.
So copy/paste from terminal is easier and faster…
And has more Information…

Yes, that’s right. However, when there is a problem that fails. If you use “zypper dup”, you will be presented with a conflict resolution dialog, and that gives you some hints on options for dealing with the problem.

zypper dup worked a charm here to bring me to 20220530, which was announced on factory mailing list just over 1.5 hours ago.

Hi
And then zypper ps -s to determine service restarts and logout/login to clean up.