tumbleweed update error

My update keep failing part way with the following error, I reboot and trying again to see the failure in the same point:

Retrieving: libQt5XmlPatterns5-5.15.2-1.4.x86_64.rpm …[done (737.5 KiB/s)]
Retrieving package libQt5WebSockets5-5.15.2-1.4.x86_64 (1442/2655), 92.2 KiB (263.3 KiB unpacked)
Retrieving: libQt5WebSockets5-5.15.2-1.4.x86_64.rpm …[error]
Download (curl) error for ‘http://download.opensuse.org/tumbleweed/repo/oss/x86_64/libQt5WebSockets5-5.15.2-1.4.x86_64.rpm’:
Error code: Curl error 55
Error message: Connection died, tried 5 times before giving up

**Abort, retry, ignore? [a/r/i/…? shows all options] (a): **a
Problem occurred during or after installation or removal of packages:
Installation has been aborted as directed.
Please see the above error message for a hint.
No processes using deleted files found.

No core libraries or services have been updated.
Reboot is probably not necessary.

Note: Not running as root you are limited to searching for files you have permission to examine with the system stat(2) function. The result might be incomplete.

Was it at exactly the same point?

I saw that error 24 times during my update. I mostly hit “r” to retry, and updating continued. At one time, I hit “a” to abort, and then restarted the update (which remembered what had already been downloaded).

There’s also an email discussion of this on the factory mailing list.

The consensus view seems to be that the download servers were overloaded, causing some connections to fail. The overloading because this was an unusually large update (almost all packages were rebuilt).

A short time ago, I did an update of another system, and that seemed to go fine. Probably more mirrors have picked up the update and are sharing the load so that servers are not so overloaded.

I finally got the update completed and installed after one more reboot. It seems like an issue with the server and curl giving up after retrying a few times.

Yes this was a huge download, and I suspected what you stated that the server were probably seeing a lot of traffic, at least the download did resume from point of failure which is a good thing.

Whenever a large upgrade ( > 1000 packages) is pending, download speed goes down as well as does reliability. Users wanting a fast and smooth upgrade may wait 1 day or 2 days. Concerned users may consider using ‘zypper dist-upgrade --download-only’ and commit the changes upon complete successful download only using ‘zypper dist-upgrade’ which will install the packages from the local cache hasslefree.

Yes, this is true.

When I started my update, I was getting speeds of 100KB/s or less. By the time I was nearing the end, it had moved up to around 400KB/s. Normally, I get over 1MB/s. Obviously started updating a bit too soon, before enough mirrors had synchronized.

Yep, hit this problem again this morning on the “1997 package upgrade” that was similar to my post about a month back where zypper, this time in TTY, found problems with two packages . . . creating dependency in some “gimp” package, figuring that it wouldn’t do “irreparable” harm to the system I chose “ignore,” figuring to post here about what the best choice would be . . . ???

Zypper cursed me for “ignoring this serious problem” . . . but moved on and again some 45 minutes later gave the “installation completed with errors” . . . as the apparent “all clear.” Since there was a kernel update I decided to reboot before making my report to the forum . . . and back in TW I ran “zypper verify” as posted in this thread and . . . it showed, “1997 packages are available for upgrade”??? So, zypper had declared “installation completed” but again, had not installed the packages . . . .

Reading this thread I just tried “zypper dist-upgrade” . . . with no “zypper ref” . . . and it showed “1994 packages in cache” . . . so I ran it through the GUI console, taking maybe another 30 minutes to accomplish the upgrade . . . and, finally zypper finds, “nothing to do.”

It seems like there should be a “better way” to handle these large upgrades . . . TW is supposed to be “rolling” which should mean, constant, regular, chewable package upgrades such that zypper can handle them without multiple passes on it, rather than within a month two chokingly large upgrades, that would be similar to a jump up in distro version??? It just takes time and computer electricity . . . to get to . . . the next large update??? :O>:(lol!:sarcastic:

One unattended install on 2021-03-13, 3183 packages, 1.76 GiB, total download time 15 min, install time 15 minutes, system power 50W = 0,025 kWh = 0,01 €. :wink:

et al:

Essentially this exact same scenario again today on the 1132 package upgrade . . . taking 30 mins to “fail to download one package” but again zypper declares, “Installation completed with errors” . . . however, again running “zypper dup -l” and finding that ALL of the packages were " in cache" and yet to be “installed,” starting another “installation” of the packages taking another 30 mins to complete with a bunch of “dracuts” . . . .

Zypper used to be a . . . zipper . . . wha happen, mon??