Tumbleweed Update as of 05/20/2019

Not sure if this should go hardware or software. Related to a mouse, but it’s bluetooth.

Ran a “zypper dup” on my Tumbleweed install at my house…everything went fine, but after a reboot, I noticed that my bluetooth connection for my mouse would flick on and off. Didn’t have time to investigate, but chalked it up to weak batteries or something like that, since I’ve had no problems at all with it until now. Today, at my office, I also did an update…and after a reboot, the mouse THERE started doing the same thing. Totally different hardware/systems/mice/adapters…no commonalities at all between them. Using KDE plasma for the GUI.

Nothing in dmesg indicating anything about bluetooth failures. Adapter is seen, and is online. Running “service bluetooth status” shows:

May 20 09:57:01 ZotacLinux.sma.org bluetoothd[1037]: **Can't get HIDP connection info**
May 20 09:57:01 ZotacLinux.sma.org bluetoothd[1037]: **connect error: Connection refused (111)**

…and running “journalctl -b | grep -i bluet” yields:

May 20 14:34:40 <hostname> **bluet**oothd[14815]: Endpoint registered: sender=:1.23 path=/MediaEndpoint/A2DPSink
May 20 14:34:40 <hostname> plasmashell[2068]: file:///usr/share/plasma/plasmoids/org.kde.plasma.**bluet**ooth/contents/ui/logic.js:36: TypeError: Type error

…which leads me to think it’s related to the KDE bluetooth system, and not bluetooth ‘in general’

Update.

Installed Gnome through YAST, and fired it up. It, too, did the exact same thing; bluetooth connect/disconnect, over and over in a loop. So, it’s NOT related to KDE. Ran bluetoothctl, listed devices, then turned on my mouse. This looped over and over.

[CHG] Device 00:00:00:00:00:00 Connected: yes
[CHG] Device 00:00:00:00:00:00 Connected: no

(Bluetooth MAC address sanitized; not really all zeros)

And FURTHER information. After another update late yesterday afternoon, I saw another kernel patch was applied. Rebooted, and disconnected/reconnected my mouse, and it worked fine.

…until a reboot. Even though the device is paired, trusted, and ready, I had to manually click “CONNECT” (using a wired mouse), and it started working again. So behavior has changed now, and it’s doing this under Gnome and KDE.

Probably this upstream bug: https://bugzilla.kernel.org/show_bug.cgi?id=203643

That sure looks like it…great find, thanks!

As long as things are being worked on and it’s not just me, I don’t mind. Using a wired mouse for a bit is only slightly annoying. Always
advantages and DISadvantages to bleeding-edge.

Wasn’t me that found it. I read mailing lists:

:smiley:

…and as of the 20190604 update, it APPEARS to be working. Had to remove and re-pair my bluetooth devices, but they came back up. Even survived a reboot, and still
worked. This appears to be fixed with the inclusion of that upstream patch.