Tumbleweed snapshot 20210212 missing lots for MATE desktop and musescore

I am trying to install this snapshot and this is what I get - will be opening another bugzilla. Am I the only one that likes the MATE desktop better than the others?

VM14:~ # zypper ref ; zypper -n dup ; zypper dup --allow-vendor-change
Repository 'Packman Tumbleweed Repository' is up to date.                       
Repository 'Main Repository (NON-OSS)' is up to date.                           
Repository 'Main Repository (OSS)' is up to date.                               
Repository 'Main Update Repository' is up to date.                              
All repositories have been refreshed.
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
2 Problems:
Problem: nothing provides qt5qmlimport(FileIO.3) >= 0 needed by musescore-3.5.2-1.3.i586
Problem: mate-applet-dock-20.04.0-1.4.x86_64 requires python3-xdg, but this requirement cannot be provided

Problem: nothing provides qt5qmlimport(FileIO.3) >= 0 needed by musescore-3.5.2-1.3.i586
 Solution 1: Following actions will be done:
  keep obsolete musescore-3.5.2-1.2.x86_64
  keep obsolete musescore-fonts-3.5.2-1.2.noarch
 Solution 2: deinstallation of musescore-3.5.2-1.2.x86_64
 Solution 3: break musescore-3.5.2-1.3.i586 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): c
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
2 Problems:
Problem: nothing provides qt5qmlimport(FileIO.3) >= 0 needed by musescore-3.5.2-1.3.i586
Problem: mate-applet-dock-20.04.0-1.4.x86_64 requires python3-xdg, but this requirement cannot be provided

Problem: nothing provides qt5qmlimport(FileIO.3) >= 0 needed by musescore-3.5.2-1.3.i586
 Solution 1: Following actions will be done:
  keep obsolete musescore-3.5.2-1.2.x86_64
  keep obsolete musescore-fonts-3.5.2-1.2.noarch
 Solution 2: deinstallation of musescore-3.5.2-1.2.x86_64
 Solution 3: break musescore-3.5.2-1.3.i586 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 3

Problem: mate-applet-dock-20.04.0-1.4.x86_64 requires python3-xdg, but this requirement cannot be provided
  not installable providers: python38-xdg-5.0.0-1.2.noarch[download.opensuse.org-oss]
 Solution 1: deinstallation of mate-applet-dock-20.04.0-1.3.x86_64
 Solution 2: deinstallation of python38-pyxdg-0.27-1.2.noarch
 Solution 3: keep obsolete mate-applet-dock-20.04.0-1.3.x86_64
 Solution 4: break mate-applet-dock-20.04.0-1.4.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 4
Resolving dependencies...
Computing distribution upgrade...
2 Problems:
Problem: nothing provides qt5qmlimport(FileIO.3) >= 0 needed by musescore-3.5.2-1.3.x86_64
Problem: mate-menu-20.04.1-2.2.noarch requires python3-xdg, but this requirement cannot be provided

Problem: nothing provides qt5qmlimport(FileIO.3) >= 0 needed by musescore-3.5.2-1.3.x86_64
 Solution 1: Following actions will be done:
  keep obsolete musescore-3.5.2-1.2.x86_64
  keep obsolete musescore-fonts-3.5.2-1.2.noarch
 Solution 2: deinstallation of musescore-3.5.2-1.2.x86_64
 Solution 3: install musescore-3.5.2-1.3.i586 despite the inferior architecture
 Solution 4: break musescore-3.5.2-1.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 4

Problem: mate-menu-20.04.1-2.2.noarch requires python3-xdg, but this requirement cannot be provided
  not installable providers: python38-xdg-5.0.0-1.2.noarch[download.opensuse.org-oss]
 Solution 1: Following actions will be done:
  deinstallation of mate-menu-20.04.1-2.1.noarch
  deinstallation of mate-panel-branding-openSUSE-42.1-4.45.noarch
 Solution 2: deinstallation of python38-pyxdg-0.27-1.2.noarch
 Solution 3: keep obsolete mate-menu-20.04.1-2.1.noarch
 Solution 4: break mate-menu-20.04.1-2.2.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 4
Resolving dependencies...
Computing distribution upgrade...

The following item is locked and will not be changed by any action:
 Available:
  virtualbox-kmp-default

The following 7 NEW packages are going to be installed:
  kernel-default-5.10.14-1.1 libBox2D2_3_1 libfmt7 policycoreutils
  selinux-autorelabel selinux-tools usbmuxd

The following 3220 packages are going to be upgraded:
 lines deleted for size too big

The following product is going to be upgraded:
  openSUSE Tumbleweed  20210210-0 -> 20210212-0

The following package is going to be reinstalled:
  insserv-compat

The following 6 packages require a system reboot:
  dbus-1 glibc kernel-default-5.10.14-1.1 libopenssl1_0_0 libopenssl1_1 systemd

3220 packages to upgrade, 7 new, 1 to reinstall.
Overall download size: 2.74 GiB. Already cached: 0 B. After the operation,
additional 237.9 MiB will be used.

    Note: System reboot required.
Continue? [y/n/v/...? shows all options] (y): 

Musescore:
https://bugzilla.opensuse.org/show_bug.cgi?id=1181905

Problem: mate-menu-20.04.1-2.2.noarch requires python3-xdg, but this requirement cannot be provided
  not installable providers: python38-xdg-5.0.0-1.2.noarch[download.opensuse.org-oss]
 Solution 1: Following actions will be done:
  deinstallation of mate-menu-20.04.1-2.1.noarch
  deinstallation of mate-panel-branding-openSUSE-42.1-4.45.noarch
 Solution 2: deinstallation of python38-pyxdg-0.27-1.2.noarch
 Solution 3: keep obsolete mate-menu-20.04.1-2.1.noarch
 Solution 4: break mate-menu-20.04.1-2.2.noarch by ignoring some of its dependencies

I would try Solution 2, if possible.
You can break the update if too many problems after deleting that rpm.

New Name python38-xdg

rpm -q --provides https://download.opensuse.org/tumbleweed/repo/oss/noarch/python38-xdg-5.0.0-1.2.noarch.rpm
python3-xdg = 5.0.0-1.2
python3.8dist(xdg) = 5
python38-xdg = 5.0.0-1.2
python3dist(xdg) = 5

Hi
The python pyxdg/xdg issue has been around for a few snapshots… only thing I struck was waiting for packages to sync with a mirror…

@larryr re MATE DE, possibly… :wink:

zypper in python38-xdg

that fixed the MATE issue - musescore still is griping about 2 nothing provides.

Hi
And nothing to do with this snapshot update… it’s a bug from over a week ago :wink:

https://forums.opensuse.org/showthread.php/549930-musescore-nothing-provides-qt5qmlimport

I suspect you haven’t stayed up to date with snapshot releases…?

I "zypper ref ; zypper -n dup " every day right after the packagekit icon says there is an update.

Musescore still works ignoring the nothing provides. The bugzilla is still open on it.

There is talk that 6.0 version is needed to fix the problem - current is 5.3.2.

I install it because I have a friend that uses it and I keep everything anyone I help support uses on one 15.2 and one tumbleweed install.