Tumbleweed repos: Unsupported protocol or redirect

Hello, I am having an issue with tumbleweed repos that I haven’t found already solved online: when trying to upgrade, none of my repositories can be refreshed (except the Brave and Packman repo) and for every repo I receive this error:

Warning: Skipping repository 'Main Repository (NON-OSS)' because of the above error.
Problem retrieving files from 'Main Repository (OSS)'.
Download (curl) error for 'https://cache.opensuse.net.br/tumbleweed/repo/oss/repodata/repomd.xml':
Error code:  Unsupported protocol or redirect (location: http://downloadcontent-br.opensuse.org/tumbleweed/repo/oss/repodata/repomd.xml)
Error message: Redirect to protocol "http" not supported or disabled in libcurl

First of all, I swear that up until a week or so ago all my repos had the url mirrorcache, not just cache. Anyway, based on similar cases found online, I tried just changing the https in the repo url to http, but every time the url resets imemdiately to https.

Even trying to change the repos to mirrorcache doesn’t work So at this point I really don’t know how to make zypper find working repository urls. These are my repos, they all have the same issue except brave and packman:

sudo zypper lr  -d
#  | Alias                                | Name                              | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                        | Service
 1 | KDE_Extra                            | KDE:Extra [audex]                 | No      | ----      | ----    |   99     | rpm-md | https://cache.opensuse.net.br/repositories/KDE:/Extra/KDE_Frameworks5_openSUSE_Tumbleweed/ | 
 2 | Packman-Essentials                   | Packman-Essentials                | No      | ----      | ----    |   90     | NONE   | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/Essentials                              | 
 3 | brave-browser                        | Brave Browser                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://brave-browser-rpm-release.s3.brave.com/x86_64/                                     | 
 4 | home_Dead_Mozay                      | home:Dead_Mozay                   | No      | ----      | ----    |   99     | rpm-md | https://cache.opensuse.net.br/repositories/home:/Dead_Mozay/openSUSE_Tumbleweed/           | 
5 | https-download.opensuse.org-18581a5a | openSUSE:Tumbleweed               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://cache.opensuse.net.br/repositories/openSUSE:/Tumbleweed/standard/                  | 
6 | https-download.opensuse.org-a969a4db | openSUSE:Factory                  | No      | ----      | ----    |   98     | rpm-md | https://cache.opensuse.net.br/repositories/openSUSE:/Factory/snapshot/                     | 
7 | repo-debug                           | openSUSE-Tumbleweed-Debug         | No      | ----      | ----    |   99     | rpm-md | https://cache.opensuse.net.br/debug/tumbleweed/repo/oss/                                   | 
8 | repo-non-oss                         | Main Repository (NON-OSS)         | Yes     | (r ) Yes  | Yes     |   95     | rpm-md | https://cache.opensuse.net.br/tumbleweed/repo/non-oss/                                     | 
9 | repo-oss                             | Main Repository (OSS)             | Yes     | (r ) Yes  | Yes     |   95     | rpm-md | https://cache.opensuse.net.br/tumbleweed/repo/oss/                                         | 
10 | repo-source                          | openSUSE-Tumbleweed-Source        | No      | ----      | ----    |   99     | NONE   | https://cache.opensuse.net.br/source/tumbleweed/repo/oss/                                  | 
11 | repo-update                          | Main Update Repository            | Yes     | (r ) Yes  | Yes     |   95     | rpm-md | https://cache.opensuse.net.br/update/tumbleweed/                                           

Does anyone have an idea on how to solve this? Thanks in advance.

Open Yast Software and go to Configuration => Repositories and click on the problematic repositories one by one and change the following part of these URLs of the repositories by clicking on the Edit button from,




Save the changes by clicking on Ok button.

Thanks!! So, at first it didn’t work: even saving the changes by clicking ok as soon as I reopened the YaST repositories page or ran zypper ref everything turned back to cache.opensuse.net.br. Then I remembered that a few months ago I installed mirrorsorcerer, a tool that should technically find the fastest available mirrors. It worked normally until now, it must have broken down because as soon as I uninstalled it I could change the repo URLs again and now I’m happily downloading 2490 packages to upgrade. Thanks again for your help, I wouldn’t have known what URL to use!

No. https://software.opensuse.org/ ist not a proper URL for a repository…

According to openSUSE:Mirrors Wiki page it is :confused:


You can test yourself. The sentence on this wiki page is missleading. But later in it it is described that you need to use “download”. And if you follow the link on the “software” page you will see that it uses the “download” link. So a little bit bad description…

Doesn’t work:


Gotcha :+1:

I tried to edit the wiki page but after logging-in, the page refused to load with an error,

Fatal exception of type “MWException”

Anyways, thanks for the correction. I’ve edited my earlier reply. Hopefully someone will fix the wiki page.

Great to hear that you solved the problem :+1:

If you use https://download.opensuse.org/, the server will take care of finding the fastest mirror for you.

No, it will take care of finding the closest mirror. Which is not necessary the fastest (and it depends on whether it correctly determined your geographical location in the first place). There are a lot of reports that automatic mirror selection results in slow download.

Agreed. In many cases closest one might be a descent choice. No guarantees though.