Tumbleweed reinstallation with inferior performance in comparisson

Lenovo Yoga 3 Pro, used exact same USB drive for both installations.

On first installation I used this thread to fix wifi problems: https://forums.opensuse.org/showthread.php/523846-Broadcom-BCM4352

Was working great for a few days then I decided to install Battle for Wesnoth. Installed via Software then realized the game was on Steam so I installed there too. Tried to uninstall Wesnoth via Software and it the system seemed to lockup. Tried switching to virtual console, no response, tried to shutdown, no response. So I did a hard shutdown holding the power button. Upon reboot the system was giving errors and wouldn’t get past the rotating arrows screen. With nothing important on the PC I decided to fresh install.

Second install everything is laggy. Sometimes when typing I’ll get multiples of the same letter, the cursor lags everywhere, and games don’t run as well as they did on first install.

What could cause this? I realize nothing is left over from the first installation after formatting, so why isn’t overall performance the same as previous installation?

Thank you.

Start by providing some basic information. Desktop environment? Xorg or Wayland? Graphics chipset and driver?

echo $DESKTOP_SESSION
echo $XDG_SESSION_TYPE
inxi -Gxx
$DESKTOP_SESSION

default

echo $XDG_SESSION_TYPE

wayland

inxi -Gxx

Graphics:
Device-1: Intel HD Graphics 5300 driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:161e
Display: wayland server: X.org 1.20.1 driver: i915 compositor: gnome-shell
resolution: <xdpyinfo missing>
OpenGL: renderer: Mesa DRI Intel HD Graphics 5300 (Broadwell GT2)
v: 4.5 Mesa 18.1.7 compat-v: 3.0 direct render: Yes

How did you reformat?
Did you actually boot to a command prompt and run fdisk, then reformatted (not just remove partitions)
or
Did you just boot to your DVD and re-install (which does not re-format)?

TSU

Used the guided partitioning on the opensuse USB, deleted everything, though I can see how that might have not actually formatted, just remade all the partitions… I don’t recall if it said formatting which makes me think it actually did not.

Booted USB SystemRescueCD to

dd if=/dev/zero of=/dev/sda bs=4096

Booted OpenSUSE Tumbleweed USB to reinstall, again.

Reinstalled wifi following this: https://forums.opensuse.org/showthread.php/523846-Broadcom-BCM4352?p=2873423#post2873423

Followed by zypper dup

It may be placebo, but it feels more responsive than ever before. Everything is working great!

Thank you for your help!

Hard to say what was wrong with your prior install, but good to read that your desktop environment is working as expected now.

Good move wiping your partition, even ;f you are probably still not re-formatting you’ve destroyed “ghosts” from your prior installs.

TSU