Tumbleweed. Problem with vlc & codecs in packman repo

I’ve installed TW from iso file and wanted to configure vlc and codecs.
I’ve added packman-essentials repo and tried to install vlc package but got an error:

nothing provides libvpx.so.1()64bit needed by vlc-noX-2.2.1-285.1.x86_64

I can see it here under TW section http://software.opensuse.org/package/libvpx1 but in yast there ain’t such package in search results.
I tried to install it from one click but with no luck. Got an error message:

Repository type can't be determined

Isn’t it strange that this package is visible on website but not present in yast? How can it be?
Can you help me with this?
And could you please provide full list of codec packages which you usually install?

Well, Tumbleweed switched to libvpx2 recently and dropped libvpx1, but the Packman VLC packages have not been rebuilt against this yet AFAICS.
Unfortunately, such things can happen especially on Tumbleweed. Will probably resolve itself in the next days.

But it might also be related to problems with Packman and an update to the latest OBS, the “Open(SUSE) Build System”.
In that case, it should probably be reported to the Packman mailinglist, so they know about the problem and can retrigger a build of the package (or add libvpx1 to Packman if necessary):
(you don’t have to be subscribed to post to that list)

Although, I see VLC is being re-built at the moment for Factory (and already has been built once against libvpx2), so again this might be resolved in a few hours/tomorrow, depending on your mirror…

Have you tried

zypper in libvpx1

What does show

zypper info libvpx1


And could you please provide full list of codec packages which you usually install?

I only install vlc and vlc-codecs. That’s all I need.

Will be moved to Tumbleweed and is CLOSED for the moment.

Moved from Multimedia and open again.

 sudo zypper in libvpx1 
Loading repository data... 
Reading installed packages... 
'libvpx1' not found in package names. Trying capabilities. 
No provider of 'libvpx1' found.
Resolving package dependencies... 

Nothing to do.

How did you determine that vlc has been rebuilt for factory with libvpx2? Is it possible to see it on this site? http://packman.links2linux.org/updates

As a temporary workaround, you can install vlc-beta.

Yep, this one works. Thank you, sir.

You can see that on Packman’s OBS webinterface e.g.: https://pmbs.links2linux.de/
Or just look at the package dependencies… (with rpm -qp --requires xxx.rpm)

Btw, vlc-beta works because this is not built against/does not use libvpx at all.

Thanks. I hope they fix libvpx issue soon.

There is no “libvpx issue” to be fixed.

This is more an issue of Tumbleweed and OBS as a whole.

I am having the exact same issue with libvpx.so.1 and Mplayer. Is there a workaround for that?


Use the Packman repo for Factory. The packages there are built against libvpx2 already.

It might also work to install libvpx1 from 13.2 or some home: repo, but I cannot guarantee you.

Or wait a few days until the Packman Tumbleweed packages are rebuilt against libvpx2…

Thank you! I´ll try the Factory repo.

Yeah I ran into this when trying out tumblweed but its actually a minor annoyance and easily fixed, changing a repo I can deal with