Tumbleweed on a Optimus Laptop

Optimus Laptop with nVIDIAS proprietary driver and Tumbleweed.

Since Tumbleweed doesn’t have prebuilt nVIDIA drivers I put up this howto that uses the normal nvidia run-file

Nvidia Optimus - Wiki

So what is Bumblebee? It is experimental Optimus support for Linux.
With the use of Bumblebee, 3D can be enabled on both the Intel and the nVIDIA card.
Currently there is no way to disable the Intel card with the use of Bumblebee.
The Intel card is running the Desktop and the nVIDIA card can be used, for applications
that need more OpenGL power, with the command “optirun <PROGRAM>”.

This howto is only made for getting the proprietary nvidia driver working while at same time keeping a fancy desktop…
And it is only meant to show what worked for me… might mess up your system totally :slight_smile:

Laptop model I used: Asus U36JC

First I uninstalled Nouveau + blacklisted it.


zypper ar -f http://download.opensuse.org/repositories/home:/Ximi1970:/bumblebee-unstable/openSUSE_Tumbleweed

git clone http://github.com/MrMEEE/bumblebee.github

cd bumblebee/

ftp ftp://download.nvidia.com/XFree86/Linux-x86_64/290.10/NVIDIA-Linux-x86_64-290.10.run

sudo ./install.sh

Here you will be informed that this is a obsolete version and get a buch of questions if you are sure and sofort,
just answer yes to it all and chose to use a nvidia run file (option 2, I think).

At the end you will have to chose your Laptop model and the default image transport, I chose “proxy” as image transport
as it is faster on my system. This can be changed at any time by running “bumblebee-configure”

If things worked right you now have configured bumblebee for your Laptop :slight_smile:

Now you need to add yourself to the bumblebee group so you don’t have to give root pswd everytime you use “optirun”

sudo usermod -A bumblebee USERNAME

Reboot and cross your fingers :wink:

Verify that things are working.

The Intel part:

glxinfo | grep OpenGL

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile 
OpenGL version string: 2.1 Mesa 7.11

The nVIDIA part:

optirun glxinfo | grep OpenGL

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 310M/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 290.10

Files to inspect if things doesn’t work…


Pardon if my English isn’t correct, I’m a “Swede” rotfl!

Kind Regards Thermal


sudo zypper ar -f http://download.opensuse.org/repositories/home:/Ximi1970:/bumblebee-unstable/openSUSE_Tumbleweed/home:Ximi1970:bumblebee-unstable.repo