Tumbleweed not booting from snapshot

Today, I was thinking about testing the snapshot feature of BTRFS. So i went to the “Start Bootloader from a Read-Only Snapshot” menu from grub and selected a zypper snapshot from the list. Another grub menu popped up and I selected “openSUSE Tumbleweed” from the menu. The OS started booting, but it never finished it. The plymouth theme was running. I pressed F2 to see the console and it said “A start job is running for NTP Server daemon”. I waited for 20 minutes but it couldn’t start NTP server daemon. It also failed to start “Name Cache Server” or something. I powered off the laptop. And selected another snapshot from the grub menu but none of them could boot. All of them produced the same error. I even tried the after-install snapshot. I am using the default snapper config that came with the 20170703 snapshot.

During the installation I selected XFS for /home partition and BTRFS for / partition and checked the Enable Snapshots checkbox. I haven’t tweaked snapper from then. How can I fix this?

My laptop normally boots fine. But it can’t from a snapshot!