Tumbleweed not booting after latest update


after running the latest update Tumbleweed does not boot any more using kernel 5.19.12. I does, however, boot using kernel 15.19.10.

My system summary:

Operating System: openSUSE Tumbleweed 20221001
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Kernel Version: 5.19.10-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × 11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics
Manufacturer: SchenkerTechnologiesGmbH
Product Name: SCHENKER VISION 14

anybody else experiencing that problem?

What problem? Exactly what does “does not boot” mean? Power turns off when you make the default Grub selection? Cooling fans howl? Can you login remotely? Does it happen every boot? Does SDDM come up, but not let you login? Do you have automatic login enabled?

Do you get a login prompt on a black screen? My first boot with i5-11400 produced this result. Logging in as root on vtty3 and running systemctl restart xdm brought up the login greeter. 4 subsequent 5.19.12 boots have worked as expected:

> inxi -C
  Info: 6-core model: 11th Gen Intel Core i5-11400 bits: 64 type: MT MCP
    cache: L2: 3 MiB
  Speed (MHz): avg: 2450 min/max: 800/4400 cores: 1: 2600 2: 2600 3: 2600
    4: 2600 5: 2600 6: 2600 7: 2600 8: 2600 9: 2600 10: 2600 11: 2600 12: 801
> inxi -GSaz
  Kernel: 5.19.12-1-default arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz root=LABEL=tm8p07stw noresume
    ipv6.disable=1 net.ifnames=0 5
  Desktop: Trinity v: R14.0.12 tk: Qt v: 3.5.0 info: kicker wm: Twin v: 3.0
    vt: 7 dm: 1: TDM 2: XDM Distro: openSUSE Tumbleweed 20221001
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 730] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: DP-1,HDMI-A-1,HDMI-A-2 empty: HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:4c8b class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    unloaded: fbdev,vesa alternate: intel gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6160x1440 s-dpi: 120 s-size: 1303x304mm (51.30x11.97")
    s-diag: 1338mm (52.68")
  Monitor-1: DP-1 pos: right model: Acer K272HUL serial: <filter>
    built: 2018 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 pos: primary,left model: NEC EA243WM
    serial: <filter> built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 519x324mm (20.43x12.76") diag: 612mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  Monitor-3: HDMI-A-2 mapped: HDMI-2 pos: center model: Dell P2213
    serial: <filter> built: 2012 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 473x296mm (18.62x11.65") diag: 558mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  OpenGL: renderer: Mesa Intel Graphics (RKL GT1) v: 4.6 Mesa 22.2.0
    direct render: Yes

Possible linu line appendages you could provide in Grub menu after striking the E key include nosimplefb=1 and intel_iommu=off.

My first boot with 5.19.12 produced this result, not i5-11400. :stuck_out_tongue:

Sounds like this one… https://bugs.archlinux.org/task/76064

After 10 minutes we can’t make any needed edits. You replied to what was intended as a correction to my post #2 here. 5.19.12 booted just fine, just not directly into X on first boot after installing 5.19.12. Other forums don’t have the 10 minute cutoff, and misleading material can be corrected at any time.

More likely https://bugzilla.opensuse.org/show_bug.cgi?id=1188954 is what happened with my i5-11400, which has nothing to do with any laptop.

No issues seen here with Intel JasperLake on MicroOS Desktop (GNOME/Wayland).


today, I also installed kernel 5.19.12 on a Lenovo Thinkpad Carbon X1 (9th Gen). The computer booted well with the new kernel, but when plugging the external monitor everything becomes black. It was only possible to switch out the computer and restart it.
After trying two times to plug the monitor, I switched back to kernel 5.19.10 and everything is working fine.



Did you try booting with either nosimplefb=1 and/or intel_iommu=off appended to the linu line in Grub?

No, I did not try any of this.

The problem seems to be solved with 5.19.13. See also following news in German: https://www.heise.de/news/Linux-Kernel-5-19-12-koennte-Displays-von-Laptops-mit-Intel-GPU-beschaedigen-7286874.html