Tumbleweed no graphical interfaces

Hi!
It started with the fact that I couldn’t start any games. So I restarted the PC and now the system no longer boots into a DE, but purely CLI. What has happened? What can I do? I did an update yesterday.

Greetings
Fanmion

Do you use an NVidia GPU? What else can you tell us about what you have and what you did? How did you “update”? One does not “update” TW. One upgrades TW, using sudo zypper dup. SDB:Upgrade Tumbleweed - openSUSE Wiki

I have to give the all-clear, it was due to Mesa Driver, which is offered by Packman Repo. I simply restored the pc via snapper. Can I hide Packman in such cases or at least when it comes to important drivers? I’m terribly sorry, I’m relatively new here?

Greeting
Fanmion

1 Like

You can lock specific problem packages with zypper al, and remove when appropriate with rl. You can also use YaST to manage locks, which it terms taboo. Any repo can be disabled, zypper mr -d, to be enabled only when knowingly needed or desired, mr -e. The locks are kept in /etc/zypp/locks, a text file that may be edited directly. Each repo is a file with name ending in .repo in /etc/zypp/repos.d/. Changing a repo’s filename to not end .repo effectively disables it, as creating or dropping a suitable file whose name ends in .repo creates an enabled repo.

Thank you!

I had the same problems with TW.
Mouse no longer worked properly and a strange desktop.
I switched to TW Slowroll, which solved all the problems.
The packman repo was indeed the problem.

If you (likely) were hit by Catastrophic result after today's graphics driver update - #174 by dr-yak, no, Packman was not the problem since the OSS Mesa was broken as well. Slowroll had an earlier version that didn’t show the problem.

I know MESA is the problem.
I went to slow roll because it’s safer.
Thanks for the reply.