Tumbleweed no boot after updating today

MSI GS73VR 7RG laptop
Tumbleweed on 2nd 1TB SSD, legacy boot (uses entire drive), encrypted /home partition, no multi-boot, grub2 on this drive.
Laptop has i915 plus Nvidia GTX1070 maxQ graphics, using proprietary Nvidia driver

After running zypper dup -l from VT1 (…I can only assume it actually finished updating - I didn’t see it as I was out of the room busy with something else!), I got a recurring message on the screen -

usb usb2-port6: cannot enable. Maybe the USB cable is bad?

Laptop would not respond to ctrl-c, reboot, or switch back to GUI - I had to hard-reset.

I removed all USB devices, still no change.

On reboot, it hangs on the Tumbleweed GUI boot screen, switching to VT1 shows -


…and it just stays there.

Reboot is working and I tried recovery mode - no change, then tried editing the boot line to include acpi=off noapic nolapic, but still no success.

I know there’s not much to go on here, I apologise, but I’m stumped and don’t know which info to provide or where to go from here apart from booting from my Tumbleweed USB stick to recover my user files and then re-install, so I’m hoping someone here is able to offer some advice.


Look at zypper logs for anything interesting:

sudo less /var/log/zypp/history

You may want to repeat dup to see if there’s new updates:

sudo zypper dup

What results when you choose to boot the previously installed kernel in the Grub menu, or the one before that, instead of recovery mode?

Are you using BTRFS, able to roll back to a previous snapshot?

How do you access the system to perform reboot?

Anyway, given message “starting cryptography setup” it may be simply sitting there waiting for passphrase. Try commenting out all devices in /etc/crypttab and corresponding mount points in /etc/fstab as a workaround.

Also boot with “plymouth.enable=0” and without “quiet” on kernel command line.

Fixed :D.

Thanks to the suggestion from MrMazda I booted from the last snapshot and it worked perfectly so I searched for and found instructions on how to recover a previous snapshot. A quick snapper rollback and all is now back to normal - many thanks to all who replied.

I’d completely forgotten about the snapshot feature - opensuse is just the absolute best distro, hands down.

Not sure if I should retry the update though, the zypper log didn’t show anything interesting (I saw no errors listed - thanks for the suggestion awerlang). At a guess I’d say a new snapshot would be made automatically when I run zypper dup, so it should be OK. But if anyone has any further suggestion before I try it again, I’m all ears.

@arvidjaar - “How do you access the system to perform reboot?” - I should have said “when I press ctrl-alt-del” instead of “reboot”.

Thanks for all the help :).