tumbleweed NetWorkManager says wireless unavailable.

After updating to tumbleweed my iwlagn wireless network card is not working.
NetworkManager says wireless is unavailable.
I tried the original 11.4 kernel that was working before the upgrade and that was not it.
Possibly a NetworkManager issue.

21: PCI 200.0: 0282 WLAN controller
[Created at pci.318]
Unique ID: y9sn.dTZhla03AE1
Parent ID: qTvu.oG+uH8EY+4D
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: network
Model: “Intel WiFi Link 100 Series”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x0083 “WiFi Link 100 Series”
SubVendor: pci 0x8086 “Intel Corporation”
SubDevice: pci 0x1305
Driver: “iwlagn”
Driver Modules: “iwlagn”
Device File: wlan0
Features: WLAN
Memory Range: 0xd1800000-0xd1801fff (rw,non-prefetchable)
IRQ: 45 (3683 events)
HW Address: 00:1e:64:52:c3:50
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v00008086d00000083sv00008086sd00001305bc02sc80i00”
Driver Info #0:
Driver Status: iwlagn is active
Driver Activation Cmd: “modprobe iwlagn”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #14 (PCI bridge)

If i use command line, setup /etc/wpa_supplicant/wpa_supplicant.conf I can connect. NetworkManager and wireless appears to be the issue.

Same here, the NetworkManager log says:

<info> (wlan0): now managed
<info> (wlan0): device state change: unmanaged -> unavailable (reason ‘managed’) [10 20 2]

Networkmanager worked in Opensuse 11.4. In Tumbleweed, interface wlan0 only works when setup with command-line tools, iwconfig, ifconfig, etc.

Shouldn’t be that way. Do you have both GNOME and KDE installed? Any other repos except Tumbleweed?


The solution for me was to update to wpa_supplicant-0.7.3-1.4.i586 from the Tumbleweed sources. The telltale messages from the NetworkManager logs were:

…[nm-device-wifi.c:1559] real_is_available(): (wlan0): not available because supplicant interface not ready
…[nm-device.c:3932] nm_device_state_changed(): (wlan0): device not yet available for transition to DISCONNECTED

Also see Re: wifi and NetworkManager 0.8.996

Thanks for the reply!