Tumbleweed / Leap15 performance much worse than 42.3

I recently upgraded from 42.3 to tumbleweed and found some FPGA synthesize jobs (using Altera/Intel Quartus 17.1) which I run regularly had slowed down significantly. To identify the problem, I did some tests and freshly installed 42.3 from the image, then updated to latest 42.3, then upgraded to 15.0. Here the results:

42.3 (kernel 4.4.76, from image) : 330 sec
42.3 (kernel 4.4.132, latest update): 320 sec
15.0 (kernel 4.12.14): 740 sec
Tumbleweed(kernel 4.16.12): 725 sec

All on the same HW (Zotac Box / Intel Core I3), with plenty of RAM (16 GB), and I also tried to boot with pti=off to avoid Spectre/Meltdown bugfixes - did not help. Furthermore, the problem is not related to the Altera SW, Xilinx Vivado shows similar results.

What did happen there? I’ve been using SUSE since 1994 but never experienced something like that. Did people forget the compile optimizations when building shared libraries? Or do newer kernels load CPU-FW related to spectre and meltdown bugs that are slowing down the system by 60% ? It feels like working on my old laptop from 10 years ago.>:(

I cannot confirm your results, and I cannot provide an answer.

For me, in all I do, I find 15.0 and TW performance better that 42.3.

Not sure what to suggest, can only offer “Good Luck”.

Maybe you need to consider compiling your own kernel more suited to your needs.

What suits my needs? Is it really the kernel or rather a library? And am I the only one with such a strange experience? Difficult to image given that it slowed down by more than a factor of 2.

I have no idea - I don’t use such software. Like Gerry also mentioned, I haven’t been impacted, but I’m not doing anything beyond basic desktop tasks. Maybe you could start by seeking support from Altera.

I also suggest posting on the Altera an Xilinux forums…


Agreed that your likely best first steps to addressing your problem is to gather more information, specifically whether others running your combination of kernel and software are experiencing the same slowdown.

That means trying to contact others through common methods like
Software community support like forums, mail lists, IRC
Social communities like Reddit

We here in the openSUSE forums probably are too general purpose and not specific to the software you’re running.


Did you inspect the output of

systemd-analyze blame