Tumbleweed KDE 4.8 (obsolete thread)

Will Tumbleweed receive KDE 4.8 once it gets released later this month? What’s the policy for upgrade Desktop Environments and things like that?

When it finds its way into the openSUSE Factory repositories and then when it’s stable, it will be put in the Tumbleweed repos. And all of that might take some time to happen.

Keep in mind we never got KDE 4.7 in TW. Most of us just used the (11.4) KDE repos without too much trouble, if any.

Since Tumbleweed has openSUSE 12.1 as base you can use the upstream repo`s of KDE for openSUSE 12.1 -> KDE repositories - openSUSE to have the latest version of the desktop if you really want too.

I just installed KDE 4.8 using the repos and dependency solutions discussed in this thread: http://forums.opensuse.org/forums/english/get-technical-help-here/applications/471392-kde-4-8-ready-now.html

It installs and works well in Tumbleweed (so far – fingers crossed) and even solves a couple of bugs I had with KDE 4.7.

Tumbleweed still responds to zypper dup sanely with the extra two KDE factory repos attached.

I just installed KDE 4.8 again using the upstream repos, core & extra after disabling the tumbleweed KDE extra repo & it updated much more smoothly than before. zypper dup asked one question, to uninstall one package, then it all upgraded fine, including the openSUSE branded login screen. File indexer is still enabled by default but runs in the background & doesn’t hog the CPU’s. Only very mild issue was that some of my fonts had increased in size, so I just altered those & logged out / back in to sort that. Added bonus is that the bug of the log in screen missing the 2nd or 3rd character of your password seems to be fixed. Running great here, I just ran zypper dup once, after initial log out / back in I ran zypper dup again & it says nothing to do. Great job openSUSE :slight_smile:

What do you get from this command: rpm -qa | grep kdebase4


kdebase4-libkonq-4.8.0-280.1.x86_64
kdebase4-workspace-4.8.0-2.1.x86_64
kdebase4-workspace-plasma-calendar-4.8.0-2.1.x86_64
kdebase4-runtime-branding-openSUSE-12.1-55.54.3.x86_64
kdebase4-nsplugin-4.8.0-280.1.x86_64
kdebase4-workspace-liboxygenstyle-4.8.0-2.1.x86_64
kdebase4-workspace-ksysguardd-4.8.0-2.1.x86_64
kdebase4-session-4.8.0-63.1.noarch
python-kdebase4-4.8.0-732.1.x86_64
kdebase4-workspace-branding-openSUSE-12.1-55.54.3.x86_64
kdebase4-runtime-xine-4.8.0-353.1.x86_64
kdebase4-workspace-plasma-engine-akonadi-4.8.0-2.1.x86_64
kdebase4-runtime-4.8.0-353.1.x86_64
kdebase4-openSUSE-12.1-55.54.3.x86_64

Why?

I tried the plain zypper dup (to see what would happen) and got a very different result. It all remained at KDE 4.7. For me. It would only upgrade for me if I ran “zypper dup --from KDE48etc”. So I’m puzzled as to why plain zypper dup worked for you. I must have some strange setup happening here.

Yes, when I ran zypper dup a couple of days ago I got a lot of questions about downgrading this, uninstalling that etc etc. I backed away from that & gave it a few days more. Tried today using same repos & just one initial question about uninstalling a qt library (I think) which was default option. Zypper dup is all I did today.

Here are my repos if that helps:


1 | KDE_Extra_Tumbleweed    | openSUSE:Tumbleweed_KDE_Extra   | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/          |                                                                                                                                                                                                    
2 | LibreOffice_Tumbleweed  | openSUSE:Tumbleweed_LibreOffice | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/ |                                                                                                                                                                                                    
3 | Tumbleweed_Packman      | openSUSE:Tumbleweed_Packman     | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed                                   |                                                                                                                                                                                                    
4 | openSUSE:KDE4.8_Core    | openSUSE:KDE4.8_Core            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/          |        
5 | openSUSE:KDE4.8_Extra   | openSUSE:KDE4.8_Extra           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/ |        
6 | openSUSE:Stable_OSS     | openSUSE:Stable_OSS             | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/               |        
7 | openSUSE:Stable_Updates | openSUSE:Stable_Updates         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-current/                              |        
8 | openSUSE:Stable_non-OSS | openSUSE:Stable_non-OSS         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/           |        
9 | openSUSE:Tumbleweed     | openSUSE:Tumbleweed             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/           | 

Thanks c100t. I found I had to follow the method of this thread which deals solely with KDE in vanilla 12.1: thread: http://forums.opensuse.org/forums/english/get-technical-help-here/applications/471392-kde-4-8-ready-now.html
I’ll put all that stuff in the vanilla 12.4 thread together as it applies to Tumbleweed for other users who might find it useful, here goes:

{first I backed up my root partition in case I want to undo it all later. Many ways to do this. I used this method: http://forums.opensuse.org/content/48-howto-backup-restore-tumbleweed-root-system-partition-quickly-simply.html }

You should have these repos attached for a well working Tumbleweed (and maybe some optional extras, but at least these):
As shown by “zypper lr -d”
john@tumbleweed121:~> zypper lr -d


#  | Alias                  | Name               | Enabled | Refresh | Priority | URI                                                                      |
---+------------------------+--------------------+---------+---------+----------+--------------------------------------------------------------------------+
 1 | CurrentUpdates         | osCurrentUpdates   | Yes     | Yes     |   99     | http://download.opensuse.org/update/openSUSE-current/                    |
 2 | PackmanTumbleweed      | PackmanTumbleweed  | Yes     | Yes     |   99     | http://packman.inode.at/suse/openSUSE_Tumbleweed                         |
 3 | Tumbleweed             | Tumbleweed         | Yes     | Yes     |   99     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |
 4 | openSUSEcurrentNonoss  | osCurrentNonoss    | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ |
 5 | openSUSEcurrentOSS     | osCurrentOss       | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/     |

The KDE Upstream repos to attach are on these URLs:

Attach the repos, including naming them and setting auto refresh, with these zypper commands:


zypper ar -cf http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/ KDE48main12.1
zypper ar -cf http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/ KDE48extra12.1

In the listings from zypper (zypper lr -d) you should now see two extra KDE repos, similar to these:


6 | KDE48main12.1          | KDE48main12.1      | Yes | Yes |   99   | http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/          |
7 | KDE48extra12.1         | KDE48extra12.1     | Yes | Yes |   99   | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/ |

Next you update the distro using this command: zypper dup --from KDE48main12.1

You’ll get a response like this, maybe with some dependency issues like I got (and maybe no issues if you’re lucky). I left a lot of extraneous dialogue out of the following text:


tumbleweed121:/home/john # zypper dup -D --from KDE48main12.1
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: qt4-qtscript-0.1.0-14.1.2.x86_64 requires libqt4 = 4.7.4, but this requirement cannot be provided
Problem: k3b-codecs-2.0.2-13.19.x86_64 requires k3b = 2.0.2-13.19, but this requirement cannot be provided

Problem: qt4-qtscript-0.1.0-14.1.2.x86_64 requires libqt4 = 4.7.4, but this requirement cannot be provided
  uninstallable providers: libqt4-4.7.4-19.2.2.i586[openSUSEcurrentOSS]
                   libqt4-4.7.4-19.2.2.x86_64[openSUSEcurrentOSS]
 Solution 1: Following actions will be done:
  keep obsolete libqt4-4.7.4-19.4.1.x86_64
  keep obsolete kdegames4-carddecks-default-4.7.2-3.1.2.noarch
  keep obsolete libkdeedu4-data-4.7.2-2.1.2.noarch
 Solution 2: deinstallation of qt4-qtscript-0.1.0-14.1.2.x86_64
 Solution 3: keep obsolete libqt4-4.7.4-19.4.1.x86_64
 Solution 4: break qt4-qtscript by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 2

Problem: k3b-codecs-2.0.2-13.19.x86_64 requires k3b = 2.0.2-13.19, but this requirement cannot be provided
 Solution 1: deinstallation of k3b-codecs-2.0.2-13.19.x86_64
 Solution 2: keep obsolete k3b-2.0.2-13.19.x86_64
 Solution 3: keep obsolete k3b-2.0.2-13.19.x86_64
 Solution 4: break k3b-codecs by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 2
Resolving dependencies...
Computing distribution upgrade...

The following NEW packages are going to be installed:
  kactivities4 kdebase4-workspace-plasma-calendar kdebase4-workspace-plasma-engine-akonadi ktorrent-lang libgadu3 libkgeomap-lang libktorrent3-lang libkvkontakte1 libmarblewidget13 libqzeitgeist1 libzeitgeist-1_0-1 NetworkManager-kde4-libs-lang python-xdg 
  skanlite-doc skanlite-lang zeitgeist zeitgeist-datahub 

The following package is going to be REMOVED:
  qt4-qtscript 

The following packages are going to be upgraded:
  {here a big list, deleted by swerdna} 

The following packages are going to be downgraded:
  lensfun-data libepub0 libggz2 libiodbc3 liblensfun0 liblqr-1-0 libqoauth1 moodbar 

The following packages are going to change vendor:
  {here a big list, deleted by swerdna}                               


182 packages to upgrade, 8 to downgrade, 17 new, 1 to remove, 190  to change vendor.
Overall download size: 323.7 MiB. After the operation, additional 49.0 MiB will be used.
Continue? [y/n/?] (y): 

Notice that I chose to uninstall the qt4-qtscript package (first dependency issue)
Notice that I chose to keep the obsolete K3B package (second dependency issue)

With those selections and parameters I had a smooth run. After that I was able to return to using standard “zypper dup” for routine Tumbleweed updates

That’s all folks

swerdna,

A million thanks for your clear and thorough guide to KDE 4.8 installation. It worked flawlessly!

All the best,
PG

Here is a note posted by caf4926 in Tech News that is important for this thread:

Please take note that currently the KDE Release repos are being populated ready for the Release next week of KDE4.8.1

This means you cannot currently update from these repos as there is a mix of 4.8.0 and 4.8.1

Release date is March 6th

It could take a day or two for the repos to sync properly.

This thread is now obsolete. KDE 4.8 is in the Tumbleweed repo so it is unnecessary to use the KDE48 factory repos to obtain KDE 4.8. It will arrive unbidden, via Tumbleweed.

For KDE 4.8 in Tumbleweed, go here: http://forums.opensuse.org/english/get-technical-help-here/tumbleweed/473741-kde-4-8-now-landing-opensuse-tumbleweed.html