Tumbleweed is unusable

What I can still do: pressing briefly main switch I can change user or switch off or reboot. Almost nothing else.
Login in any user give keyboard almost useless (but escape seem s working), no pointer visible and so on.
In panel, in lower left corner menu is not available.
In bootloader screen I tried all options: “Advanced options …” and “start bootloader from a read-only snapshot” but nothing change.
Yesterday I did a big update (more than 500 packages) that probably is the origin of the problem.
Any suggestion to resume control of system?

@Giorgio_os Hi, at grub, press the e key, then arrow down to the line starting linux(or linuxefi) press the end key, then add a 3 and press F10 to boot and see if that gets the system up and running.

What GPU hardware?

Thanks for quick answer.

Not sure I did it correctly but it seems not working.

AMD Radeon. If you need more info I’ll search in one of my old threads.

Trying again I found a “read only snapshot” that works (almost). The only thing still not working is internet. Using my mobile as modem via wifi internet is not working. Even if mobile works with onother pc.

You most likely ran into the issue with Mesa packages. Apparently that should be resolved with 24.1.1. Perhaps you can follow this thread: Tumbleweed no graphical interfaces - #8 by GJElde

Perhaps choose an older snapshot and do a rollback from it:

Thanks for suggestions.

I’m not so skilled then I will look into snapshot management .
But I think the easiest way could be update the system from the working snapshot. Unfortunately internet doesn’t works.

Made a rollback (very easy) from a “working” snapshot and now I’m writing from my laptop bring back to life. Big result but not enough.
I have two main problems:

  1. All my documents, works, files and so on are in an NTFS partition. I mounted at boot but it’s read only. Note that folder where I mount this partition in Dolphin show permission read/write for all (owner, group, other). For this I open a new thread.

  2. update all packages (unfortunately partial update is almost impossible) and system become unusable again. Then I had to rollback one more time.
    The the next big problem to solve is understanding which package is the problem.

I’m here again with a new problem: MicroOS.
In bootloader there is openSUSE MicroOS and Tumbleweed disappeared.
Probably during rollback or after, trying to update system, I installed something wrong.
What is MicroOS?
How can I go back to Tumbleweed?

By the way MicroOS is probably the origin of a conflict in update I have now.

Is openSUSE-repos-MicroOS installed instead of openSUSE-repos-Tumbleweed? If yes, switch them back, then dup, then, optionally, remove openSUSE-repos-Tumbleweed, and create lock openSUSE-repo* to prevent either from getting reinstalled. Having one installed creates a repo management service. Without either, the admin has traditional full control of repo configurations.

I don’t think, at least I never did it voluntarily. I don’t remember any repo added after rollback.

Here’s my repos

:~> zypper lr
Repository priorities in effect:                                                            (See 'zypper lr -P' for details)
      90 (raised priority)  :  1 repository
      99 (default priority) :  4 repositories

# | Alias               | Name                                   | Enabled | GPG Check | Refresh
--+---------------------+----------------------------------------+---------+-----------+--------
1 | openSUSE-20240309-0 | openSUSE-20240309-0                    | No      | ----      | ----
2 | packman-essentials  | packman-essentials                     | Yes     | (r ) Yes  | Yes
3 | repo-debug          | openSUSE-Tumbleweed-Debug              | No      | ----      | ----
4 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss            | Yes     | (r ) Yes  | Yes
5 | repo-openh264       | Open H.264 Codec (openSUSE Tumbleweed) | Yes     | (r ) Yes  | Yes
6 | repo-oss            | openSUSE-Tumbleweed-Oss                | Yes     | (r ) Yes  | Yes
7 | repo-source         | openSUSE-Tumbleweed-Source             | No      | ----      | ----
8 | repo-update         | openSUSE-Tumbleweed-Update             | Yes     | (r ) Yes  | Yes

is there anything related to MicroOS?

openSUSE-repos-MicroOS and openSUSE-repos-Tumbleweed are rpm packages, not repos.

Now it’s clear.
None of them seems installed.

Your repos as they are might be just fine. We cannot be sure because you failed to use the -d switch with the zypper lr output you pasted, which causes the most important information, URLs, to be omitted.

Only because I don’t know.

~> zypper lr -d
# | Alias               | Name                                   | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                             | Service
--+---------------------+----------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------+--------
1 | openSUSE-20240309-0 | openSUSE-20240309-0                    | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-JetFlash_Transcend_16GB_ZFURB3G5-0:0-part2      | 
2 | packman-essentials  | packman-essentials                     | Sì      | (r ) Sì   | Sì      |   90     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials/ | 
3 | repo-debug          | openSUSE-Tumbleweed-Debug              | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/tumbleweed/repo/oss/                         | 
4 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss            | Sì      | (r ) Sì   | Sì      |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                           | 
5 | repo-openh264       | Open H.264 Codec (openSUSE Tumbleweed) | Sì      | (r ) Sì   | Sì      |   99     | rpm-md | http://codecs.opensuse.org/openh264/openSUSE_Tumbleweed                         | 
6 | repo-oss            | openSUSE-Tumbleweed-Oss                | Sì      | (r ) Sì   | Sì      |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                               | 
7 | repo-source         | openSUSE-Tumbleweed-Source             | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/source/tumbleweed/repo/oss/                        | 
8 | repo-update         | openSUSE-Tumbleweed-Update             | Sì      | (r ) Sì   | Sì      |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/    

Your repo list should be no problem as it currently is, but #1 is obsolete and may be deleted. #2 differs slightly from what I use

baseurl=http://ftp5.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/Essentials

but also should be no problem.

What model Radeon do you have? If I have a similar one I may be able to try to reproduce.

Please show output from rpm -qa | grep mwar | sort

Note that my problem now is going back to Tumbleweed instead of keeping MicroOS.

Here’s what you asked for:

~>  rpm -qa | grep mwar | sort
kernel-firmware-all-20240618-1.1.noarch
kernel-firmware-amdgpu-20240618-1.1.noarch
kernel-firmware-ath10k-20240618-1.1.noarch
kernel-firmware-ath11k-20240618-1.1.noarch
kernel-firmware-ath12k-20240618-1.1.noarch
kernel-firmware-atheros-20240618-1.1.noarch
kernel-firmware-bluetooth-20240618-1.1.noarch
kernel-firmware-bnx2-20240618-1.1.noarch
kernel-firmware-brcm-20240618-1.1.noarch
kernel-firmware-chelsio-20240618-1.1.noarch
kernel-firmware-dpaa2-20240618-1.1.noarch
kernel-firmware-i915-20240618-1.1.noarch
kernel-firmware-intel-20240618-1.1.noarch
kernel-firmware-iwlwifi-20240618-1.1.noarch
kernel-firmware-liquidio-20240618-1.1.noarch
kernel-firmware-marvell-20240618-1.1.noarch
kernel-firmware-media-20240618-1.1.noarch
kernel-firmware-mediatek-20240618-1.1.noarch
kernel-firmware-mellanox-20240618-1.1.noarch
kernel-firmware-mwifiex-20240618-1.1.noarch
kernel-firmware-network-20240618-1.1.noarch
kernel-firmware-nfp-20240618-1.1.noarch
kernel-firmware-nvidia-20240618-1.1.noarch
kernel-firmware-platform-20240618-1.1.noarch
kernel-firmware-prestera-20240618-1.1.noarch
kernel-firmware-qcom-20240618-1.1.noarch
kernel-firmware-qlogic-20240519-1.1.noarch
kernel-firmware-radeon-20240519-1.1.noarch
kernel-firmware-realtek-20240618-1.1.noarch
kernel-firmware-serial-20240519-1.1.noarch
kernel-firmware-sound-20240618-1.1.noarch
kernel-firmware-ti-20240618-1.1.noarch
kernel-firmware-ueagle-20240519-1.1.noarch
kernel-firmware-usb-network-20240618-1.1.noarch
sof-firmware-2024.03-1.1.noarch
texlive-eqnnumwarn-2024.213.1.0svn45511-56.2.noarch