Tumbleweed installation is broken, at least from net image

I have installed it many times without any fail.

This time, installation of multiple packages failed and system did not install.

sha256sum: openSUSE-Tumbleweed-NET-x86_64-Snapshot20190621-Media.iso


Some sort of hint about what went wrong, or about where (in the procedure) things went wrong might be more informative.

Started quarter of the way, from “ca-certificates”. After that, there was fail after fail. Most seem to install, but had to click countless times to accept error. Strange that only random set of packages failed. Those failed installs did not seem to have anything in common, at least I did not notice any.

By the way, I then tried 15.1 net install and installed OS multiple times succesfully, until latest time, when the same “ca-certificates” error came.

Download seems to succeed, but when install bar gets to full, there is error.

Why installing multiple times? Because there is a separate problem with Nvidia proprietary drivers that in practice ruins the installation and apparently makes it impossible to use Nvidia’s own drivers. If this were good quality, It would work with few clicks without expertise and if it does not work, then the OS should automatically go back to using Nouveau. There was not even a warning about the risk and danger that trying to use Nvidia provided drivers may ruin the installation.

While I agree that using NVidia drivers is less simple that one hopes, “ruin” is an exaggeration. An unsuccessful NVidia driver installation should be reversible with little difference in fuss compared to installing it. When results a black screen or other apparent boot failure, usually employing nomodeset at the Grub cmdline on retry can succeed to boot into text only mode and clean up whatever went wrong. Performing a complete new installation is usually unnecessary.

Before installing the non-FOSS driver in the first place, it’s a good idea to determine that neither the Nouveau DDX nor the default DDX (modesetting) is satisfactory. Modesetting is newer technology than nouveau, so you may wish to give it a workout before going the non-FOSS route. Enabling it can be a simple matter of removing xf86-video-nouveau.

Sometimes net installation trouble is a matter of mirror inconsistency while they are in process of updating to a new snapshot. Waiting a while for mirrors to stabilize usually works.

If 90% of users do not have the competence and knowledge to do those fixing steps, then ruined is a right word. Many don’t even have a second computer from where to search anwers from internet. For most, it is not even clear that the installation is possible to fix with some difficult to find information. If there is a guess that fixing is possible, the difficulty level is unknown.

If taking into account what users know, new installation is usually necessary in actual practice. And why would we not take user’s knowledge into account. For most people it is in practice irrelevant what is in theory possible to do if they had some information. So, giving that information is not a valid argument for why it is not too hard to accomplish for most people.

The NET install needs more things to happen without problems than the DVD install.
If you have an inconsistent network connection, the NET install should be avoided.

I’ve done a couple TW installs within the past 48 hrs, and all went well.
Could be just luck or that’s usual… There has been a Mirrorbrain problem which forced the entire world to download off the same server for awhile this past week, I don’t know but assume that problem should have been resolved by now. That might affect some people.

Bottom line is that for all installs, there is some risk that the first attempt won’t work. Maybe even a second attempt.
And, that’s under best conditions., you may have minor problems you’re not aware of that might cause bigger problems.

I don’t know that installing proprietary drivers is advisable during the initial install, the install has enough going on without having to also install the proprietary driver also. The community nouveau driver should be sufficient just to get installed and then you should be able to install the nVidia driver separately later.


Same thing happened with DVD / stick without net. Also with 15.0 ( year older version ), the same file started errors

I used custom partitioning (which I have done countless times succesfully ).

When started the stick in non-UEFI mode from boot menu and went mostly with what was suggested, it worked. It now has bios-boot and big btrfs partition along with my custom ext4. Hopefully this gives some clues about where the problem might be.

I installed nvidia driver later, not on OS install.