Tumbleweed install not detecting existing nvme disk

Hi, I’ve tried the DVD-x86_64-Snapshot iso from both 2023-03-30 and 2023-03-31 (openSUSE Tumbleweed - Get openSUSE) to install Tumbleweed on a Dell Latitude 5400 from a usb stick using dd (SDB:Live USB stick - openSUSE Wiki). Download and usb stick prep works fine, but each time during the installation when I get to the Guided Setup or Expert Partitioner, no drive is detected. The laptop uses an nvme drive in case that is part of the problem, though I only see some issue with that 7 years ago from a quick search, and fixed with a kernel update. I disabled secure boot and intel amt mode in bios just in case (is there something else in bios to be on guard about?). Any other ideas what’s going on?

Some other users have had issues with Tumbleweed install lately. This workaround worked for many.
Gecko Linux is OpenSUSE with a different install program.
Once installed if you do “sudo zypper dup” you will be exactly the same as if installed from your live USB stick.
You might try the gecko linux rolling image - it is a couple of months old but is OpenSUSE
Their Rolling is Tumbleweed
Their Static is Leap

@Observing0116 What model NVMe device is this, some could be blacklisted, some have funky controllers (WD SN series).

If you have moved to Geeko a third party build, then you need to head to their forums for support.

Secure Boot should not affect devices in the machine, it affects what can boot on the machine, in this case, the USB drive or distros installed in the internal drive (ssd/nvme/hdd).

Can you boot a Tumbleweed Live CD and share hardware information (lspci, fdisk, and else)? If not even the Live CD detects, check other places (journalctl, dmesg) to see if there are issues while detecting devices.

1 Like

Thank you all for your help! @avicenzi The Live CD gave me the answer in dmesg: “Found 1 remapped NVMe devices. Switch your BIOS from RAID to AHCI mode to use them.” I did just that and installation was successful. Great tip.