Tumbleweed install booting into grub command prompt after inputting LVM password

So I reinstalled tumbleweed with nearly default settings on my ssd yesterday (because of this issue). LVM enabled, snapshots, encryption, btrfs, etc. Did all this through guided disk partitioning without changing anything significant. I installed with kde, only removing the “games” pattern. After install everything was fine. Then today I boot up my pc and after inputting the password I am shown the default grub command prompt with no error code (see pic).

I keep rebooting over and over again and this keeps happening. I didn’t do anything to mess up grub or even update since installing, I just added amd_pstate=active and loglevel=3 through yast kernel parameters, as well as installed a few applications and changed wallpaper on kde. This has happened with 3 different TW installations for me. Does anyone know why this is happening or how to fix?

I can’t even boot into the grub menu to boot an older snapshot.

The only way I’ve managed to avoid this is by keeping /boot and /boot/efi unencrypted, but I would prefer /boot to be encrypted under lvm like opensuse does by default for better security and also to be able to boot snapshots from grub.

Does anyone know how to fix this?

When the install completed, did you reboot?

When did you add amd_pstate - during the initial install or after install was complete?

Are you using legacy BIOS or EFI boot?

I did reboot after finishing the install, yes. And the amd_pstate=active parameter was added after installing after booting into the system for the first time.

One weird thing; after trying to boot into it many times, once it worked. I then used tumbleweed for a few hours and thought i’d test rebooting it after running the 08/19/2023 snapshot, and unfortunately the issue happened again, and now it won’t boot back into the system. Not sure why this is, but at least it is capable of booting properly. Only issue is, how can I get it to do this every time rather than occasionally.

I’m using UEFI boot with legacy boot disabled

I figured out the cause of the problem… which is rather simple. Misspelling the password in the lvm prompt boots you into an empty grub prompt. This happened to me because I somehow misspelled the password during setup and so inputting the password I thought I’d entered ended up causing this issue. It was only by misspelling it by typing quickly that I could boot properly.

Rather embarrassing mistake, but at least it’s solved. I just wish there would be some indication that the reason you enter the grub prompt is due to it being the wrong password rather than just a blank grub prompt.

1 Like

One problem is that entering normal mode (which provides CLI) clears screen, so any error message before that is lost. Otherwise, grub enters CLI when it cannot open its configuration file, so if you see it, it is the strong indication that encrypted container was not unlocked.

Also, grub does not really know whether it is a wrong password or some other problem. All that grub could really say - it failed to recover encryption key.

But I fully agree, it is rather bad UX, so you may consider bug report.