tumbleweed hang after boot afteer dup

hi :slight_smile: it boots, but after the boot a black screen with an underscore at the left top of the screen
I tried to follow this thread
https://forums.opensuse.org/showthread.php/540064-any-update-keeps-tumbleweed-system-from-being-able-to-reboot
but doing this:

Scroll to the right. You will probably see “splash=silent”. Replace that string with “plymouth.enable=0”.

it doesn’t works, but it seems a better situation, the login screen appears but when I insert password it hang there with grey bullets on password
the same happen booting with the previous kernel but it seems to go more ahead and it hangs with the suse lamp
I tried to login as root but I didn’t succeed
I tried to something like …install and generate colour profiles.
how can I boot again in my tumbleweed?

My first guess would be a video driver problem. Are you using Nvidia graphics?

no, intel graphics

If available, you can boot from a working snapshot: https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha-snapper.html#sec-snapper-snapshot-boot
Note this is a Leap doc but it’s about the same for TW.

After you rollback to a working snapshot, you can zypper addlock plymouth packages, and try dup again.

It is a known issue: https://bugzilla.opensuse.org/show_bug.cgi?id=1169783

I’m not on BTRFS, I use EXT:|

I red, but it seems to me that they can boot and login i rescue mode at least, I cannot, how can I solve??

I tried the latest TW, but no prompt (is mentioned in the bug report as well) and thus I rolled back. You could try a live media and mount the drive to edit the corresponding Plymouth files.

If you’re on ext, and plymouth.enable=0 didn’t help, you could try logging in tty and removing plymouth.

a) when stuck at boot, type ctrl+alt+f1 to get to a tty, then log in as root
b) or, in grub menu, type e to edit boot parameters, append the number **3 **to the line starting with linux or linuxefi, then log in as root

Then:

zypper rm -u plymouth
zypper dup
mkinitrd

And reboot.

In any case, I’d reinstall the system with btrfs instead of ext.

For Leap, which is more stable over all, EXt4 is ok but tumbleweed changes so much and is more likely break more so the snapper on BTRFS rollback is a very good idea. :wink:

a)didn’t worked, at stuck ctrl+alt+f1 gives me the commandline login, with the “login”, so I inserted root then return and when I try to insert password I can read the inserted password and return didn’t login
b) worked the login but network didn’t so zypper dup didnt perform anything
c) I tried to login as root with gnome clessic, I succeed, I performed zypper dup but it didn’t worked
now I’m at the same point, I think to give up tumbleweed, too problematic, so I tried to use the second emergency system leap 15.1, but I met network wireless problems, so I opened anotjer thread:'(

yes I agree;), but when I installed the first time TW with btrfs my ssd disk was full after two days and didn’t boot until I deleted some tmp files from disk, so I passed to ext4:|

Perhaps a rolling release is not for you. :slight_smile:

The new snapshot of TW should be reverting Plymouth packages to 0411, thus it should work than again: https://bugzilla.opensuse.org/show_bug.cgi?id=1169783#c59

…yes, may be TW is not for me lol!, I was prepared to have a non stable release as said in
https://en.opensuse.org/Portal:Tumbleweed
“…Tumbleweed is updated once Factory’s bleeding edge software has been integrated, stabilized and tested. Tumbleweed contains the latest stable applications and is ready and reliable for daily use…”
, I didn’t expected the perfection not everything “integrated, stabilized and tested …stable applications and is ready and reliable for daily use” but at least the fundamental, boot, login, network. but it seems not:sarcastic:
I’m using the 15.1 now on another partition now, I can recovery almost everything bI hope leap 15.1 should be more stable and tested, but it has also many problems but at least boot and login works, network not too much:(

Things to try:

Verify any configuration conflicts:

sudo rpmconfigcheck

Check for errors in the journal:

sudo journalctl -b -p 0..3

Are you on wireless? Have you tried ethernet?

manythanks but I cannot login to TW:) and I was on ethernet

When you get stuck at login, switch to a tty by typing Ctrl+Alt+F1. Then login into the terminal and run the commands.

It doesn’t work, appear a “commandline” login, I insert username or root, press enter, appear the “password” word, I insert the password but it is visible when I type, usually it isn’t, indeed after pressing enter nothing happen

Ctrl-Alt-F1 is subtly different from ttys 2-6 in ways that are not necessarily apparent. Try, when anyone ever suggests Ctrl-Alt-F1, to use any of the other 5 instead, e.g. Ctrl-Alt-F3. Does root login there fail as well?

…manythanks, I didn’t know the subtle difference :slight_smile: ctrl alt f1 gives a subtle different behaviour, the first time I can insert password and it is not visible, after timeout the password result visible. at the end it seems that doesn’t works
https://susepaste.org/16647413
ciao :slight_smile: