Tumbleweed freezes upon boot after new installation

Hi all
I recently installed OpenSuse Tumbleweed on my 8 years old laptop. In the past I installed both Debian and ArchLinux on the same laptop without any issue.
Installation went fine, although at the end of the installation the laptop did not reboot. The dialog appeared, I clicked ok, waited more than 5 minutes and when nothing happened I manually reset the pc.
GRUB works fine and correctly identifies all the OS installed (Windows 10, ArchLinux and OpenSuse).
When I select OpenSuse, it starts booting but after a few seconds the messages on the screen start to be messed up, they are not left aligned anymore, and some of them overlap. It stops after a few lines, the screen is freezed with the messages printed while booting, hard disk stops spinning.
One of the last messages printed is “Reached target system initialization”
Since the laptop features both an Intel and NVIDIA GPU, I tried appending nomodeset to the boot options, but it didn’t fix the issue.
Any help is appreciated

Have you tried to select recovery mode in the grub

Yes, I forgot to mention. I tried, but it didn’t help. It can’t boot and freezes almost immediately

Is there any log I could provide to analyze the situation?
I already checked /var/log/journal but the folder is empty