Tumbleweed freezes instead of shutting down

If I shut down or reboot my laptop from KDE (Slimbook Hero), the Plasma logout greeter freezes and the system doesn’t shut down. The only way to turn it off is to hold down the power button.
I have this in the kernel log:
[ T669] systemd-journald[669]: File /var/log/journal/9bc0113e37674651bbb6b53a0cc20e20/system.journal corrupted or uncleanly shut down, renaming and replacing.

Output of inxi -Faz:
System:
  Kernel: 6.9.4-1-default arch: x86_64 bits: 64 compiler: gcc v: 13.3.0
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9.4-1-default
    root=UUID=85778f64-4d0e-456e-b03b-5e90e2fb8256 splash=silent quiet
    security=apparmor nosimplefb=1 mitigations=auto
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
    wm: kwin_wayland tools: avail: xscreensaver vt: 3 dm: SDDM Distro: openSUSE
    Tumbleweed 20240614
Machine:
  Type: Laptop System: SLIMBOOK product: HERO-RPL-RTX v: Standard
    serial: <superuser required>
  Mobo: SLIMBOOK model: HERO-RPL-RTX v: Standard
    serial: <superuser required> part-nu: HERO-RPL-RTX
    uuid: <superuser required> UEFI: American Megatrends LLC. v: N.1.03GOS04
    date: 02/02/2024
Battery:
  ID-1: BAT0 charge: 44.2 Wh (70.9%) condition: 62.3/62.3 Wh (100.0%)
    volts: 15.5 min: 15.2 model: standard type: Li-ion serial: <filter>
    status: discharging
CPU:
  Info: model: 13th Gen Intel Core i7-13620H bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
    microcode: 0x4121
  Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
    cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
    L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 520 high: 956 min/max: 400/4700:4900:3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 916 7: 400 8: 400 9: 811 10: 400 11: 400 12: 400 13: 956 14: 400
    15: 400 16: 850 bogomips: 93424
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling mitigation: Clear Register File
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS; IBPB:
    conditional; RSB filling; PBRSB-eIBRS: SW sequence; BHI: BHI_DIS_S
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Raptor Lake-P [UHD Graphics] vendor: Tongfang Hongkong
    driver: i915 v: kernel alternate: xe arch: Gen-13 process: Intel 7 (10nm)
    built: 2022+ ports: active: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:a7a8 class-ID: 0300
  Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile]
    vendor: Tongfang Hongkong driver: nvidia v: 550.90.07
    alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-04) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 8
    ports: active: none empty: DP-1,HDMI-A-1,eDP-2 bus-ID: 01:00.0
    chip-ID: 10de:28a0 class-ID: 0300
  Device-3: SunplusIT HD Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 2b7e:b651
    class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.12 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,vesa alternate: intel,nouveau,nv dri: iris
    gpu: i915,nvidia display-ID: 0
  Monitor-1: eDP-1 res: 1552x873 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: iris
    surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
    inactive: device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.0 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Graphics (RPL-P)
    device-ID: 8086:a7a8 memory: 15.18 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.283 layers: 6 device: 0 type: integrated-gpu
    name: Intel Graphics (RPL-P) driver: N/A device-ID: 8086:a7a8
    surfaces: xcb,xlib,wayland device: 1 type: discrete-gpu name: NVIDIA
    GeForce RTX 4060 Laptop GPU driver: N/A device-ID: 10de:28a0
    surfaces: xcb,xlib,wayland
Audio:
  Device-1: Intel Raptor Lake-P/U/H cAVS vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs,snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51ca class-ID: 0403
  Device-2: NVIDIA vendor: Tongfang Hongkong driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22be
    class-ID: 0403
  API: ALSA v: k6.9.4-1-default status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f1 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Tongfang Hongkong driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Info: services: NetworkManager,wpa_supplicant
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
  Local Storage: total: 1.86 TiB used: 207.87 GiB (10.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: TeamGroup model: TM8FP6002T
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: VC2S0390 temp: 40.9 C
    scheme: GPT
Partition:
  ID-1: / raw-size: 1.52 TiB size: 1.52 TiB (100.00%) used: 207.82 GiB (13.3%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 54.1 MiB (18.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.52 TiB size: 1.52 TiB (100.00%)
    used: 207.82 GiB (13.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /opt raw-size: 1.52 TiB size: 1.52 TiB (100.00%)
    used: 207.82 GiB (13.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var raw-size: 1.52 TiB size: 1.52 TiB (100.00%)
    used: 207.82 GiB (13.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p4 maj-min: 259:4
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 1512 fan-2: 1553
Info:
  Memory: total: 32 GiB note: est. available: 31.09 GiB used: 4.88 GiB (15.7%)
  Processes: 395 Power: uptime: 0h 6m states: freeze,mem,disk
    suspend: s2idle avail: deep wakeups: 0 hibernate: platform avail: shutdown,
    reboot, suspend, test_resume image: 12.4 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: flatpak pkgs: 39 Compilers: gcc: 13.3.0 Shell: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34

I’ve seen similar threads, but I didn’t find a solution. My system is up-to-date.

Where else should I look for the cause if this?

If I run sudo shutdown, I get a terminal instead of shutting down. If I press the power button from there the system reboots.

I had the same issues, but because of the Nvidia proprietary driver. I only uninstalled them, rebooted, re-installed them and resolved.

You seem to have something corrupted. I’d run some Live USB OS (even Ubuntu would be OK) with GParted and check the file systems of your partitions.