Tumbleweed freezes during boot

Multi-boot machine including Windows 10 and a few Linux distros. I have been using Manjaro as my main OS, but had installed Tumbleweed KDE, liked it, and had spent some time setting up and configuring the software I use with the intent to make Tumbleweed my principal OS. Then I inadvertantly deleted some critical stuff in Manjaro which caused my Manjaro to completely crash and I couldn’t boot back into it. When I tried to access Tumbleweed, I couldn’t boot into it either. The Tumbleweed Grub 2 menu is still accessible, with Tumbleweed as one of the choices, but if you select that it goes to the Tumbleweed Plasma splash screen and the little “I’m thinking, please wait” circle turns around for about a minute and then freezes and nothing works, requiring a hard shut down with the computer power button.

I had Timeshift set up in Manjaro with lots of snapshots and still had the Manjaro-live CD, so I was able to boot from the CD, use Timeshift to restore to a point before the crash occurred, and recover my Manjaro installation. Tried to do the same with Tumbleweed (TW), but it seems I hadn’t yet set up Timeshift in TW so I don’t have any TW snapshots to restore with. My TW installation is on a btrfs partition and I can access the files in that partition from Manjaro or from a Tumbleweed live CD. Don’t know whether that will be of any help.

I could just re-install Tumbleweed from scratch, but that would mean starting from scratch to install and configure all the software etc that I use, so I’m hoping there a way to get back into the existing installation. (Of course, I’m kicking myself for not having set up Timeshift, and that will be the first thing I will do if I can get back in, and the first thing that I will do with any new OS I install in the future.) Any advice would be very much appreciated. I’m not very experienced with Linux CLI commands, so I’m afraid that I’m going to need to be led through any commands in detail.

By the way, my computer is an Asus M32BF with integrated Raedon graphics. It has UEFI Bios.

Here is the System Information from the Manjaro System Settings app:

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.13.12-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × AMD A10-7800 Radeon R7, 12 Compute Cores 4C+8G
Memory: 10.7 GiB of RAM
Graphics Processor: AMD KAVERI

Any suggestions would be very much appreciated.

Are you able to succeed to boot your installed system via the installation media’s boot installed system menu selection?

I have two TW installations on hardware very close to what you have:

# inxi -CSy
  Host: asa88 Kernel: 5.13.12-1-default x86_64 bits: 64
  Desktop: Trinity R14.0.10 Distro: **openSUSE Tumbleweed 20210901**
  Info: Quad Core model: **AMD A10-7850K** Radeon R7 12 Compute Cores 4C+8G
  bits: 64 type: MCP cache: L2: 2 MiB
  Speed: 1700 MHz min/max: 1700/3700 MHz Core speeds (MHz): 1: 1700 2: 1697
  3: 1699 4: 1689
# inxi -Gay
  Device-1: **AMD Kaveri** [Radeon R7 Graphics] vendor: ASUSTeK driver: amdgpu
  v: kernel alternate: radeon bus-ID: 00:01.0 chip-ID: 1002:130f
  class-ID: 0300
  Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu
  unloaded: fbdev,modesetting,vesa alternate: ati display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 120 s-size: 406x254mm (16.0x10.0")
  s-diag: 479mm (18.9")
  Monitor-1: DisplayPort-0 res: 1920x1200 hz: 60 dpi: 94
  size: 519x324mm (20.4x12.8") diag: 612mm (24.1")
  OpenGL: renderer: AMD KAVERI (DRM 3.41.0 5.13.12-1-default LLVM 12.0.1)
  v: 4.6 Mesa 21.2.0 direct render: Yes

Above is from my Trinity Desktop installation, the older of the two, working just fine. I have Plasma on the newer.

I recently reported this https://bugzilla.opensuse.org/show_bug.cgi?id=1188954, so it’s possible you’re suffering the same issue.

One place to start is to upload /var/log/Xorg.0.log from your TW installation to https://paste.opensuse.org/ or https://pastebin.com/ so we can see what it has to tell us about what is or isn’t going on. This you can do from Manjaro.

On my Plasma installation, quite new, Plasma is not starting, and I’m seeing this bad news in Xorg.0.log:

(EE) AIGLX error: dlopen of /usr/lib64/dri/swrast_dri.so failed (libdrm_radeon.so.1: cannot open shared object file: No such file or directory)
(EE) AIGLX error: unable to load driver swrast
(EE) GLX: could not load software renderer

This may be because this is a minimalist installation that I haven’t finished debugging yet. Xorg pieces might still be missing.

I don’t use BTRFS, so you may need help from https://en.opensuse.org/SDB:BTRFS and/or the BTRFS man page or others here on the forums for getting your TW / filesystem mounted and proceed with diagnosis and file fetching. Normally I would say to just chroot into TW from manjaro, which would allow you to do pretty much anything you could do booting it directly. https://fedoramagazine.org/os-chroot-101-covering-btrfs-subvolumes/ seems to show how this is done.

If you get chrooted in, then you can use journalctl to search for failed entries, and fix whatever needs fixing, but first let’s see that Xorg.0.log.

I failed to install enough of Plasma before. It’s working now:

inxi -Gay
  **Device**-1: **AMD Kaveri** [Radeon R7 Graphics] vendor: ASUSTeK **driver: amdgpu**
  v: kernel alternate: radeon bus-ID: 00:01.0 chip-ID: 1002:130f
  class-ID: 0300
  **Display**: x11 server: X.Org 1.20.13 compositor: kwin_x11 **driver: loaded: amdgpu**
  unloaded: modesetting alternate: ati,fbdev,vesa
  display-ID: :0 screens: 1
  **Screen**-1: 0 s-res: **2560x2520** s-dpi: 120 s-size: 541x533mm (21.3x21.0")
  s-diag: 759mm (29.9")
  Monitor-1: HDMI-A-0 res: 2560x1080 hz: 60 dpi: 97
  size: 673x284mm (26.5x11.2") diag: 730mm (28.8")
  Monitor-2: DisplayPort-0 res: 2560x1440 hz: 60 dpi: 109
  size: 598x336mm (23.5x13.2") diag: 686mm (27")

When you stuck during boot with “circle turns around for about a minute” hit Esc button to see text output.
Tumbleweed with BTRFS creates full system snapshots - you don’t need additional stuff.