Tumbleweed: Enable Networking Virt Manager

I am running Windows 10 Technical Preview in a Virt Managed KVM under Tumbleweed host. How do I enable networking?

Hi
To what network interface on the host?

I use bridges connected direct to ethernet interfaces here…

http://thumbnails111.imagebam.com/39082/1ce4a3390811674.jpg](http://www.imagebam.com/image/1ce4a3390811674)

I want to share wireless, I’ll post a screenie when get a chance. I was looking at KVM documentation insteada Virt Manager. Doh!

By default,
When you install libvirt (including vm manager), a networking LBD (Linux Bridge Device) is set up automatically that will work with any active network connection on the Host, including wireless. Note that despite the similarity in name, a Linux Bridge Device does not necessarily mean that the networking connection is bridging mode (the virtual networking is same network as the physical network).

You can further inspect virbr0 which was already set up for you or create additional LBD configured for other types of networks (eg NAT, Host only, DHCP) in vm manager.

When you configure the Guest’s networking properties, you specify which LBD to use, as I described you should find a virbr0 already exists. You can select this, or any other LBD you may have created, the LBD determines what kind of networking will be exposed to the Guest.

Within the Guest, only a default wired connection should be configured. No changes should ever be made here except perhaps whether to configure a static address or DHCP. The <type> of networking (eg wired/wireless, NAT, bridging, etc) is not configured within the Guest, is determined by the Guest properties.

TSU

None of the networking options suffice;

http://postimg.org/image/o8kaz7se5/3af2b305/

  1. Is there some reason why you’re running a Tumbleweed Host? IMO this makes little sense unless you are researching. You alsoways want to apply the highest priority to stability for the HostOS.

  2. Pls post your “ip addr” output from your Host machine. I strongly suspect you are using an improper interface, AFAIK no usable interface should be identified with “macvtap” You should be specifying an ordinary interface name without any special attributes. I’d also ask whether you did anything custom re: macvtap. AFAIK macvtap has been a part of the standard Linux kernel for a long time now and should not be further odified.

  3. Unless something has changed in your version of vm manager or are using a different app than what I’d expect you to be using, you should not be configuing a virtual network in the screenshot you posted. To verify, post a screenshot of how vm manager first appears when it’s launched.

TSU

http://postimg.org/image/sqx7sgeil/

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 04:7d:7b:da:aa:51 brd ff:ff:ff:ff:ff:ff
3: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 7c:e9:d3:f3:7d:31 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.5/24 brd 192.168.1.255 scope global dynamic wlp1s0
       valid_lft 86177sec preferred_lft 86177sec
    inet6 fe80::7ee9:d3ff:fef3:7d31/64 scope link 
       valid_lft forever preferred_lft forever
  1. Your physical networking device(s) aren’t recognized. Your “ip addr” only describes your loopback interface, other interfaces should be described as well. Go into YAST>Network Devices and try to setup your physical NIC. This should have been done automatically during install, did you install without a NIC? How are you even configured to run Tumbleweed without a working network connection?

  2. Your vm manager doesn’t look familiar so either it’s a Tumbleweed bleeding edge implementation or a different app. Click on “Help” and if there is an “About” submenu item and then either post the results or a screenshot. Am looking for the actual app name and version.

TSU

The mystery deepens! Totally networked here, wireless & Ethernet both work reliably;

http://postimg.org/image/4xm9txukv/

Looks very different than what I expected.

No worry, I’ll be able to take a look at this in a vm shortly.

Disregard my last comment about only the loopback displayed, it appears to be an issue with displaying

 in the mobile format, the content didn't scroll to reveal the entire content. So yes, it appears that you are displaying physical interfaces but when you create your virtual network you should build the LBD on your wlp1s0 interface, not the one you showed in your earlier screenshot.

Don't know yet if you just choose a wrong interface or if you're seeing a bug.
If I can install the same virt manager app you're using, I'll be able to check it out.

TSU

While waiting on getting a test setup,

Was wondering if any LBD actually were created on your machine.
On your Host, pls post the results of

brctl show

And then repeating the command specifying the name of any device that is returned above

brctl show *devicename *

TSU

OK,
First…

I’ve verified at this point that what you’re running seems to be specific to Tumbleweed and not distributed to any of the main OSS repos.

For that reason, I’m going to request that this thread be moved to the Tumbleweed Forum.

Secondly…
I’m still interested in what you’re looking at, so will be building a special Tumbleweed machine to take a look at it.
Maybe someone in the TW Forum will already know the answer to your situation, if not I might be able to find the answer a bit later.

A basic question…
Typically in all openSUSE including TW (I assume at this point without having actually done it in TW) the proper way to install KVM is using the YAST applet “Install Hypervisor and Tools.” That should install libvirt and your choice of hypervisor (currently Xen, KVM, and user tools only for Docker) completely <and> possibly most importantly offer to create a device networking bridge device. I referred to this LBD earlier which is configured to work with <any and all> physical networks on your machine.

If you installed libvirt some other way, perhaps you should back track and use the YAST applet.

TSU

Will be movedto Tumbleweed so that Tumblewed users may be able to shed more light on this.

Is CLOSED for the moment.

Moved from Virtualisation and open again.

OK. Finally have a Tumbleweed install completed and inspected.
Result actually is that vm manager is no different than what is usual in other mainline non-Tumbleweed, I was mistaken that Tumbleweed is different, so I don’t know where you’re getting your screenshots.

Technical comment - It looks like libvirt now creates a network spanning devices, ie a main br0 device is created bound to one or more physical interfaces and then libvirt bridging devices (virbr0, virbr1, etc) are bound to chosen main bridge devices (br0 for example).Spanning is typically enabled by default, most Users wouldn’t be technically proficient enough to tread where angels do not dare…

The following assumes that the User installed libvirt by using the YAST “Install hypervisor and tools” applet. During the install, the User will be prompted whether to install a networking bridge and the User answered affirmatively and checked <both> the box for the virtualization technology (eg KVM) <and> the User Tools (which is easily overlooked but is required to get vm manager, vm install and virt install). <Not> checking the user tools box means you likely will manage your Guests by command line or use the GUI tools remotely. If the User didn’t accept the offer to have this first networking bridge setup, then all of the above needs to be setup manually which could be intimidating to a first time User.

These are the essential places in vm manager necessary for configuring virtual networking.

First, as can be expected you should start with the default page. From here, there are two places you’ll likely visit most often.

View and Manage Virtual Networks (Add, Remove, Edit)
Edit > Connection Details
Click on Virtual Networks (not Network Interfaces) tab
You should see a network named “Default” with a Device name “virbr0” configured with NAT and DHCP issuing addresses 192.168.122.2-192.168.122.254 in a Class C default network.

If you’d like to create a different network with different connection properties… eg Bridging networking, Host Only, IPv6 support… then you would click on the green “plus” in the bottom left to add a new network and add the new network. Note that you would <not> modify the network interface tab which would already be setup to work with any active physical network interface, unless you really wanted to create a bridging device that would work only with a specific interface.
Lock in your changes with the “Apply” button.

View and Manage Guest Networking Properties
Note that you first need to have a desired virtual network created (see above) although you can create a virtual network on the fly
Rt-click on an existing Guest, select “Details” - A window will then open that looks like “Connection Details”
Select the bridging device from the list on the left.
Click the “Apply” button.

Small note:
For long time Users of libvirt, it looks like virt install no longer exists (at least I don’t see it as a ready option), now there is only vm install. There used to be an “old” virt install that still had useful and sometimes more appropriate default sizing options. Now, there is only vm install and you need to carefully set every option because defaults aren’t necessarily appropriate.

And, to the OP there is no “virt manager” I can find. Only vm manager.

TSU

Forgot one other thing I noticed…
In your Windows Guest, you’ve setup your networking incorrectly.

It does not matter what the GuestOS is, you should <not> configure your networking to connect to a bridge device (or at least there is no typical need. There may be corner scenarios where you might want to do this, but only if you are a very advanced User who knows what you are doing configuring highly unusual networking).

It does not matter what kind of HostOS physical network is being used (802.3 wired, WiFi, satellite, wireless carrier, fibre, etc), an ordinary wired network will be presented to the Guest.

So, within the GuestOS you should configure a very ordinary wired connection. If you change external physical networks often as I do on my laptop, then the <only> changes you might make in the GuestOS networking properties is whether to configure a DHCP client or static address.

TSU

Probz a bug as the only options given, none work.

Managed to create a network as you guided. There was no default network so maybe I not configure network through YaST correctly when first prompted. If only the horrid screen redraws did not spoil the whole thing, regression? Was fine before now, but that is another post.

Thank you!

If you were able to create your default network manually on your own, kudos!

TSU