Tumbleweed-DVD-i586-Snapshot20201123 graphical mode fail

Hi
I have problems with graphical mode in openSUSE-Tumbleweed-DVD-i586-Snapshot20201123-Media on ASUS P3B-F motherboard
Xfce and Gnome crash in the same way, KDE hasn’t tried it yet.
It may be due to some instruction that the cpu does not support (it is very old) ???
Thanks

LOCALIZED FAIL ON DMESG:

75.364715] traps: gnome-shell[1235] trap invalid opcode ip:b6c683a2 sp:bfa51890 error:0 in libmutter-7.so.0.0.0[b6b77000+119000]
78.647719] traps: gnome-shell[1296] trap invalid opcode ip:b6c663a2 sp:bf9011d0 error:0 in libmutter-7.so.0.0.0[b6b75000+119000]
90.203122] traps: gnome-shell[1440] trap invalid opcode ip:b6de800b sp:bf86d3e4 error:0 in libmutter-clutter-7.so.0.0.0[b6d7c000+aa000]
91.083574] traps: gnome-shell[1455] trap invalid opcode ip:b6e9200b sp:bf858b24 error:0 in libmutter-clutter-7.so.0.0.0[b6e26000+aa000]
91.434270] traps: gnome-shell[1474] trap invalid opcode ip:b6dfb00b sp:bf905ff4 error:0 in libmutter-clutter-7.so.0.0.0[b6d8f000+aa000]
93.456359] rfkill: input handler disabled
100.030360] traps: gnome-session-f[1481] trap invalid opcode ip:b41f6df0 sp:bfe875a0 error:0 in librsvg-2.so.2.47.0[b3cca000+5ab000]
101.196434] rfkill: input handler enabled
114.035732] traps: gnome-shell[1715] trap invalid opcode ip:b6ca83a2 sp:bf8c9be0 error:0 in libmutter-7.so.0.0.0[b6bb7000+119000]
117.321807] traps: gnome-shell[1775] trap invalid opcode ip:b6eb700b sp:bff917d4 error:0 in libmutter-clutter-7.so.0.0.0[b6e4b000+aa000]
117.625951] traps: gnome-shell[1782] trap invalid opcode ip:b6e0900b sp:bf9f9a14 error:0 in libmutter-clutter-7.so.0.0.0[b6d9d000+aa000]
118.447237] rfkill: input handler disabled
122.330340] traps: gnome-session-f[1789] trap invalid opcode ip:b5600df0 sp:bf81da30 error:0 in librsvg-2.so.2.47.0[b50d4000+5ab000]
124.180486] rfkill: input handler enabled
127.897769] traps: gnome-shell[1947] trap invalid opcode ip:b6e1b00b sp:bfc2bd34 error:0 in libmutter-clutter-7.so.0.0.0[b6daf000+aa000]
128.216539] traps: gnome-shell[1954] trap invalid opcode ip:b6dea00b sp:bf8b1094 error:0 in libmutter-clutter-7.so.0.0.0[b6d7e000+aa000]
129.475984] rfkill: input handler disabled
132.447333] traps: gnome-session-f[1961] trap invalid opcode ip:b5605df0 sp:bfdbc900 error:0 in librsvg-2.so.2.47.0[b50d9000+5ab000]
134.384596] rfkill: input handler enabled
138.246431] traps: gnome-shell[2115] trap invalid opcode ip:b6de900b sp:bfaff114 error:0 in libmutter-clutter-7.so.0.0.0[b6d7d000+aa000]
138.548993] traps: gnome-shell[2122] trap invalid opcode ip:b6dfe00b sp:bfe01924 error:0 in libmutter-clutter-7.so.0.0.0[b6d92000+aa000]
139.384007] perf: interrupt took too long (2514 > 2500), lowering kernel.perf_event_max_sample_rate to 79500
139.395207] rfkill: input handler disabled
141.220169] rfkill: input handler enabled
142.927571] traps: gnome-session-f[2129] trap invalid opcode ip:b55f7df0 sp:bfe38130 error:0 in librsvg-2.so.2.47.0[b50cb000+5ab000]

**LSCPU:
**
Architecture: i686
CPU op-mode(s): 32-bit
Byte Order: Little Endian
Address sizes: 36 bits physical, 32 bits virtual
CPU(s): 1
On-line CPU(s) list: 0
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 8
Model name: Pentium III (Coppermine)
Stepping: 6
CPU MHz: 1002.293
BogoMIPS: 2004.58
Vulnerability Itlb multihit: KVM: Mitigation: VMX unsupported
Vulnerability L1tf: Vulnerable
Vulnerability Mds: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
Vulnerability Meltdown: Vulnerable
Vulnerability Spec store bypass: Vulnerable
Vulnerability Spectre v1: Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2: Mitigation; Full generic retpoline, STIBP disabled, RSB filling
Vulnerability Srbds: Not affected
Vulnerability Tsx async abort: Not affected
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pse36 mmx fxsr sse cpuid

DMESG:

0.000000] Linux version 5.9.8-2-default (geeko@buildhost) (gcc (SUSE Linux) 10.2.1 20201028 [revision a78cd759754c92cecbf235ac9b447dcdff6c6e2f], GNU ld (GNU Binutils; openSUSE Tumbleweed) 2.35.0.20200915-1) #1 SMP Thu Nov 12 07:43:32 UTC 2020 (ea93937)
0.000000] x86/fpu: x87 FPU will use FXSAVE
0.000000] BIOS-provided physical RAM map:
0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009e7ff] usable
0.000000] BIOS-e820: [mem 0x000000000009e800-0x000000000009ffff] reserved
0.000000] BIOS-e820: [mem 0x00000000000f0000-0x00000000000fffff] reserved
0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000003ffebfff] usable
0.000000] BIOS-e820: [mem 0x000000003ffec000-0x000000003ffeefff] ACPI data
0.000000] BIOS-e820: [mem 0x000000003ffef000-0x000000003fffefff] reserved
0.000000] BIOS-e820: [mem 0x000000003ffff000-0x000000003fffffff] ACPI NVS
0.000000] BIOS-e820: [mem 0x00000000ffff0000-0x00000000ffffffff] reserved
0.000000] Notice: NX (Execute Disable) protection missing in CPU!
0.000000] SMBIOS 2.3 present.
0.000000] DMI: System Manufacturer System Name/<P3B-F>, BIOS ASUS P3B-F ACPI BIOS Revision 1008 Beta 004 10/15/2001
0.000000] tsc: Fast TSC calibration using PIT
0.000000] tsc: Detected 1002.221 MHz processor
0.008390] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
0.008400] e820: remove [mem 0x000a0000-0x000fffff] usable
0.008419] last_pfn = 0x3ffec max_arch_pfn = 0x100000

…]
14.664341] [drm] radeon kernel modesetting enabled.
14.664528] checking generic (c8000000 300000) vs hw (c8000000 8000000)
14.664532] fb0: switching to radeondrmfb from VESA VGA
14.967650] sr 2:0:0:0: [sr0] scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
14.967660] cdrom: Uniform CD-ROM driver Revision: 3.20
14.971616] sr 2:0:0:0: Attached scsi CD-ROM sr0
15.824044] Console: switching to colour dummy device 80x25
15.824153] radeon 0000:01:00.0: vgaarb: deactivate vga console
15.828545] PCI Interrupt Link [LNKA] enabled at IRQ 11
15.828580] PCI: setting IRQ 11 as level-triggered
15.834916] [drm] initializing kernel modesetting (R350 0x1002:0x4E48 0x1002:0x0002 0x00).
15.835746] [drm] AGP mode requested: 1
15.835769] agpgart-intel 0000:00:00.0: AGP 1.0 bridge
15.835795] agpgart-intel 0000:00:00.0: putting AGP V2 device into 1x mode
15.835839] radeon 0000:01:00.0: putting AGP V2 device into 1x mode
15.835874] radeon 0000:01:00.0: GTT: 256M 0xD0000000 - 0xDFFFFFFF
15.835889] [drm] Generation 1 PCI interface in multifunction mode
15.835942] [drm] Limiting VRAM to one aperture
15.835959] radeon 0000:01:00.0: VRAM: 128M 0x00000000C8000000 - 0x00000000CFFFFFFF (128M used)
15.846714] [drm] Detected VRAM RAM=128M, BAR=128M
15.846748] [drm] RAM width 256bits DDR
15.851574] [TTM] Zone kernel: Available graphics memory: 431152 KiB
15.851613] [TTM] Zone highmem: Available graphics memory: 506892 KiB
15.851625] [TTM] Initializing pool allocator
15.851650] [TTM] Initializing DMA pool allocator
15.851742] [drm] radeon: 128M of VRAM memory ready
15.851757] [drm] radeon: 256M of GTT memory ready.
15.851853] [drm] radeon: 2 quad pipes, 1 Z pipes initialized
15.852459] radeon 0000:01:00.0: WB disabled
15.852480] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x00000000d0000000
15.866578] [drm] radeon: irq initialized.
15.866657] [drm] Loading R300 Microcode
15.881690] [drm] radeon: ring at 0x00000000D0001000
15.881757] [drm] ring test succeeded in 0 usecs
15.882111] [drm] ib test succeeded in 0 usecs
15.895319] [drm] No TV DAC info found in BIOS
15.903455] [drm] Radeon Display Connectors
15.903490] [drm] Connector 0:
15.903499] [drm] VGA-1
15.903511] [drm] DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
15.903521] [drm] Encoders:
15.903530] [drm] CRT1: INTERNAL_DAC1
15.903540] [drm] Connector 1:
15.903549] [drm] DVI-I-1
15.903557] [drm] HPD1
15.903568] [drm] DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
15.903578] [drm] Encoders:
15.903586] [drm] CRT2: INTERNAL_DAC2
15.903595] [drm] DFP1: INTERNAL_TMDS1
15.903604] [drm] Connector 2:
15.903613] [drm] SVIDEO-1
15.903620] [drm] Encoders:
15.903629] [drm] TV1: INTERNAL_DAC2
16.208769] [drm] fb mappable at 0xC8040000
16.208792] [drm] vram apper at 0xC8000000
16.208799] [drm] size 8294400
16.208806] [drm] fb depth is 24
16.208812] [drm] pitch is 7680
16.360467] fbcon: radeondrmfb (fb0) is primary device
16.427626] BTRFS: device fsid c1657a52-4d1d-4d69-b903-09e75a7d450a devid 1 transid 529 /dev/sda2 scanned by systemd-udevd (239)
16.748905] Console: switching to colour frame buffer device 240x67
16.915633] radeon 0000:01:00.0: [drm] fb0: radeondrmfb frame buffer device
16.915898] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0
…]
64.823471] NET: Registered protocol family 17
71.009737] fuse: init (API version 7.31)
75.364704] show_signal: 9 callbacks suppressed
75.364715] traps: gnome-shell[1235] trap invalid opcode ip:b6c683a2 sp:bfa51890 error:0 in libmutter-7.so.0.0.0[b6b77000+119000]
78.647719] traps: gnome-shell[1296] trap invalid opcode ip:b6c663a2 sp:bf9011d0 error:0 in libmutter-7.so.0.0.0[b6b75000+119000]
90.203122] traps: gnome-shell[1440] trap invalid opcode ip:b6de800b sp:bf86d3e4 error:0 in libmutter-clutter-7.so.0.0.0[b6d7c000+aa000]
91.083574] traps: gnome-shell[1455] trap invalid opcode ip:b6e9200b sp:bf858b24 error:0 in libmutter-clutter-7.so.0.0.0[b6e26000+aa000]
91.434270] traps: gnome-shell[1474] trap invalid opcode ip:b6dfb00b sp:bf905ff4 error:0 in libmutter-clutter-7.so.0.0.0[b6d8f000+aa000]
93.456359] rfkill: input handler disabled
100.030360] traps: gnome-session-f[1481] trap invalid opcode ip:b41f6df0 sp:bfe875a0 error:0 in librsvg-2.so.2.47.0[b3cca000+5ab000]
101.196434] rfkill: input handler enabled
114.035732] traps: gnome-shell[1715] trap invalid opcode ip:b6ca83a2 sp:bf8c9be0 error:0 in libmutter-7.so.0.0.0[b6bb7000+119000]
117.321807] traps: gnome-shell[1775] trap invalid opcode ip:b6eb700b sp:bff917d4 error:0 in libmutter-clutter-7.so.0.0.0[b6e4b000+aa000]
117.625951] traps: gnome-shell[1782] trap invalid opcode ip:b6e0900b sp:bf9f9a14 error:0 in libmutter-clutter-7.so.0.0.0[b6d9d000+aa000]
118.447237] rfkill: input handler disabled
122.330340] traps: gnome-session-f[1789] trap invalid opcode ip:b5600df0 sp:bf81da30 error:0 in librsvg-2.so.2.47.0[b50d4000+5ab000]
124.180486] rfkill: input handler enabled
127.897769] traps: gnome-shell[1947] trap invalid opcode ip:b6e1b00b sp:bfc2bd34 error:0 in libmutter-clutter-7.so.0.0.0[b6daf000+aa000]
128.216539] traps: gnome-shell[1954] trap invalid opcode ip:b6dea00b sp:bf8b1094 error:0 in libmutter-clutter-7.so.0.0.0[b6d7e000+aa000]
129.475984] rfkill: input handler disabled
132.447333] traps: gnome-session-f[1961] trap invalid opcode ip:b5605df0 sp:bfdbc900 error:0 in librsvg-2.so.2.47.0[b50d9000+5ab000]
134.384596] rfkill: input handler enabled
138.246431] traps: gnome-shell[2115] trap invalid opcode ip:b6de900b sp:bfaff114 error:0 in libmutter-clutter-7.so.0.0.0[b6d7d000+aa000]
138.548993] traps: gnome-shell[2122] trap invalid opcode ip:b6dfe00b sp:bfe01924 error:0 in libmutter-clutter-7.so.0.0.0[b6d92000+aa000]
139.384007] perf: interrupt took too long (2514 > 2500), lowering kernel.perf_event_max_sample_rate to 79500
139.395207] rfkill: input handler disabled
141.220169] rfkill: input handler enabled
142.927571] traps: gnome-session-f[2129] trap invalid opcode ip:b55f7df0 sp:bfe38130 error:0 in librsvg-2.so.2.47.0[b50cb000+5ab000]

**
LSPCI:

**
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] R350 [Radeon 9800 Series] (prog-if 00 [VGA controller])
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device 0002
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 250 (2000ns min), Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 11
Region 0: Memory at c8000000 (32-bit, prefetchable) [size=128]
Region 1: I/O ports at d800 [size=256]
Region 2: Memory at b7000000 (32-bit, non-prefetchable) [size=64]
Expansion ROM at 000c0000 [disabled] [size=128]
Capabilities: [58] AGP version 2.0
Status: RQ=80 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW+ AGP3- Rate=x1,x2
Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x1
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Kernel driver in use: radeon
Kernel modules: radeon

01:00.1 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] R350 [Radeon 9800 PRO] (Secondary)
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device 0003
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 250 (2000ns min), Cache Line Size: 32 bytes
Region 0: Memory at b8000000 (32-bit, prefetchable) [size=128]
Region 1: Memory at b6800000 (32-bit, non-prefetchable) [size=64]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-[/size][/size][/size][/size][/size][/size]

That is a possibility.

You can try reporting a bug. I think they decided some time ago to stop supporting really old hardware that lacks some newer instructions.

I thought in less than an hour’s time I could help with this. I have a 440BX/Coppermine system with TW just upgraded two weeks ago, but with MGA graphics. I stole a Radeon 9000 from a 64bit PC to put in it. It then took at least 3 hours to determine that the Radeon produces a resource conflict with the SCSI HBA that prevents the PC from loading the HBA BIOS, which prevents reaching IPL. So, I had to restore the MGA, add another PATA HD, clone the SCSI disk containing TW to it, remove the HBA, and finally reinstall the Radeon before I could boot TW. Then I dup’d to 20201127 before testing X.

When the login manager tries to load, all that ultimately paints is the background graphic. WINDOWMANAGER=/usr/bin/icewm startx produces a black screen with mouse pointer. Xorg.0.log shows no apparent problem. No apparent difference whether using kernel 5.9.10 or 5.8.15. Vttys work as expected. Replacing the Radeon with a Matrox G400 makes X work entirely as expected. Journal and dmesg suggest to me the problem is either with the interaction with X and the authentication system, or more likely, the radeon kernel driver.

https://bugzilla.opensuse.org/show_bug.cgi?id=1102737 suggests nrickert’s response may be correct. However, these CPUs are supported on Debian Stable and Testing. I reported a bug anyway, as X works when I put the MGA back in:
https://bugzilla.opensuse.org/show_bug.cgi?id=1179387

Hi.
Thank you very much for reporting my question as a bug, I didn’t know how to do it.
I think the error occurs when loading the desktop environment, maybe they have been compiled with unsupported instructions.
XavierM


lspci
 75.364715] traps: gnome-shell[1235] trap invalid opcode ip:b6c683a2 sp:bfa51890 error:0 in libmutter-7.so.0.0.0[b6b77000+119000]
 78.647719] traps: gnome-shell[1296] trap invalid opcode ip:b6c663a2 sp:bf9011d0 error:0 in libmutter-7.so.0.0.0[b6b75000+119000]
 90.203122] traps: gnome-shell[1440] trap invalid opcode ip:b6de800b sp:bf86d3e4 error:0 in libmutter-clutter-7.so.0.0.0[b6d7c000+aa000]
 91.083574] traps: gnome-shell[1455] trap invalid opcode ip:b6e9200b sp:bf858b24 error:0 in libmutter-clutter-7.so.0.0.0[b6e26000+aa000]
 91.434270] traps: gnome-shell[1474] trap invalid opcode ip:b6dfb00b sp:bf905ff4 error:0 in libmutter-clutter-7.so.0.0.0[b6d8f000+aa000]
 93.456359] rfkill: input handler disabled
 100.030360] traps: gnome-session-f[1481] trap invalid opcode ip:b41f6df0 sp:bfe875a0 error:0 in librsvg-2.so.2.47.0[b3cca000+5ab000]
 101.196434] rfkill: input handler enabled
 114.035732] traps: gnome-shell[1715] trap invalid opcode ip:b6ca83a2 sp:bf8c9be0 error:0 in libmutter-7.so.0.0.0[b6bb7000+119000]
 117.321807] traps: gnome-shell[1775] trap invalid opcode ip:b6eb700b sp:bff917d4 error:0 in libmutter-clutter-7.so.0.0.0[b6e4b000+aa000]
 117.625951] traps: gnome-shell[1782] trap invalid opcode ip:b6e0900b sp:bf9f9a14 error:0 in libmutter-clutter-7.so.0.0.0[b6d9d000+aa000]
 118.447237] rfkill: input handler disabled
 122.330340] traps: gnome-session-f[1789] trap invalid opcode ip:b5600df0 sp:bf81da30 error:0 in librsvg-2.so.2.47.0[b50d4000+5ab000]
 124.180486] rfkill: input handler enabled
 127.897769] traps: gnome-shell[1947] trap invalid opcode ip:b6e1b00b sp:bfc2bd34 error:0 in libmutter-clutter-7.so.0.0.0[b6daf000+aa000]
 128.216539] traps: gnome-shell[1954] trap invalid opcode ip:b6dea00b sp:bf8b1094 error:0 in libmutter-clutter-7.so.0.0.0[b6d7e000+aa000]
 129.475984] rfkill: input handler disabled
 132.447333] traps: gnome-session-f[1961] trap invalid opcode ip:b5605df0 sp:bfdbc900 error:0 in librsvg-2.so.2.47.0[b50d9000+5ab000]
 134.384596] rfkill: input handler enabled
 138.246431] traps: gnome-shell[2115] trap invalid opcode ip:b6de900b sp:bfaff114 error:0 in libmutter-clutter-7.so.0.0.0[b6d7d000+aa000]
 138.548993] traps: gnome-shell[2122] trap invalid opcode ip:b6dfe00b sp:bfe01924 error:0 in libmutter-clutter-7.so.0.0.0[b6d92000+aa000]
 139.384007] perf: interrupt took too long (2514 > 2500), lowering kernel.perf_event_max_sample_rate to 79500
 139.395207] rfkill: input handler disabled
 141.220169] rfkill: input handler enabled
 142.927571] traps: gnome-session-f[2129] trap invalid opcode ip:b55f7df0 sp:bfe38130 error:0 in librsvg-2.so.2.47.0[b50cb000+5ab000]

xavierM, please log onto Bugzilla and add yourself as CC to the bug report, commenting that you started this thread. That enables you to follow and participate in its resolution, responding for need for any additional information, and testing potential fixes. I need to put my Radeon back where it came from without waiting on that bug’s resolution.

done
thank you

Developers are throwing away AGP code:

https://www.phoronix.com/scan.php?page=news_item&px=AGP-Radeon-Nouveau-Drop-RFC
https://www.phoronix.com/scan.php?page=news_item&px=Radeon-AGP-GART-Disabling-Patch
https://lists.freedesktop.org/archives/dri-devel/2020-May/265527.html
https://lists.freedesktop.org/archives/amd-gfx/2020-May/049540.html
https://lists.freedesktop.org/archives/amd-gfx/2020-May/049541.html

Try to use PCI-only mode for AGP port or PCI video cards.