Tumbleweed: Cannot install chromium nor google chrome

Hi guys,

I am new here so you have to apologize if I post silly questions.
I am using openSuse tumbleweed strictly as an internet interface, so I basically do what a normal windows user does, meaning especially I am no software developer nor any kind of nerd.

My question:

I tried to install on Tumbleweed 20210817-1109.1 the chromium browser using the Yast software administration module. The result was as follows:

  • the installation went straightforward without any mistakes, but:
  • the browser does not start.

I tried several approaches (this tool some weeks) and did not manage to get the browser software started.

  • It is also not possible to download the original google-chrome browser for openSuse directly from google and install this. The package can properly be downloaded but the attempt to install creates a mistake: “Software konnte gemäß Anweisung nicht installiert werden” meaning in english something like “software could not be installed according to instruction”.

I do not know what “according to instruction” refers to nor was there any link to the mentioned instruction nor was there any possibility to trouble shoot this problem.

Additional info: Installation of chromium or google chrome was no problem with my older tumbleweed system (which was roundabout 2 years old) but occurs since I updated the system.

Does anyone have an idea or can input this behaviour to the openSuse development community?



Hi and welcome to the Forum :slight_smile:
What package did you download from google? I have it installed here on Tumbleweed, just installed the rpm via the zypper command;

zypper in google-chrome-stable_current_x86_64.rpm

I also delete the google repo and cron job created… I prefer to manually update.

Here, “chromium” is starting and running without obvious problems. It was installed from Yast some time ago. It did update yesterday.

That might be his problem. He is not installing it as root on the system in the native openSUSE way, he is installing it as user for that user (normally for testing purposes).