Tumbleweed Bootloader config issues with previous Mageia grub2 remainders

I installed Tumbleweed over an old Mageia installation (dual boot with Widows10), before that I deleted the Mageia \home partition (unfortunately not the Mageia root partition), and I did not reset the grub2 bootloader (MBR) to e.g. original Windows MBR. During the installation process Yast2 crashed or exited with errors a few times, I then retried, until it eventually worked, but some software packages couldn’t be installed, later I saw something about “change package provider from Mageia to opensuse”, this shouldn’t happen, I did not at all intend to keep the Mageia remainders. I had the impression, that the Mageia and grub2 remainders made Yast2 behaviour extremely unstable. I later tried to configure grub2 via the official Yast2 Bootloader section, again there were error messages, but it eventually worked after some tries, yet everything seemed somewhat unstable. I then completely removed the grub2 bootloader via Windows Rescue disk, replaced it with original Windows 10 MBR, deleted/formatted all linux partitions and reinstalled Tumbleweed and grub2 again. Now everything seems to be quite stable, as stable as a rolling release can get, but I really think, that someone should look into these issues.

Another minor issue with LXQt menu (system settings), I tried LXQt, they (and probably many other desktops environments) throw all the Yast2 programs into one folder, together with the other system setting tools. This makes it really hard to work with system settings, if you e.g. want to play with energy saving, screensaver, standby, etc you can hardly find the non-Yast2 setting programs in all that mess, I’ve seen this “misconfiguration” often before, it would be nice to have a subfolder “Yast2” for all the Yast2 programs only. Where would I report such an enhancement request?

If you did not reformat root partition (ie perhaps selected upgrade or not to reformat) then that would leave stuff from previous OS on root and confuse things.

If you did not replace the MBR boot code that could also lead to problems. Again might happen if upgrade was selected or the write grub to MBR box not checked for any reason.

Thing is you probably could have kept your home and just zapped the root, though the installer defaults normally are correct and should format root before installing files.

I didn’t format, since I wanted to keep the ext4 format, of course it would have been wiser to reformat it to the same format, didn’t think about it at the time. On the other hand, I didn’t expect, that without formatting remainders of the old system would be kept and stay “alive”.