Tumbleweed and Rocket Lake UHD 750

A strange incompatibility happened to me. My Tumbleweed OS works great on a Gigabyte z490m gaming x whit i5 10500. After bios update,
I put yesterday new i5 11500 Rocket Lake processor and it doesn’t start anymore, the new installation doesn’t finish and stops
on a localhost page and flashes. After this, mounted an old M.2 with Leap 15.2 already installed, it starts but the gradation remains
fixed at 1024x768. I thought the drivers for Rocket Lake gen 12 were in the latest Kernel … any ideas? (also tried LEAP 15.3 Betam same issue)

best regads from roma
alessandro

https://www.phoronix.com/scan.php?page=news_item&px=Intel-XE_LPD-Linux-Patches

Hi hi, can anyone answer? where do i find these patches and how do i can install on Tumbleweed snap 210414? (also eventually on Leap 15.2)
ciao from Italy… newbie on Suse

Intel Xe (UHD 750) is too new for Linux. To use it try

  1. TW
  2. Leap + new kernel (kernel:stable repo) + new Mesa 3D + maybe some additional patches.

Or disable it or use “nomodeset” kernel parameter.

You have Gen 12, not Gen 13 graphics: https://en.wikipedia.org/wiki/Intel_Xe .

Swapping CPU means changing builtin GPU => you need new boot image (initramfs).

Hi, thanks for reply

I use TW released April 14 latest kernel, but it doesn’t work … I can’t find patches anywhere

One way to bring such articles (with the patches they reference) to the attention of openSUSE packagers, is if your PC functionality is not working properly, then write a bug report on openSUSE’s functionality in your affected area, and note also in your bug report that its possible a fix you read in Phoronix might address the issue (and provide the appropriate link).

There is guidance here as to how to go about raising a bug report: https://en.opensuse.org/openSUSE:Submitting_bug_reports

If you refuse to create new boot image then reinstall OS.

thanks try it

is the first thing I tried, without success

I did an extreme test with win 10 and hardware everything works … it all depends on Opensuse.

I’m in a similar situation: I installed Windows just to check the hardware. And hunted down the options to use Ubuntu 20.10 with a newer kernel, newer Mesa drivers and forcing the i915 module to recognize the UHD 750 graphics. But I haven’t found a combination of newer kernel to work with either Leap 15.2 or Tumbleweed.

While Ubuntu 21.04 was just released today, I found one post that said it was still necessary to force the i915 module to load. I haven’t had a chance to try that yet.

One of the most puzzling things to me is that with a 2560 x 1440 monitor, Leap usually comes up 800x600, but occasionally 1024x768 or if I’m lucky, 1920x1080.

I would submit a bug, but it’s not clear whether this is a kernel bug, a Mesa bug, an installer bug, or all of the above. Any thoughts or guidance?

Not a bug, just not yet implemented feature.

Try these steps:

  1. Make fresh install
  2. Update kernel from kernel:stable repo
  3. Update Mesa 3D from Experimental repo
  4. Possibly you may need to add some kernel parameters

Create bug report after this steps & testing.

Sometimes I use Leap + kernel from kernel:stable repo + Mesa 3D from Experimental repo, and it works OK.

I’m sorry your experience, I thought I was the only one

What has worked for me:

  1. openSUSE-Tumbleweed-DVD-x86_64-Snapshot20210420-Media.iso

Running this alone, the system did not boot to a gui login, but I could log in as root and run startx.

  1. Add the experimental 5.12 kernel from Opensuse. I did this by going to https://software.opensuse.org/package/kernel-default, clicking the button for “show kernel-default for other distributions”, then clicking the yellow “Show experimental packages” for openSUSE Tumbleweed and selecting Kernel:Head, 5.12.rc8 and used “Expert download” to get to https://software.opensuse.org/download/package?package=kernel-default&project=Kernel%3AHEAD to display the instructions to “Add repository and install manually”.

I used the command line to add the repository (zypper addrepo https://download.opensuse.org/repositories/Kernel:HEAD/standard/Kernel:HEAD.repo) but then started YaST and “Software Management” to view the repository and using a selection on the “View” tab – not configuring repositories – to “Switch system packages”. Then under the “Package > All in This List > Update if newer version available”. This selected kernel-default and set of kernel firmware files.

  1. After rebooting, the system still did not boot to a gui login, but looking at dmesg output showed “Your graphics device 4c8a is not properly supported by the driver in this kernel version” and advised setting force_probe=4c8a. I tried adding a file to /etc/modprobe.d with the content “options i915 force_probe=4c8a” but this did not work.

Then I rebooted and manually edited the kernel command line from GRUB to add “i915.force_probe=4c8a” and booted the system.

This worked! I got the GUI login at full resolution, and glxinfo -B showed accelerated graphics. I further verified with the phoronix test suite for unigine-heaven (referenced in some other phoronix posts related to Rocket Lake) and that ran to completion. I could see some rendering artifacts which I’m ignoring, but everything is much improved.

My working assumption is that these Tumbleweed builds are still planned for inclusion with Leap 15.3, but it looks as though a 5.12 kernel will be required. But Tumbleweed has Mesa 21.0.2 which seems to have at least some UHD 750 support.

Now to edit the kernel options permanently and see if it still works.

I was also successful starting with Leap 15.2, applying all the updates, and then using the experimental version of Mesa (https://software.opensuse.org/download/package?package=Mesa&project=X11%3AXOrg) – again choosing “Add repository and install manually” and using YaST to switch vendor, rebooting and then using the experimental kernel (Kernel:HEAD:Backport) to get a 5.12.rc8 kernel for Leap 15.2, and using i915.force_probe=4c8a in the linux boot options in Grub.

https://www.phoronix.com/scan.php?page=article&item=intel-rkl-linux&num=2

With Rocket Lake, the Linux support is all in order once again. But there is one sort of exception: the Gen12 Xe Graphics might not be working out-of-the-box depending upon your kernel. When I first booted up the Rocket Lake test system with Linux 5.12 + Mesa Git previously already installed, I was startled to find accelerated graphics not working… LLVMpipe was at play. This was a big surprise given Intel’s track record and Gen12 Linux graphics support being out for a while now. Checking dmesg though quickly revealed that the PCI ID was still hidden behind the early support flag.

https://www.phoronix.net/image.php?id=intel-rkl-linux&image=intel_rocket_7_med](https://www.phoronix.com/image-viewer.php?id=intel-rkl-linux&image=intel_rocket_7_lrg)

Re-booting the system while having “i915.force_probe=4c8a” avoided the issue and accelerated graphics were quickly working. All was well on both the i5-11600K and i9-11900K processors when booting the stable Linux kernel with the force_probe option. While the patch to remove Rocket Lake from requiring the force probe has been on the mailing list for several months, as of writing it hasn’t landed in the stable upstream Linux kernel. At the moment that is queued into DRM-Next ahead of Linux 5.13… We’ll see if one of the “fixes” pull request soon removes this restriction. Some distribution kernels including the likes of Ubuntu are already carrying the patch for providing the Rocket Lake support out-of-the-box.

So long story short, the Xe Graphics are ready to go for Linux users on sufficiently new kernels/Mesa, but you may end up needing to boot with the “i915.force_probe=4c8a” option in order to enable it for the time being. Once past that initial surprise, the Rocket Lake graphics were running fine for the past several weeks with my testing using Mesa 21.1-devel from the Oibaf PPA and Linux 5.11 and 5.12 Git. Those on Mesa 21.0 should also be fine while obviously the newer the Mesa and kernel generally means more performance and greater driver support, so in cases of new hardware especially: the newer the better.

Kernel:stable is more stable than kernel:head.
With Experimental repos you will get more recent releases than with standard TW. Sometimes I got with Leap + Experimental repos kernel and Mesa 3D newer than those in TW.
Supposedly we will get good support for Intel Xe in TW within 3-4 months.
Supposedly decent support will be in kernel 5.13.