Tumbleweed and Leap 15.2: it only boots sometimes ca 50-50

i booted up leap 15.2 3 days and it did not boot then when i retied it worked and its now ahs an 505-50 % cahnce to boot i tried tumbleweed same result please advise!

forgot to mention: i completly wiped my hard drive to install tumbleweed so if it was an broken hardware driver / an driver that was unstable it would not be carried over ( also my Bluetooth is not working on tumbleweed at all but that for another thread )

As you may know “It does not work” is infamous for containing no information to work on.

The same is true for “it does not boot”. So please describe exactly what happens after you switch the system on. What do you see, how far does things go: Grub or no, etc., etc.

Remember that we can not look over your shoulder, but depend completely on your description and copied/pasted computer information.

it ether works normally or crashes onthe boot screen after grub

Press esc key as soon as the boot starts to show progress which may give a clue what hangs

actually an update fixed it on tumbleweed thank you for your attemt o help tho