tty1 to tty6 not loging on new kernel

I’m trying to access the terminals tty1 to tty6 on Leap 15.0 and it is no longer working in the newer kernel. Can anyone tell me why?

Marcus Borelli

Not if this is all you can give us as info.
Which desktop environment?
Do the vtty’s show anything?
Videocard involved?

I use Plama 5.12.6 on Leap 15.0. In the new kernel the tty1 to tty6 outside of DE is not accepting the password entry only the login name. In the previus kernel was OK.


Can you ‘su --login’ from a KDE Konsole window?

Yes. Inside de KDE konsole and konsole as root work fine. Outside the KDE do not accept write password. Login name OK but password no.

Did you perhaps install with a different keyboard layout?

If I use the previous kernel the login/password works. This never happen before.

Can you share the error message you get when attempting to provide your password?

What is returned from the following? (substitute <username> with the your actual login username)

grep <username> /etc/passwd

In kernel ended 12.22 there are not this issue. But in kernel ended 12.25 there is an issue. Inside Plasma both konsole work fine.

All I can say is this may be hardware-dependent perhaps. I’m not impacted with the two machines I have running the same kernel.

OK. Thank you for the chat.

openSUSE Leap 15.0; KDE Plasma 5

While I see no difference between the last two kernels, a difference between konsole and TTY login might mean that the “system keyboard layout” is different (or recognized as such) from the desktop keyboard layout.
For instance I see something similar in my system with EN_US system layout and IT desktop layout.
Try to check with Yast2 System Keyboard layout, or change the password so that its spelling is not dependent on layout (e.g. only lowercase letters excluding a q w z …)

Yes, I’m left wondering if the intitrd is somehow impacted here eg with the wrong vconsole keymap written in the initrd perhaps? It certainly is a corner case, as I’m not aware of other Leap 15 users being similarly affected here.

Anyway, along this line of thinking the current vconsole and x11 keymaps can be got using

localectl status

and set using

localectl set-keymap --no-convert <new-map>
  • ‘–no-convert’ option is used to prevent the Xorg keymap from being changed’
    If necessary, initird can then be updated with
dracut -f; reboot

localectl status
System Locale: LANG=pt_BR.UTF-8
VC Keymap: br-abnt2
X11 Layout: br
X11 Model: abnt2
X11 Options: terminate:ctrl_alt_bksp

The problem is on second step - password - the return is not being accepted. In login name is OK. I can use a ssh login from another machine in my local network.



And what does

su -
locatetcl status

give ?

What happens if you use CTRL-J instead of Return?


Please try the following test:

  • At a VT (tty1 … tty6) username prompt, type in the “root” password and check that the characters displayed are in fact those of root’s password.

The result:

localectl status
System Locale: LANG=pt_BR.UTF-8
VC Keymap: br-abnt2
X11 Layout: br
X11 Model: abnt2
X11 Options: terminate:ctrl_alt_bksp

It is very estrange …In previous kernel is OK. The difference is in the last kernel.

Could you explain how to view the password in your test?

Nothing happen.