Tty screen after booting up

hi i’m using a lenovo y410 lappy,it has dual core processor and intel graphics card,i have installed the kde version after booting up the opening screen with the hard disk icon appears and soon after that the screen goes black and a tty scren opens up i’ve already tried ctrl+alt+F7 it doesnt seem to be working.
P.S:i’ve been using ubuntu for ayear or so and i’m particularly new to both KDE and openSUSE.
thanka fr the help.:slight_smile:

Hello and welcome here.

You say you have installed the KDE version. But the KDE version of what? I assume openSUSE (beecause that is what these forums are about), but openSUSE has several versions. It has even several supported versions.

sorry forgot to mention that ,it’s the 12.3 latest version :slight_smile:

Hi, welcome

A couple of questions:

  • Have you tried the Advanced options - Failsafe boot?
  • Before install, did you check the download?
  • Some Intels require ‘nomodeset’ as a kernel-parameter at boot. If booting in Failsafe works, get back here with results and we’ll show you how to make things persistent.

how do you exactly boot in the failsafe mode all i can see in the advanced options are
opensuse 12.3 with linux 3.7.10-1.1-default
opensuse 12.3 with linux 3.7.10-1.1-default(recovery mode)
i have tried runing the first option it doesnt do anything i see the wallpaper and after few minutes i get a CLI

Well, it’s the other one:
opensuse 12.3 with linux 3.7.10-1.1-default(recovery mode)

If it works then, please post the file /var/log/Xorg.0.log.old !

recovery mode = failsafe = emergency mode

Because yours is only the latest of many, many of the same thing and certainly will by far not be the last,
I am building a wiki page describing the/a correct troubleshooting procedure.

It won’t be ready until tomorrow, but if you would like a head start on the main troubleshooting fixes, try the following in order

  • Disable KMS (Recovery Mode or console > YAST > /etc/sysconfig editor> search kms > enable “no kms”
    See Release Notes for background info of this setting
  • “nomodeset” setting
  • Change drivers. Beware that some changes don’t blacklist or uninstall the previous driver, primary example is nVidia > proprietary. To be safe, just removexorg.conf if it exists
rm /etc/X11/xorg.conf

If you search all my most recent postings with keywords like nvidia, gpu you’ll see posts with some detailed steps to follow, but the wiki I’m preparing will consolidate all in a page or two. Although many of my posts are nVidia GPU specific, many like the KMS setting apply to any GPU.


I’ve posted an early draft which more or less contains the “meat and potatoes” for troubleshooting Display Boot issues for 12.3 at the following

Formatting the text and page layout is still in early stages, hope to improve readability with changes
Re-sizing and ading screenshots still need to be done.

This page is intended to focus on 12.3 issues (and possibly later, depending on future changes).
Have omitted everything I could think of that is irrelevant to 12.3 and later that’s contained in the SDB (Yes, I still put the SDB link at the bottom of my page).

This page is <open> for anyone to edit however they would like (just login and you can make changes). Don’t worry about making mistakes or saying crazy things, I’m keeping copies of the page code elsewhere and openSUSE wiki allows approx 4 rollbacks “undoing” recent changes. When making changes, pls include a comment describing changes (above the “save” button).


Linlap on the Lenovo Y410 has this to say: Lenovo 3000 Y410 [Linux Laptop Wiki] (assuming that is the same hardware as what you have). It notes Intel Graphics Media Accelerator X3100 as the graphics, and suggests the Intel i810 Intel graphic module that comes with the Intel graphic driver should be used. If true, I assume that i810 selection may automatic, but I’m not certain. Possibly the i915 is being attempted.

From what I have read the i810 is part of the xorg-x11-driver-video-intel rpm that is installed by default on an openSUSE install. I hope the i810 is not necessary as I read that for ‘modesetting’ it does not work with KMS, but rather does with UMS: X.Org Wiki - IntelGraphicsDriver where of interest is the row for ‘modesetting’ .

If you were more familiar with GNU/Linux I would ask you insert and mount a USB stick, copy the content of the /var/log/Xorg.0.log file to the USB stick, unmount the stick, and then using a PC with the graphics/internet functioning, post the content of the Xorg.0.log file to SUSE Paste.

My suspicion thou, if the i810 is needed (and the i915 does not function for your hardware) is that you will need to boot with the ‘nomodeset’ or ‘x11failsafe’ boot code(s).

Sorry,for the very late reply seems that the problem was with my hard disk it was corrupt so the whole system failed anyways thanks for all the reply and support :slight_smile: