Trying to use KVM - libvirt daemon not running

I’m trying to use kvm but don’t know how.
First I installed patterns-openSUSE-kvm_server. Then I ran **vm-install **from terminal. I got error

libvirt: XML-RPC error : Failed to connect socket to ‘/var/run/libvirt/libvirt-sock’: No such file or directory
Error: Failed to open a connection to libvirt. Please verify the libvirt daemon is running.

Then I installed libvirt (it also installed few other packages). Even then while running vm-install from terminal it gives the same error message.

What should I do?

Hi
Start the libvirtd service as indicated in the error…


systemctl start libvirtd.service

If you want it to start automatically on a reboot, then enable the service.

If you continue to run into issues,
Undo everything you’ve done installing kvm and libvirt manually.

In YAST, you will find an applet “Install hypervisor and tools,” run that.
You will be given the choice to install either kvm or Xen, choose accordingly.
Continue and follow the prompts.

In general, this is the only recommended way to successfully install KVM (with libvirt) or Xen.

TSU