trying to setup wireless on laptop

I know nothing about doing it manually.
Tumbleweed KDE5 42.3
Everything I have read I haven’t been able to find or get to show up as it was described. I am sure it has to do with my lack of knowledge.
Where is the best place to find how to set up wireless?
If I run hwinfo --wlan --short as root in the konsole, nothing happens that I can see.

Trying that, I see:

# hwinfo --wlan --short
  wlan0                Dell Wireless 1506 WLAN Half Mini-Card

Note that I am not actually using that, and I haven’t even configured it since installing 42.3.

That you get no output seems to indicate that there is no suitable driver for your wireless card.

Maybe you should indicate what kind of wireless card you have. Perhaps somebody will know how to get it working.

I was able to run hwinfo --short and saw in the output that my wireless card is ‘Dell wireless 1397 wlan mini card’. Hope this helps. I have been using PCLOS Kde4 and had wireless working fine. Then I had to move from kde4 to kde5 and PCLOS kde5 was unstable on my laptop, so I went searching and openSuse seems to be stable for me. It looks and works great so far except for setting up the wireless.

I did a google search on that string. It looks as if it is a broadcom card.

Try installing the “broadcom-wl” package. You will need to use an ethernet connection for that, since wireless is not working. If you have not already added the packman repo, do that first.

Actually, you will need “broadcom-wl” and “broadcom-wl-kmp-default”.

I purchased my Dell laptop in 2010, and ran into the same problem. But, by now, my broadcom card is supported with the opensource kernel. But newer broadcom cards might need the closed source broadcom-wl driver.

Please, please. Do not tell stories were you can post what you see, so we can see it and come to our own conclusions.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.


Thanks for your help with so little information. I’m sorry, but I am not sure how to add the packman repo. Do I do it using Yast2 or from the command line?

Easiest is with

Yast → Software Repositories

Click “Add”
Check the box for “Community Repositories”
Select “Packman Repository” from the list.
Click OK
and you are done. (It will ask you to accept the GPG signing key for that repository).

I should add – that’s easiest in the sense that you don’t have to think about it. Adding from the command line is a one line command, but you have to know the details.

Great nrickert. I can do that. I am mostly a gui user.

If that solves the wifi problem I will post back and marked solved.


When I click “Community Repositories”, the next window shows List of Repositories and it has two in the list. "Main Repository (Sources) and Main Repository (Debug)

At the top of the window there is “list of Online Repositories”. Is that where I should enter “Packman Repository”?

If I select the Main Repository (Sources), then it is added to the repository list that I already have.

Post your Repo List:

zypper lr -d

Also post:

/sbin/lspci -nnk | grep -iA3 net

zypper lr -d

Repository priorities are without effect. All enabled repositories share the same priority.

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

1 | openSUSE-20170802-0 | openSUSE-20170802-0 | No | ---- | ---- | 99 | yast2 | hd:///?device=/dev/disk/by-id/usb-Kingston_DT_101_G2_0013729B67AEBA802633017A-0:0-part2 |
2 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ---- | 99 | NONE | |
3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | |
4 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | |
5 | repo-source | openSUSE-Tumbleweed-Source | No | ---- | ---- | 99 | NONE | |
6 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes | 99 | rpm-md |

My laptop doesn’t have the code thingy at the moment since I am editing this post. The original post was from my desktop and I realized I needed to do it from my laptop.

/sbin/lspci -nnk | grep -iA3 net

09:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller [11ab:4354] (rev 13)
Subsystem: Dell Device [1028:02aa]
Kernel driver in use: sky2
Kernel modules: sky2
0c:00.0 Network controller [0280]: Broadcom Limited BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb

My mistake.

I forgot that you are using Tumbleweed. The community repository list is almost empty for Tumbleweed.
So do it at the command line:

zypper ar -f -n packman packman

You will probably be prompted to trust the GPG key at some time, such as when you then use Yast to search for “broadcom-wl”.

I have gotten the packman repository installed. Then I did a search for ‘broadcom.wl’ and it showed up along with 4 or 5 other files. I clicked on ‘broakcom.wl’ and ‘broadcom-wl-kmp-default’. They installed. I rebooted and unplugged the wired internet cable. From there I am not sure what to do to get wireless going. I tried searching in Dolphin for broadcom.wl but didn’t find it. I then went back into yast2 and did a search for broadcom.wl and there were no results. Not sure what to do next.

Is the device listed in the output of:

/sbin/ifconfig -a

(this does not require root).

Is there a NetworkManager icon in your tray? If you hover over that, or click it, does it show any wifi networks?

/sbin/ifconfig -a

bash: /sbin/ifconfig: No such file or directory

There is a network icon in the tray. Of course at the present I have the internet cable plugged in. If I hover over it I get the message about being connected to a wired internet connection. If I right click it and click on ‘configure network connections’ there is only the wired connection showing. If I remove the internet cable the tray icon is red and clicking doesn’t show anything different. If I right click the icon there a red airplane showing with a box to the left If I click the box then the plane goes black but I haven’t found that clicking on anything else produces any change. I appreciate your trying to help me. In the past my wifi is found and I haven’t had much trouble getting it going.

Oops. Sorry about that.

We are suppose to use:

ip a

I installed net-tools-deprecated so that I still have “ifconfig”. I prefer the format of its output.

It looks as if WiFi is still not working. There’s probably an Fn key combination to enable/disable wifi. You can try that to see if anything changes.

Otherwise, I hope a wifi expert comes along and offers further help.

Check for a wireless node with

ip link

Also, check wireless status with

/usr/sbin/rfkill list

You may need to install the ‘rfkill’ package first.

It might pay to confirm what’s installed with

zypper se -si broadcom*

From what has been posted to this point in this thread, it looks like

  • You probably have working NIC drivers (Broadcom) installed.
  • You’re having problems locating Network Manager to configure.

So, first…
Verify that your wireless LAN NIC is recognized and working.
Easiest way is to open YaST > Network Settinhgs
and inspect the listed NICs on your default page. If your wireless NIC is listed, fine. If not, then you still have a problem.
Assuming that you do see your wireless NIC, you can either configure using YaST(not recommended because you can only configure one wireless connection which is OK for a Desktop) or use Network Manager to configure connections to multiple APs.
Assuming you want to use Network Manager, while you are in Network Settings click on the “Global Options” tab (far left) and select Network Manager in the Network Setup dropdown. Save until you exit the YaST Network Settings module.

Assuming your install is a default (no changes that might have removed Network Manager packages for example), you should see <two> network icons to the right of your panel (aka taskbar). Rt-click each one of them, one will display your network IP settings (as you posted above) and the other should enable you to “Enable Networking”(which should already be enabled) and “Edit Connections” which is what you want.


zypper se -si broadcom*

Retrieving repository 'packman' metadata .........................................[done]
Building repository 'packman' cache ..............................................[done]
Loading repository data...
Reading installed packages...

S  | Name                    | Type    | Version                     | Arch   | Repository       
i+ | broadcom-wl             | package |           | x86_64 | (System Packages)
i+ | broadcom-wl-kmp-default | package | | x86_64 | (System Packages)

Looks like it is installed.

I don’t seem to have Network Settings. I have Network Services (xinetd). Not sure what that is all about when I click on it.