Trying to print remotely, different subnet

Both PCs have:
opensuse 12.3
KDE 4.10.5 r1
CUPS 1.5.4

I have a printer attached to one printer via USB and I want to print to it from the other.
Let me see if I can give you a good picture of the network.

Printer-----PC-— wireless ----router- wired — ATT-modem-–INET
PC- wired ------------------------------------------------------^^^^^^^

10.2 can print fine, of course being directly attached.
1.10 cannot ping anything on the 10.n subnet.

The wireless router passes out DHCP addresses in the range of
It has a connection to the ATT-modem via

I’ve tried a lt of stuff about trying to get CUPS working but so far no love.

Can it be made to work ?


You would be better off putting both printers on the network so that both are visible to both PCs. To get a PC to print to a printer attached to another PC via a USB connection, you have to have a pipe between the PC’s network connection and the USB output - feasible with a bit of command line magic I suspect but not run-of-the-mill. (I used to do something similar with a laptop and a PC in the 1990s using serial connections.)

I sometimes print to another USB-attached printer connected to a Mac PC on the same LAN. (It is my fathers network and Mac which I support.) As the Mac uses CUPS and advertises the printer, I have visibility and use as soon as I’m on the network without any configuration required.

Much better picture if you can provide what kind of printer it is.
What are the features of that printer.

1.10 cannot ping anything on the 10.n subnet.

It sounds like you have a routing issue to sort out first. Once you have traffic passing between the two subnets as required, you can proceed with the CUPS configuration.

That’s what I was thinking and I don’t know how to go about sorting it out.

I think I was able to ping 1.10 from 10.2 but not the other way.
I looked at some of the settings in the firewall, even turned it off on 10.2 but it made no difference.
Hmmm, I need to try it with both firewalls off.
And now that I mention it, there is a firewall in the ATT modem.

What settings could I use in the opensuse firewall that would be the most permissive.

John Hudson, there is only 1 printer attached to PC-

the printer is a Brother HL2040.

Yes, you should check out the firewall first. Your wireless router connection (to the ATT router) should have a IP address assigned to the wired interface within the same 192.168.1.X subnet as your ethernet-attached PC, although you did not say what it was. In other words, it should be possible to ping the wireless router from the machine.

In an effort to assist, I’ll give you a couple of tutorial links that may be helpful to you:

linux4all: Sharing Linux Printers Across Multiple Subnets

IP Routing and Subnets

but before you attempt to open ports in firewalls and get CUPS working, you must satisfy yourself that you have the network routes sorted.

First of all give me the following information

  1. Is the PC with connected to ATT modem getting the address from DHCP or have you given it statically

I haven’t been deeply into this but I more than suspect CUPS will handle it all. On KDE the cups interface can be reached via program launch-utilities-manage printing.

One of the options on a printer is to share it. Past that I can’t help much but some time ago I had a problem with cups announcing a printer to the whole world via the internet and stopped it from being announced at all. These options are now on the admin page obtained as above. My recollection is that it announces them periodically but I can’t remember the interval. Wireshark should help sort that out and show you if things are actually working. A similar package used to be part of the normal distro. It can be obtained here

There are some instructional video’s on it’s home web page but it’s fairly simple to use. Just select the network interface that is being used and identify the cups transmissions.

Make of printer etc doesn’t matter. All that matters is that both function via cups. Going on normal printer installation once the set up is running it should show up on one of the cups pages but wont be shown under printers until it’s actually installed locally from that page.

:|Wish I could help more but this should head you in the right direction. CUPS is a server so shouldn’t need anything else. There may be a need to check via yast that it is fully installed etc or that other parts are needed. Going on my 12.3 install it includes all of it and just lacks bluetooth drivers.

To save keep on logging in etc to cups I always add myself to the lp group. :sarcastic:It still requests a log in when test pages are printed though but I just use my own log in.


>:( Turns out that the wireshark package wont work. Annoying as I intended to install it as it can be useful to see what is actually going on within a network.


Sorry about that. It seems it does run but needs starting as root from the console and complains about an undefined symbol but still shows the traffic.


Sorry it took so long to get back, but somehow I had my network connections messed up and it took a bit to get them straight.

Here is where I am right now and I am going to start giving them names or I will get lost. If you have a better way, let me know.
It looks like it goes one way only and I don’t know if the problem is with the ATT side or Netgear. I bet ATT and am going to read a bit more on it.
I promise that I won’t touch it unless ordered to.
My marriage might depend on this so please try your best. rotfl!

Corky = 10.2<-----static
Sunny = 1.10<-----static
ATT = and ??? <—I don;t know what I am looking at here so I tried to take a snapshot below.
Netgear = and

I had a 3rd PC that I configured to be on the 10.1 subnet. I used this to see if I had CUPS set up correctly and it was able to print to the printer on 10.2 (Corky).
So, CUPS is correct and prints remotely.

Back to the other PC, Sunny(1.10)

I can ping Sunny from Corky. So it goes from Corky to Netgear to ATT to Sunny.
I cannot ping Netgear from Sunny. It does not fail, but it gets stuck with PING ( 56(84) bytes of data. I kill it with a CTL-C after about 5 minutes. and get a message as:
710 packets transmitted, 0 received, 100% packet loss, time 708999ms

Curious in that I ran a traceroute from Sunny to Netgear and it got as far as the ATT router/modem. So it went like this:<------Sunny<-------ATT
and got no further

Sunhui-PC:~ # traceroute<-----this is the netgear router
traceroute to (, 30 hops max, 40 byte packets using UDP
1 homeportal ( 4.426 ms 5.381 ms 4.295 ms
2 homeportal ( 5.987 ms 4.837 ms 6.206 ms
Sunhui-PC:~ #

Some ATT router/modem info.

Internet Details


Firewall Status

Firewall Active

The firewall actively blocks access of unwanted activity from the Internet.
Current Applications, Pinholes and DMZ Settings: Custom


WNDR3700 is the Netgear router.

John your posts make no sense in this thread. Please start your own thread.

so you can ping from to but not vice versa.If it is the case then if your Netgear router has firewall then try pinging disabling the firewall in netgear router.

And another thing is Does your ATT modem has dhcp server functionality.

It does relate to this thread if anybody read the longer post. rotfl! looks like they didn’t. Ahhhhhhhh well.


On the other post I made perhaps the OP will read this - clicking the correct version numbers at the top of the page. The cups admin pages may set this up automatically.

Printer Sharing -

Wireshark can be used to check that there are transmissions, protocols to look for are mentioned above. The particular type of transmission I am familiar with is depreciated.

I don’t think there is any need for static ip’s as cups uses what ever the dns service provides. Does here anyway.

This will probably help sort out a subnet - option 2 - as explained.

Router Setup: Two router setups


No, you have it backwards I can ping from 10.2 to 1.10 but not as you said above.
ATT has DHCP as does the netgear.
ATT is ~
Netgear is ~

I would expect that your Netgear wireless router ethernet port to have an IP address assigned that is in the same subnet as your PC that is connected to the ATT router. You should be able to ping that router from the machine.

If ATT has the DHCP server functionality then change the ip address of the netgear router to the same subnet ip and then disable the dhcp server in netgear router so that you get the ip address from the ATT router to your other subnet PC also i.e the PC connected to netgear router

Thank you for your suggestion, but I had set them up as separate for a reason and I prefer to keep them that way.
From what I have read, it should be doable and I am going to keep trying. It certainly serves as a learning experience.

Did I ever mention that network configuring is a work of the devil ?>:)