Trying to install rocm and get Blender to recognize my vid card correctly

What I am using:

After making sure I have only one version installed of all files (I cleaned up from a previous attempt)

I have through yast installed:

rocminfo4.0.0 - Radeon Open Compute (ROCm) Runtime rocminfo tool

But then:


guus@linux-2ls4:~> clinfo 
Number of platforms                               0 

guus@linux-2ls4:~> /opt/rocm-4.4.0/bin/rocminfo      
bash: /opt/rocm-4.4.0/bin/rocminfo: No such file or directory


So can you confirm your motherboard slot is PCI 3.0 and support Atomics, as per the requirements, plus it’s an unsupported card… did you look at a BIOS upgrade for the card?

Tried the 4.0.1 version… it likes my CPU… no GPU… happy with amdgpu-pro…


ROCk module is loaded

HSA System Attributes    
Runtime Version:         1.1
System Timestamp Freq.:  1000.000000MHz
Sig. Max Wait Duration:  18446744073709551615 (0xFFFFFFFFFFFFFFFF) (timestamp count)
Machine Model:           LARGE                              
System Endianness:       LITTLE                             

HSA Agents               
Agent 1                  
  Name:                    Intel(R) Xeon(R) CPU E3-1245 V2 @ 3.40GHz

/opt/amdgpu-pro/bin/clinfo | egrep "Version:|version"

  Platform Version:         OpenCL 1.2 CUDA 11.2.136
  Platform Version:         OpenCL 2.1 AMD-APP (3180.7)
  Device OpenCL C version:  OpenCL C 1.2 
  Driver version:           460.39
  Version:                  OpenCL 1.2 CUDA
  Device OpenCL C version:  OpenCL C 1.2 
  Driver version:           3180.7
  Version:                  OpenCL 1.2 AMD-APP (3180.7)

ROCm instruction need update:

IMHO using amdgpu-pro headless is much easier.

Or simply switch to nVidia cards.

Those instructions are for an old version, zypper points to 4.0.0.

Worked witth ROCm 3.10, which is previous to 4.0.

On windows 10 (pc is dual boot) Blender recognizes my vid card right.

That how I understand its driver related.

Can I do that on tumbleweed ?

I do not understand this part:

  • Update lib path (if necessary). ROCm 3.5 is installed under “/opt/rocm-3.5.x”. Create a symbolic link “/opt/rocm -> /opt/rocm-3.5.1”. Check the lib path in /etc/ and make sure these are listed

I think I understand I need to make a file, but not were ?

What drivers for you AMD GPU are you using on Windows, not ROCm?

Sure, just download the amdgpu-pro-20.40-1147287-sle-15.2.tar.xz, extract it, switch to root user and change to the directory and run the installer…

For example

cd /stuff/repositories/AMD_work/

tar -xf amdgpu-pro-20.40-1147287-sle-15.2.tar.xz

amdgpu-pro-20.40-1147287-sle-15.2  amdgpu-pro-20.40-1147287-sle-15.2.tar.xz

su -

cd /stuff/repositories/AMD_work/amdgpu-pro-20.40-1147287-sle-15.2/
./amdgpu-install --opencl=legacy,pal --headless --no-dkms

With that advice you create folder /opt/rocm which contains all the same as in /opt/rocm-#.
It is useful to maintain system with standard path /opt/rocm.

But maybe it is easier to use that way: .

For TW:
ILL you are downgrading amdgpu drivers with this way by installing Leap 15.2-like drivers in TW.
Try to use this: .
Or install ROCm for upstream kernel drivers.

No, not using the driver (dkms), using kernel driver…

But you are installing libdrm-amdgpu?

Yes, it’s a userspace library…

ldd /usr/bin/blender | grep drm => /usr/lib64/ (0x00007f2a9ff0b000) => /opt/amdgpu/lib64/ (0x00007f2a9fcf2000)

To be honest no idea. I doubt they are the rocm ones, just the default drivers for windows from AMD.

On windows , probably because of the gamer in me, the first thing after windows install is to install the amd drivers.

I can boot windows 10 and see exactly what driver I have installed, if that is use full ?

Likely just the AMD ones, I would just install opencl as indicated and move on :wink:

Thank you, I will have a look.

I have this feeling there is still a file pointing to 3.5 or some other version.
Although this might not be the main problem, I do remember creating at least one file. Also gonna have a look in , I think its called user dev.
Its were I have also placed a file to get my mouse under control.

The only part I did understand about this for tumble weed.
Install part of the proprietary AMD drivers (the rocm part) besides? on top of ? the opensource dirvers, and disable mesa opencl.

After this I keep getting confused, because it sounds so easy, how hard can it be :wink:

According to YAST, I am not using mesa opencl anymore, because its not installed.
So I must be using some part of rocm already ?

The only place I would check is /etc/ but all should be removed on uninstall of rocm…