trying to install leap 15.0 over leap42.3

Still having problems with install problems on machine 3000 miles from me.

Originally I made this PC with Leap 42.3 on it and sent it to her working. Few months later it crashed first running firefox, the screen would just go black and nothing she could worked to bring it back except forced shutdown and reboot then it would work again for a few minutes and same thing. I had her open a terminal and as root do zypper up. Next boot it crashed to black screen immediately after GUI desktop (plasma KDE) showed. I had her use flashdrive gecko linux and told her back everything up from her NTFS partition in case we heve to take drastic steps. She has been running off this flashdrive now for almost a year. During that time I made a USB with leap 15.0 on it and tested it by installing to my machine which is identical to hers. It worked perfectly for me. Sent it to her and it crashed just before writing partition table step.

We did do a fsck-ext4 from the flashdrive running gecko and it said her ext4 partition on the PC was ok.

I know leap 15.0 complains if you choose ext4 instead of btrfs but afaik btrfs just fills your disk with useless snapshots which is why we stayed with ext4.

So what else can I do to instruct her on how to fix her linux partition with a working copy of some sort. I don’t know what to try at all. Leap 42.3 is dead, Leap 15.0 is dead, and her internet connection is so slow iso downloads take a long time and usually fail near the end.

I normally use “ext4”. The installer doesn’t actually complain. But it isn’t completely obvious how to select “ext4”.

That you are dealing with a computer that is 3000 miles away does make it harder.

Does still describe the layout of her PC? How much different is it from yours? When were these PCs new? Former use of 11.2 suggests 10 year old hardware. All the trouble she is having could indicate quirky or old hardware is a factor, even failing old RAM if the GPU is onboard sharing system RAM.

Please show input and output from

inxi -Gxxbaz

run on yours in Konsole using code tags. Inxi is available from OSS repos, but a much improved much newer version is available directly from its author. It’s simply a relevant information gathering script, about 650kb.

Is changing its HD a simple enough procedure that you could configure a new HD on yours, ship it to her, have her replace hers, then connect her old one via USB adapter or enclosure to copy her data from? 1TB HDs can be had for well under $50 any more. For less than another $10, 2TB can be had.

Alternately, have her take hers out and send it to you to get it reconfigured on yours. Sounds like maybe a third PC between the two of you would be a good plan if HD changes aren’t doable. With most desktops made in the past decade or more, HD changes have been rather simple to do, often without need even for a screwdriver.

it’s been so many years and so many systems. Our two systems (laptops acer aspire 64 bit e1 type) were set up 4 years ago when she lost her k6 then her k7 then her toshiba laptop and in despiration we got identical pc’s then she had a problem with leap 42.1 I think and we upgraded to leap 42.2 then to 42.3. My acer has given no trouble at all. But she is non-technical and I tired of constantly having to rebuild windows so on these machines I set linux with virtualbox to run her windows and keep a copy so that if windows crashes as it always seems to do she in a few keystrokes resore with a fresh copy. Vut for the past year we ahve had to use the flash drive because I can’t seem to talk her through re-installing a fresh linux.

Yes same machine and set-up. she said she did upgrade=1 and it didn’t work then she wouldn’t talk to for weeks. I asked her about sending me her harddrive so i could fix it and she no way then she won’t have any system working or not. I’ve working systems for 45 years and now I am thinking it was all in vein as I don’t know enough to get hers going.

Hers is running 42.3 and mine is running 15.0 upgraded from 42.3. I needed a new software program and it wasn’t availaable from repos so I upgraded so I could get it. but we were having such trouble with hers that I sent a flashdrive installer of leap 15.0 figureing to just replace her hardidsk linux partition leaving her NTFS alone but she said it got to the partition screen and froze so she rebooted and this it didn’t even start.

Where is 3,000 miles from Alberta? Bangor? Miami? Bermuda? Maybe a nearby openSUSE geek could be found to assist.

She is in Augusta Maine. But after 17yrs of working with her I really don’t think I would wish adding stress to an unsuspecting opensuse geek. I did have another thought, I have a spare 1tb drive in a case. how would I clone my system with a few modifications that are different at my end such she could boot to Linux on the external or swap the drives and have it work? I have 2 printers and scanner and graphics drawing pad that differs from her printer/scanner at her end?

Hmm, guess I should update my system from 15.0 to 15.1 then look at cloning it and testing it. Make sure all packages and documentation is up to date. Remove anything that she will never need from the clone.

Looks like a workable plan to me.