Trying to install Falkon wrecked my KDE desktop I think

A friend on Linux, was talking about Falkon.

I wanted to try it and ended up here:


Yast started and asked for the root password.

During the install of Falcon yast suggested a Vendor change.
I am deeply regretting, and typing this on windows 7 , that I said yes to that vendor change.

First signs of trouble KDE pop messages that something had crashed.
I could not even restart the computer the normal way, nor could I any more open the console from KDE.

ctrl + alt + F1 and that way still works.

I rebooted the pc, and now can’t log in anymore.

When I reboot, I get the familiar grub screen were I can choose opensuse ( default ) or win 7.

Then I get the login screen but then the problems start.

Mouse works but as soon as I hit any key on my keyboard the text input box seems to freeze.
Trying to use that other desktop from the login screen, gives the same result.

I can login but only through the commandline after ctrl + alt + F1 .

I already tried going into yast from the command line by typing YAST, but I can’t find how to switch (back) to a different vendor.

While typing this, I wonder, should I have typed YAST2

How to clean up this mess?
I already un-installed Falkon through YAST from the commandline, but that did not fix anything.
( probably because is does not undo the vendor change )

In 42.3, you could install “qupzilla”.

Relatively recently, “qupzilla” was renamed as “falkon”. With “qupzilla” in 42.3, you would be getting a slighly earlier version of “falkon”.

You should be able to still boot into your system. When you get the grub menu, hit the ‘e’ key. Then scroll down to the line that begins “linux” (or could be “linuxefi”). Hit the END key, and append " 3" to the end of that line.

That should get you get in as root with a command line.

Once in, run Yast Software Repositories. And disable or remove those additional repos that you added.

If you have been using the “packman” repo, then set the repo priority for “packman” to a lower number than the 99 default value. I use 97 for “packman”.

Save those changes.

Then, at the command line (as root):

zypper dup

That should fix most of your problems. In particular, it should switch important libraries back to the standard repos, instead of the repo that you used for “falkon”.

Thank you will give it a try, and report back. :slight_smile:

Just removing the latest added repositories sounds easy enough.

I removed the mrbadguy repository and then did zypper dup.

That almost fixed everything. :slight_smile:

I can log in again through the desktop, but there is something weird to me, at the login screen.

First I don’t see the login screen, but some screen were I can add text with the mouse.
I need to click an keyboard icon to make it go away. Then I see the normal login screen.

Had also some other issue with icons, but fixed that.


This post might have the solution for me:

The virtual keyboard is gone, all is as it was before.

Thank you for the help. :slight_smile:

Looking back I probably should have disabled more repositories before I did zypper dup, but more important all is working fine again.

I’m glad to hear that things are back to working again.

Thanks for reporting back.