trying to install extcalc

I have been looking for a good versatile scientific calculator
application, and ran across extcalc on sourceforge. (I tried pgcalc, but
it seems to have some bugs and gives the wrong answers for trig
functions - haven’t had time to file a bug report)

The readme file on extcalc says that I need to have the following
installed before compiling and making the binary file:


GCC 4
QT4.3 or higher
OpenGL
cmake

I have gcc, and I installed cmake. I am running KDE, so I have various
qt packages installed, but I could not find in the repositories a
package that was just “qt4.3” or higher.
Do any of the following meet the requirements?


george@tribaltrekker:~> rpm -qa | grep qt4
libqt4-4.8.4-3.6.1.x86_64
libpoppler-qt4-4-0.22.1-1.1.1.x86_64
libqt4-qt3support-32bit-4.8.4-3.6.1.x86_64
libqt4-sql-4.8.4-3.6.1.x86_64
libqt4-sql-sqlite-4.8.4-3.6.1.x86_64
python-qt4-utils-4.10-104.4.x86_64
python-qt4-4.9.6-3.2.2.x86_64
libqt4-sql-sqlite-32bit-4.8.4-3.6.1.x86_64
libyui-qt4-2.42.5-1.1.1.x86_64
libntrack-qt4-1-016-4.1.1.x86_64
pinentry-qt4-0.8.1-18.1.1.x86_64
libqt4-x11-4.8.4-3.6.1.x86_64
libqt4-sql-32bit-4.8.4-3.6.1.x86_64
libqt4-x11-32bit-4.8.4-3.6.1.x86_64
libqt4-sql-mysql-4.8.4-3.6.1.x86_64
libqt4-sql-mysql-32bit-4.8.4-3.6.1.x86_64
python-qt4-devel-4.9.6-100.24.x86_64
libqt4-devel-4.8.4-313.1.x86_64
qt4-qtscript-0.2.0-6.1.1.x86_64
libqt4-32bit-4.8.4-3.6.1.x86_64
libqt4-qt3support-4.8.4-3.6.1.x86_64

Also, as for openGL, these are the only things in the repositories I
found, none of which are installed. Would anyone know which of these I
would need?


george@tribaltrekker:~> zypper se opengl
Repository 'Downloads' is out-of-date. You can run 'zypper refresh' as
root to update it.
Loading repository data...
Reading installed packages...

S | Name               | Summary
| Type
--+--------------------+----------------------------------------------------------------+--------
| ghc-OpenGL         | Haskell OpenGL library
| package
| ghc-OpenGL-devel   | Haskell OpenGL library development files
| package
| go-Go-OpenGL       | Go bindings for OpenGL
| package
| go-Go-OpenGL-doc   | API documenation
| package
| opengl-games-utils | Utilities to check proper 3d support before
launching 3d games | package
| python-opengl      | OpenGL bindings for Python
| package



G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 2013-07-08, George Olson <golson765@no-mx.forums.novell.com> wrote:
> I have been looking for a good versatile scientific calculator
> application, and ran across extcalc on sourceforge. (I tried pgcalc, but
> it seems to have some bugs and gives the wrong answers for trig
> functions - haven’t had time to file a bug report)

Extcalc 0.9.2 is listed under the KDE 3 repo so I would install like this:


sh-4.2$ su -
sh-4.2$ zypper ar -f http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_12.3/ "KDE3"
sh-4.2$ zypper in kde3-extcalc
sh-4.2$ exit

I haven’t tried this myself, but have to admit I wonder why you need a scientific calculator given that numeric
programming is just so much more powerful nowadays.

extcalc is a graphics calculator and so excellent for trying out the formulae need for Javascript animations. That may not be what George Olson wants it for but it’s a very good reason for having it rather than a plain scientific calculator.

On 07/09/2013 04:36 AM, john hudson wrote:
>
> extcalc is a graphics calculator and so excellent for trying out the
> formulae need for Javascript animations. That may not be what George
> Olson wants it for but it’s a very good reason for having it rather than
> a plain scientific calculator.
>
>

yes, thanks… I need it for testing some devices and comparing with a
hand-held calculator that will be used in field work where I cannot
bring a pc


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 07/08/2013 09:40 PM, flymail wrote:
> On 2013-07-08, George Olson <golson765@no-mx.forums.novell.com> wrote:
>> I have been looking for a good versatile scientific calculator
>> application, and ran across extcalc on sourceforge. (I tried pgcalc, but
>> it seems to have some bugs and gives the wrong answers for trig
>> functions - haven’t had time to file a bug report)
>
> Extcalc 0.9.2 is listed under the KDE 3 repo so I would install like this:
>
>


> sh-4.2$ su -
> sh-4.2$ zypper ar -f http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_12.3/ "KDE3"
> sh-4.2$ zypper in kde3-extcalc
> sh-4.2$ exit
> 

I haven’t tried this myself, but have to admit I wonder why you need a scientific calculator given that numeric
programming is just so much more powerful nowadays.

Interesting, I was able to install it, but just like pgcalc, it had root
permissions. I ran it as root (haven’t tested the functions yet), and
here is the output:


tribaltrekker:/opt/kde3/bin # ls -l extcalc
-rwxr-xr-x 1 root root 1283640 Feb 24 15:02 extcalc
tribaltrekker:/opt/kde3/bin # ./extcalc
libpng warning: Duplicate iCCP chunk
libpng warning: Duplicate iCCP chunk
libpng warning: Duplicate iCCP chunk
libpng warning: Duplicate iCCP chunk

had the same output after changing permissions and running it as a
regular user.

Curious as to why zypper allowed an install (in 2 instances - 1 with
pgcalc and 1 with extcalc) to be installed here and only have root
permissions.


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 07/09/2013 03:11 AM, George Olson wrote:
> but just like pgcalc, it had root permissions.

your system is broken, somehow…(i say because this experience, like
the one with pgcalc is completely wrong–programs you install should
note need to be run as root)

are you (pick one) routinely/often/occasionally/never logging into
KDE (or other desktop environment) as the administrator named root?

and, in another thread you mentioned you solved the pgcalc having to
be run as root problem by “found the executable and changed the
ownership”–so, tell how you changed the ownership? (at the command
line, or with a GUI tool like Dolphin) and did you do that while
logged into the desktop environment as administrator/root?

hmmm…maybe the problem is the way you are installing…you said
earlier you are installing with zypper…so, what command line (for
example) did you use when installing extcalc?


dd
http://tinyurl.com/DD-Caveat

On 07/09/2013 12:58 PM, dd wrote:
> On 07/09/2013 03:11 AM, George Olson wrote:
>> but just like pgcalc, it had root permissions.
>
> your system is broken, somehow…(i say because this experience, like the
> one with pgcalc is completely wrong–programs you install should note
> need to be run as root)
>
> are you (pick one) routinely/often/occasionally/never logging into KDE
> (or other desktop environment) as the administrator named root?
>
> and, in another thread you mentioned you solved the pgcalc having to be
> run as root problem by “found the executable and changed the
> ownership”–so, tell how you changed the ownership? (at the command
> line, or with a GUI tool like Dolphin) and did you do that while logged
> into the desktop environment as administrator/root?
>
> hmmm…maybe the problem is the way you are installing…you said
> earlier you are installing with zypper…so, what command line (for
> example) did you use when installing extcalc?
>

In answer to your questions, here goes (and thanks for your help, as I
do want to fix my system).

I do not ever log into KDE as the administrator named root. I don’t
think I have ever done that. I typically only go to root by typing su on
a konsole.

When I changed the ownership of the executable, it was the following
command (copied from my history records) :


980  2013-07-06 10:42:51 chown george:users pgcalc
999  2013-07-09 09:08:07 chown george:users extcalc

I notice that the history records as root include a time and date stamp,
while the history records as a regular user don’t seem to have that (or
maybe you have to specify it).

Anyway, in both cases I had to go to the /opt/kde3/bin directories to
find those programs. They ran as root when I used the ./pgcalc command
from that directory (for example), and then when I changed the ownership
they ran with the same command, not as root.

Here also are the history records of the zypper commands I used to
install both programs:


913  sudo zypper in pgcalc
987  sudo zypper in kde3-extcalc

Could it be because I was using “sudo” instead of going to root to
install? That would seem strange, because I have installed a ton of
packages using “sudo zypper in”. For example, knode, which I installed
recently to have a backup to thunderbird, and knode ran just fine after
“sudo zypper in”.

In fact, here is the list of everything I have installed that way. Most
of these haven’t had any problems:


george@tribaltrekker:~> history | grep "sudo zypper in"
241  sudo zypper in -f digikam-3.1.0
275  sudo zypper in kile
302  sudo zypper in texlive-gmdoc
303  sudo zypper in texlive-gmdoc-doc texlive-gmdoc-enhance
texlive-gmdoc-enhance-doc
305  sudo zypper in texlive-imakeidx texlive-imakeidx-doc
479  sudo zypper in pdftk pdftk-qgui
697  sudo zypper in knode
722  sudo zypper in -r packman kdenlive
725  sudo zypper in -r KR410 kdenlive
726  sudo zypper install kdenlive-0.9.6-36.1.x86_64
729  sudo zypper install kdenlive-0.9.6-2.17
730  sudo zypper install --oldpackage kdenlive-0.9.6-2.17
751  sudo zypper in avidemux
831  sudo zypper in avidemux-qt
913  sudo zypper in pgcalc
928  sudo zypper in maxima kmplot wxMaxima gnuplot
930  sudo zypper in gnuplot-doc
944  sudo zypper in cmake
987  sudo zypper in kde3-extcalc


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 2013-07-09, George Olson <golson765@no-mx.forums.novell.com> wrote:
> Interesting, I was able to install it, but just like pgcalc, it had root
> permissions. I ran it as root (haven’t tested the functions yet), and
> here is the output:

Could you please output the error message you see when you attempt to the program as a regular user?

On 07/09/2013 12:50 PM, George Olson wrote:
> Could it be because I was using “sudo” instead of going to root to
> install?

maybe that is it, but i’m not sure…i know a LOT of people are
happy with “sudo zypper” but i can tell you that i have never used
it…because sudo does NOT result in a full root with a full root
environment…instead it uses the users environment with root
powers…i always use either YaST Software Management or the
following two step:


su -
zypper in pgcalc

and NOTE that dash (-) because without that dash (in openSUSE) you
still have a user environment with root powers…only with “su -”
do you finally become the real full 100% root.

last week i installed pgcalc with YaST (to see if mine would require
running as root, as did yours (it did not)) and it worked perfect
right out of the box, and i looked just now and see


linux-os114:/opt/kde3/bin # ls -hal pgcalc
-rwxr-xr-x 1 root root 447K Feb 19  2011 pgcalc*
linux-os114:/opt/kde3/bin #

where you can see that my pgcalc is still owned by root (as it should
be) and i can run it from any user command line, even without using
its full path…just ‘pgcalc’ in a terminal and it pops up…and, so
should extcalc

so??? i guess if you ran


su -
zypper in pgcalc
zypper in extcalc

you might have the same experience, without running chown.

but maybe the reason sudo worked with all of the others is none of
the others are KDE3 applications…


dd
openSUSE®, the “German Engineered Automobile” of operating systems!
http://goo.gl/PUjnL
http://tinyurl.com/DD-Caveat
http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software

On 2013-07-09, dd <DenverD@no-mx.forums.opensuse.org> wrote:
> On 07/09/2013 12:50 PM, George Olson wrote:
> so??? i guess if you ran
>


> su -
> zypper in pgcalc
> zypper in extcalc
> 

you might have the same experience, without running chown.

I can confirm that the above commands (at least for pgcalc) install correctly allowing regular users to run the program.

A similar procedure using `sudo’ gives exactly the same result.

So I can’t reproduce the problem George is having. Consequently until he actually states precisely what error message he
is seeing when he is trying to run pgcalc/extcalc as a regular user, I cannot help.

Would help to see the origianl permissions. Should be owned by root with users allowed to execute.

On 07/09/2013 07:36 PM, gogalthorp wrote:
> Would help to see the origianl permissions.

i expect the one i posted (-rwxr-xr-x 1 root root) is exactly 100%
original.


dd

That’s what I have and it opens using KDE Plasma or from the console.

On 07/10/2013 02:55 AM, dd wrote:
> On 07/09/2013 07:36 PM, gogalthorp wrote:
>> Would help to see the origianl permissions.
>
> i expect the one i posted (-rwxr-xr-x 1 root root) is exactly 100%
> original.
>
Yes, that is what it was.

I think I found the problem, though. The directory /opt/kde3/bin/ was
not in my $PATH. So I added it to the $PATH, and change the permissions
back to root:root on both extcalc and pgcalc, and they both run now, but
only from the shell.

This is how I added the directory to $PATH and then checked that it was
on there:


george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
george@tribaltrekker:~> echo $PATH
/home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/

I wonder why the directory /opt/kde3/bin/ was never automatically added
to my PATH variable? Could that be because of installing it by way of
sudo instead of su - like you said?

Also, how do I add a directory to $PATH for the KDE desktop environment?
The programs will run out of the shell now, so it seems like I only
added the /opt/kde3/bin/ directory to the $PATH that applies to the
shell. (I am using bash for my shell)


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 2013-07-11, George Olson <golson765@no-mx.forums.novell.com> wrote:
> I think I found the problem, though.

Look George. We’re not supreme beings (well maybe Andreas is). We’re not clairvoyant nor we can’t send imps or gremlins to
to behold your computer screen to see what you mean when you say `program X can only be run as root’. There may be
hackers among forum members (there’s certainly the talent) who can sneak into your computer and fiddle about with your
machine, but they wouldn’t admit it here.

So please output what you seen when you run:


sh-4.2$ extcalc

or


sh-4.2$ pgcalc

… as a regular user, having installed either program the normal way (either through YaST or zypper in).

On 07/11/2013 08:44 AM, George Olson wrote:
>


> george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
> george@tribaltrekker:~> echo $PATH
> /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/
> 

I wonder why the directory/opt/kde3/bin/ was never automatically added
to my PATH variable? Could that be because of installing it by way of
sudo instead of su - like you said?

i do not know…i looked at my path and see


/home/denverd/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin

and then look and see that /usr/X11R6/bin and /usr/games are totally
empty which i can’t explain other than i must have, while trying to
help someone here installed a game to try to help and afterwards
uninstalled the game…maybe something similar caused /opt/kde3/bin
to be created and put in the path…

i believe that ideally a correctly created rpm would not only place
the exec in the right place but also add that place to the path…

but, if i look at your path (quoted above) i see “/home/george/bin”
three times and i wonder why!! i wonder if you ran “sudo zypper
extcalc” while in /home/george/bin and zypp installed the
executable in the right place but wrongly added your current location
to the user path??

strange… i can’t answer, but someone around here can!

> Also, how do I add a directory to $PATH for the KDE desktop environment?
> The programs will run out of the shell now, so it seems like I only
> added the/opt/kde3/bin/ directory to the $PATH that applies to the
> shell. (I am using bash for my shell)

i do not understand that question. please try again. are you planning
to change your shell from bash? to what? (and why? i mean of course
you can change it to whatever you want, but moving from bash is gonna
severely reduce the number of knowledgeable helpers…)


dd
http://tinyurl.com/DD-Caveat

On 07/11/2013 06:08 PM, dd wrote:

>
>> Also, how do I add a directory to $PATH for the KDE desktop environment?
>> The programs will run out of the shell now, so it seems like I only
>> added the/opt/kde3/bin/ directory to the $PATH that applies to the
>> shell. (I am using bash for my shell)
>
> i do not understand that question. please try again. are you planning to
> change your shell from bash? to what? (and why? i mean of course you can
> change it to whatever you want, but moving from bash is gonna severely
> reduce the number of knowledgeable helpers…)
>

Sorry, not clear on that one. What I mean by that is, is there a
different PATH variable for the KDE desktop environment (kwin?) than
there is for a bash shell? I saw an older post,

http://forums.opensuse.org/english/get-technical-help-here/applications/395836-adding-directory-path.html

that specified some terms called “csh” and “tcsh”, as distinguished
differently from “.bashrc”. So I was wondering if perhaps when you are
in a bash shell, the PATH that applies to the shell is actually not the
same PATH that applies in the KDE desktop environment. If there is, I
was wondering how you change that PATH, because changing it in bash
didn’t seem to do the job for being able to run the file by clicking on
an icon. I can change the icon settings to look in the /opt/kde3/bin/
directory, for the application, but was thinking that I shouldn’t have
to do that.


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 07/11/2013 04:29 PM, flymail wrote:
> On 2013-07-11, George Olson <golson765@no-mx.forums.novell.com> wrote:
>> I think I found the problem, though.
>
> Look George. We’re not supreme beings (well maybe Andreas is). We’re not clairvoyant nor we can’t send imps or gremlins to
> to behold your computer screen to see what you mean when you say `program X can only be run as root’. There may be

hackers among forum members (there’s certainly the talent) who can sneak into your computer and fiddle about with your
machine, but they wouldn’t admit it here.

nice, lol :slight_smile:

So please output what you seen when you run:


> sh-4.2$ extcalc
> 

george@tribaltrekker:~> extcalc
If 'extcalc' is not a typo you can use command-not-found to lookup the
package that contains it, like this:
cnf extcalc

or


> sh-4.2$ pgcalc
> 

george@tribaltrekker:~> pgcalc
If 'pgcalc' is not a typo you can use command-not-found to lookup the
package that contains it, like this:
cnf pgcalc

>
> … as a regular user, having installed either program the normal way (either through YaST or zypper in).
>
>
>


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 07/11/2013 06:08 PM, dd wrote:
> On 07/11/2013 08:44 AM, George Olson wrote:

> i do not understand that question. please try again. are you planning to
> change your shell from bash? to what? (and why? i mean of course you can
> change it to whatever you want, but moving from bash is gonna severely
> reduce the number of knowledgeable helpers…)
>

Well, now I see that the issue must be something deeper. I had an
interesting thing happen - I opened up a bash console, added
/opt/kde3/bin/ to the path, and ran extcalc. It ran fine. I checked the
PATH, and /opt/kde3/bin/ was in the PATH variable. Then I exited the
shell, and reopened the shell, and extcalc would no longer run. I
checked the PATH variable again, and /opt/kde3/bin/ was no longer in the
path. It had only been added for that open session of the konsole, and
then it went back to the way it was before once I closed the konsole.

How do I add /opt/kde3/bin/ permanently to the PATH variable?

Here is how I added it before. Note that I am not adding it as root, as
it seems that root has its own PATH variable (correct me if I am wrong
on that).


george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
george@tribaltrekker:~> echo $PATH
/home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/

Then I closed the konsole, opened it up again within 5 seconds after
closing it, and checked path:


george@tribaltrekker:~> echo $PATH
/home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/

See, it’s not there!


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it

On 07/12/2013 11:44 AM, George Olson wrote:
> On 07/11/2013 06:08 PM, dd wrote:
>> On 07/11/2013 08:44 AM, George Olson wrote:
>
>> i do not understand that question. please try again. are you planning to
>> change your shell from bash? to what? (and why? i mean of course you can
>> change it to whatever you want, but moving from bash is gonna severely
>> reduce the number of knowledgeable helpers…)
>>
>
> Well, now I see that the issue must be something deeper. I had an
> interesting thing happen - I opened up a bash console, added
> /opt/kde3/bin/ to the path, and ran extcalc. It ran fine. I checked the
> PATH, and /opt/kde3/bin/ was in the PATH variable. Then I exited the
> shell, and reopened the shell, and extcalc would no longer run. I
> checked the PATH variable again, and /opt/kde3/bin/ was no longer in the
> path. It had only been added for that open session of the konsole, and
> then it went back to the way it was before once I closed the konsole.
>
> How do I add /opt/kde3/bin/ permanently to the PATH variable?
>
> Here is how I added it before. Note that I am not adding it as root, as
> it seems that root has its own PATH variable (correct me if I am wrong
> on that).
>
>


> george@tribaltrekker:~> export PATH=$PATH:/opt/kde3/bin/
> george@tribaltrekker:~> echo $PATH
> /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/:/opt/kde3/bin/
> 

Then I closed the konsole, opened it up again within 5 seconds after
closing it, and checked path:


> george@tribaltrekker:~> echo $PATH
> /home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/george/bin/:/home/george/bin/
> 

See, it’s not there!

Well, now it is there:


george@tribaltrekker:~> echo $PATH
/home/george/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/home/george/bin/:/home/george/bin/

All I did differently was reboot - I ran zypper ps and saw there were
some things that needed to be reset, so I rebooted and then opened a
konsole and checked PATH. Looks like it is in there now and this did the
trick.

Also, the file runs now from the icon without having to put the full
path in the application line. So looks like the problem is solved.

Thanks to everyone for your help!


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB
learning openSUSE and loving it