Trying to get Xen PCIBACK to work...HELP!

Ive installed Xen 3.3.1 from yast onto openSUSE 11.1. All of this works fine however I need to get PCIBACK working but am struggling at this. I have searched until the cows come home but cant find anything specific to the SUSE distro.

From what I can tell, openSUSE 11.1 / Xen 3.3.1 has pciback compiled as a module. So Ive recompiled a new initrd with pciback support and added the following line to my modprobe.conf:

options pciback hide=(00:1b:0)

When I boot the OS and look in dmesg | grep pciback I get nothing, grrrrr. I added it to the kernel line instead as pciback.hide=(00:1b.0) again nothing.

Now the wierd thing is when i added it to the kernel line and to the modprobe.conf file, I got a message saing pciback is unrecognised, followed by a message saying it was seized followed by some pci statements.

Does anyone know which is the right file to active pciback on boot?


I’m also having a hard time to get xen and pci passtrough working. I haven’t had a previous xen installation in combination with PCI passtrough so and cannot say that my current installation has worked in the past.

I think that your problem might be relatively simple. Try the following notation of pciback.hide (include 4 leading zero’s):


What I’ve tried so far is pretty much the same as you did. I first found out that pciback was compiled into the kernel. I downloaded the standard kernel (trough yast) and compiled pciback as a module. It is possible for me to see that pciback is doing its part. If it works, you get messages in your logging like:

pciback 0000:03:03.0: seizing device

The thing I cannot get to work is starting an actual domU. From all the posts I’ve read on the internet it seems that pci passtrough is broken on xen 3.3 (not sure about 3.4). Configurations that used to work on xen 3.2 are no longer working there

The errors I’m trying to fix is:

Error: pci: 0000:03:05:0: non-page-aligned MMIO BAR found

Is there somebody who has gotten this to work on openSuSE 11.1 ?

Okay… I’ve made some progress…

It seems that the MMIO problem has something to do with memory not aligned with memory pages. You should use “reassigndev=” to give the dom0 a chance to correct this problem. After adding this line all my PCI devices are visible to the domU

example of my menu.lst

title Xen – openSUSE 11.1 - (xen)
root (hd0,0)
kernel /xen-3.4.0.gz
module /vmlinuz- root=/dev/system/root resume=/dev/system/swap splash=silent showopts vga=0x314 pciback.
hide=(0000:03:03.0)(0000:03:03.1)(0000:03:05.0)(0000:03:05.1)(0000:03:05.2)(0000:03:06.0) reassigndev=0000:03:03.0,0000:03:03
module /initrd-

Notice that I now also use xen-3.4. This is of an earlier attempt to get stuff working. I think it it not neccesary.

My PCI devices still do not work. Now I have a problem with interrupts (“request for interrupt xx failed”). Don’t now how I should fix this, must look into that further.