Trying to compile driver


Im new to OpenSuse and i’m trying to install a driver for my wifi, i have compiled this driver before succesfully on Ubuntu but it won’t work in OpenSuse:

My laptop:

Fujitsu Siemens Amilo L1310G
Intel Celeron M 1.6 Ghz
Some atheros wlan card
512MB Ram

My laptop uses a software based button for activating wireless on the laptop. Thats the application wich im trying to compile.

My steps:

  1. Downloaded to tar package.
  2. Extracted it by doing “tar xvjf fsaa1655g.tar.bz2”
  3. cd fsaa1655g
  4. make

This is my output:

jurgen@linux:~> su
linux:/home/jurgen # cd fsaa1655g/
linux:/home/jurgen/fsaa1655g # make
make -C /lib/modules/ SUBDIRS=/home/jurgen/fsaa1655g modules
make[1]: Entering directory `/usr/src/linux-'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/usr/src/linux-'
make: *** [default] Error 2
linux:/home/jurgen/fsaa1655g #

I installed every GCC package possible in the package manager and make command aswell.

Hope some Suse Guru can help me :slight_smile: thanks in advance,


Do you have kernel-source & kernel-syms installed?
they must match your running kernel “uname -a”
install with Yast & then also run Online Update if you don’t have them (to get them to match
also a good idea while you are in Yast to do Patterns > C/C++ and install all that too.

If that doesn’t help get back & someone will try to help:)

Welcome to openSUSE.

I downloaded and looked at the tarball you referenced. That tarball is very old, and I doubt it will work as built.

I recommend instead you find the MS-Windows (winXP) drivers for that laptop, and try the ndiswrapper.

I can’t help re: the ndiswrapper, but there are others on this forum who can. Here are some links to a couple of stickies to get you started:
Welcome - openSUSE Forums
Additional wireless bits - openSUSE Forums

The tarball may be very old, and its not for the wifi card itself, its for turning on the radio of my wifi card, its a shitty laptop when it comes to drivers (even in Windows) but i’ve tried to download the kernel-source and kernel-syms but it says they’re not available, by the way, i am using OpenSuse 10.3, i used 11 but it didnt quite work on my laptop (very slow boot and lots of other problems)

edit: think my internet connection dropped, can’t even visit websites, i’ll keep you informed.

They should be there for openSUSE-10.3.

I’m typing this from an openSUSE-10.3 PC, and I have those two rpms.

Yeah well, i’ve been expierencing lots of problems, my keyboard stopped working all of a sudden, i solved this by adding NOACPI to grub, and my network connection seems to be up, i recieve IP and everything but i can’t browse webpages or ping my local computers.

edit: well now i am finally installing the kernel-source and kernel-syms some weird stuff is going on, also my USB mouse just stopped working, but i still got my touchpad wich is working now.

OK, well i’ve installed a newly compiled Madwifi, and i am able to see networks but i can’t connect because the radio isn’t turned on. according to the Ubuntu docs it should be like this:

This is what i did:

jurgen@linux:~/fsaa1655g> su
linux:/home/jurgen/fsaa1655g # make
make -C /lib/modules/ SUBDIRS=/home/jurgen/fsaa1655g modules
make[1]: Entering directory `/usr/src/linux-'
make -C ../../../linux- O=../linux- modules
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-'
linux:/home/jurgen/fsaa1655g # make install
su -c "install -d /lib/modules/ && install -m 644 -c fsaa1655g.ko /lib/modules/ && /sbin/depmod -a"
linux:/home/jurgen/fsaa1655g #

This should be ok because there are no errors?

next up there should be a file in /etc/modprobe.d/ that is called options.

There isn’t any so i created a new one, as i can remember from Ubuntu, there isn’t anything else in the file only:

options ath_pci rfkill=0

options fsaa1655g radio=1

Next up i should add fsaa1655g to the /etc/modules file, but the file doesn’t exist in OpenSuse (in Ubuntu it does)

So… Where is the modules file located? or what do i have to change?


What am i doing wrong? I’m beginning to get really pissed off, sometimes my mousepad and keyboard work, sometimes not when i boot with the noacpi option in grub my keyboard and mousepad seem to work, but my network connection doesn’t (allthough i get an IP-address and gateway) is there some major fix for it?

Where did you get your openSUSE-10.3 CD/DVD from?

I think you may have a bad install, or even have a failing hard drive (or bad memory). What have you done to check your hardware is still good?

Also, reference your openSUSE-10.3, … prior to your installing it, did you do an md5sum check comparing:
a. md5sum of .iso file of openSUSE-10.3 listed on openSUSE web site against,
b. md5sum of .iso file as downloaded on your harddrive against,
c. md5sum of data on your DVD when re-extracted to an .iso ?

alternatively, did you run the “media” check in the installation CD/DVD initial menu (its one of the “Fx” options)?

I’ve read about this sort of acpi behaviour with some users’s laptops.

Why not surf on your laptop model and see what you can learn?

I’ve downloaded the regular ISO from the OpenSuse webpage with KDE (3.5 i think) i’ve been trying to fix all of this, i did a memcheck and everything seems to be ok, harddrive is doing file im going to install suse 11 now, maybe that will work now, if none will work im going back to Ubuntu i think.

Don’t forget to do the md5sum check, … and also the media check BEFORE the install, else you are quite possibly wasting your time.

What’s this MD5 checking? I know what MD5 is but why check it? I’ve downloaded the ISO from the official webpage, it should be correct right?

There is more to this.

Very very often the ISO will be corrupted in the download. Or often in many cases, if the user burned the CD/DVD at a speed that was NOT the slowest speed, and burned with media that was not high quality media, or simply had an old/failing CD/DVD burner/reader for the burn or install, there will be significant problems. Please read our stickie on this: NEWBIES - Suse-11.0 Pre-installation – PLEASE READ - openSUSE Forums

The need for doing the md5sum check is also noted in various places on the Novell web site.

Every Linux distribution (even Ubuntu) recommend doing md5sum checks.

Well, ive now installed SUSE 11, wich was very slow at first but rins properly now. So thanks you guys for all the help, i’ll keep you informed when i need help again.


I just installed 11.0 om my Amilo 1655g. I used to have 10.1 working with the radio switch module fsaa1655g and ndiswrapper.
When trying to compile the fsaa1655g i get the message: No rule to make target ‘modules’ after entering /usr/src/linux-
kernel-source and kernel-syms for the running kernel are installed.
Any ideas what im doing wrong??

Thks Morten

I wonder if these different versions between running kernel and available kernel-headers might be part of the problem.

Screenshot : Free Image Host.

How can i get the kernel-headers that match my kernel??

Greetings Morten