Trying to change from KDE to Gnome desktop. Get error.

I decided to try Gnome but KDE keeps coming up.
Used Yast to load the software.
Went to etc/sysconfig editor
Went to Desktop and Display Manager and chose and DISPLAYMANAGER and chose GDM
Went to Window Manager and DEFAULT-WM and chose Gnome.
Asked if I wanted to save, said yes.
Get error “Configuration module KDM failed.” “Configuration module KDM3 failed” and "OPENSUSE WM failed. "
Even tried as root and same thing happens.
Any suggestions.

Used Yast to load the software.

Go and check you installed the gnome patterns

You can ignore this error message. It should work none-the-less.

But you don’t have to change the defaults in /etc/sysconfig/ to just try out GNOME.
You can select GNOME at the login screen instead, just click on the “Gear” symbol.
This will also be remembered for subsequent logins.

If you don’t see a login screen because you have auto-login turned on, then just logout and you should get there…

Cannot get to the gear symbol. When I log in, now get a "Welcome to linux-XRCP screen, and flies by the KDE logon where the gear is.
When I am on the desktop, xconsole is now opened which is new.
What “patterns” files do I need to install?

That’s a failsafe session.
You have to press the “Gear” before you log in.

But as I said, if you log out, you should get to the login screen again and be able to select a different session.

What “patterns” files do I need to install?

The GNOME pattern.
Open YaST->Software Repositories, select View->Patterns and enable “GNOME Desktop Environment”. All necessary packages should then be installed.

On 2013-11-12 16:06, mrjacque wrote:
>
> Cannot get to the gear symbol. When I log in, now get a "Welcome to
> linux-XRCP screen, and flies by the KDE logon where the gear is.

You have autologin active, so you have to log out and choose. However,
that might not work if you still have DISPLAYMANAGER to GDM. Please undo
those changes.

> When I am on the desktop, xconsole is now opened which is new.
> What “patterns” files do I need to install?

Yast package manager, chose to display patterns, then install the gnome
patterns.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I tried to change back to KDM and KDM4, and now cannot get any desktop to load. I get the Liunux-XRCP screen, enter my user and password, display flashes and then goes back immediately to the login screen. How do I get out of this loop?

What have you set as DISPLAYMANAGER and DEFAULT_WM now exactly?
Do you still have GNOME as default WM?

Click on the Gear symbol and select something else, at least IceWM should work.

Cannot even get to the gear. only the Linux-XRCP logon screen (User - Password) and back to that screen. How to even get to the gear?

Linux-XRCP is your host name I guess.
On the logon screen should be a “Gear” symbol if you are using KDM.
Well, if you don’t use the standard openSUSE theme, the button might look different, it may be a down-arrow or labelled “Sessions” then.

Could be you have set the DISPLAYMANAGER wrong or uninstalled KDM and are using xdm now?

Maybe post a screenshot?

I did XDM and know what it looks like. I do not get that far.
This password screen comes on,nothing on the page except “User”, and an xterminal in the bottom corner. I enter the user and “Password” comes up at a line below.
I enter both. They are correct because have tried wrong password and get a password error.
What happens next is the screen for a few seconds goes black as if to launch, then comes back to the login screen only showing User and the xterminal.
Is there some keyboard command to bring up the login menu with the gear? Do not see any other way of getting out of this loop.

Well, if you have a password screen to logon, you either have XDM, KDM or GDM.
Which one I do not know.

Please answer my questions, and I may be able to help you.

And to be sure: it should be “kdm” in /etc/sysconfig/displaymanager, not “KDM”. Upper case vs. lower case is important here.

I chose the option in the screen so it was lower case.
The screen I get says
OPENSUSE
Welcome at Linux-XRCP.site
and has a terminal screen in the bottom lower left corner with some command results.
After I try to login, the screen at the bottom says “Console login for linux-xrcp” and the splash screen now says
Welcome at Linux-XRCP

Are you in a terminal? It sound like it to me. I don’t think you are even getting to a GUI login.

Not sure how you tried to install gnome but if you did not use the patterns you did not do it right. So I’m guessing you have gnome partially installed and are missing packages that are needed.

If at a terminal prompt then you can log in as root then type yast and do the install right. note this is a text version of yast so no mouse you navigate with tab and arrow keys select with space/return

I cannot even get in using my root password. Keeps coming back to the same screen no matter what password I use.
Is there a file I can edit or delete to get me out of this endless loop?

On 2013-11-13 00:26, mrjacque wrote:
>
> I cannot even get in using my root password. Keeps coming back to the
> same screen no matter what password I use.
> Is there a file I can edit or delete to get me out of this endless loop?

Yes. As we have told you several times, you have to edit the variables
you edited on the first post and put the original values.

DISPLAYMANAGER
DEFAULT_WM

You must edit those two by whatever method you prefer to their original
values. Upper case is not the same as lower case, so be careful what you do.

If you can not get to any terminal in graphical mode, then do it in text
mode. Press the keys ctrl-alt-F1 simultaneously. Log in as “root”, and
enter your administrator password.

Then type:


joe  /etc/sysconfig/displaymanager

That’s an editor. Get to the line with “DISPLAYMANAGER” and change it
back to the original value:


DISPLAYMANAGER="kdm"

The command to exit and save is on the help, and how to reach “help” is
displayed on the first line.

Then the other file:


joe  /etc/sysconfig/windowmanager

And make sure that you have:


DEFAULT_WM="kde"

Save, and type “reboot” to reboot the machine.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Now that you told me what files to edit to change those variables, with a little work, I was able to edit them while in Ubuntu.
I am now back on OpenSUSE. Thank you.
The entries in both files was kde3. Still am trying to find out what linux-xrcp.site is that I got.

As I already wrote, that is your hostname.
It’s created randomly during installation, you can change it in YaST->Network Devices->Network Settings->Hostname/DNS if you want to.

And if you are using KDM again now, you can change it’s appearance in Configure Desktop->Login Screen.

For KDE4 this should be:

DEFAULT_WM="kde-plasma"

The name has changed quite a while ago… :wink:

On 2013-11-13 08:16, wolfi323 wrote:

> robin_listas;2597456 Wrote:

> Code:
> --------------------
> > >
> > DEFAULT_WM=“kde”
> >
> --------------------
>>>
>>
> For KDE4 this should be:
>
> Code:
> --------------------
> DEFAULT_WM=“kde-plasma”
> --------------------
>
> The name has changed quite a while ago… :wink:

Ah, right… Mine has still KDE, because the machine has been upgraded
many times, and I don’t use the full kde desktop, only some apps I like.

I did say to write there whatever it originally had. O:-)

I’ll take the chance to edit my file to modernize it :wink:


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)