trying to build sflphone for 12.1

Hi,

I’m again, against my wishes, trying to build an application. The
telephony repo for 12.1 has sflphone 0.9.12, but only the kde client,
and the common rpm is missing. Not installable. So I try to build it myself.

(how do I enter bugzillas angainst a repo? they ignore them!)

I hit the problem that “No package ‘libccrtp1’ found”, because 12.1 has
version 2.

So I download an older version and try to build it (ccrtp-1.8.0.tar.gz).
And obviously, I hit another problem:

ptrdiff_t does not name a type

Then I download the rpm sources for 11.4 (libccrtp-1.8.0-4.1.src.rpm),
hopping that they solved the problem; I try to build it and… same problem.

This one I find in google, an ubuntu page:

https://wiki.edubuntu.org/GCC4.6


ptrdiff_t does not name a type

/usr/include/sigc++-2.0/sigc++/signal.h:38:11: error: 'ptrdiff_t' does
not name a type

Fix: #include <cstddef>

So I edit “~/Compilaciones/ccrtp-1.8.0/src/ccrtp/sources.h” and add that
include. Solved? The above problem yes, but i hit a new one:


> Making all in demo
> make[1]: Entering directory `/home/carlos/Compilaciones/ccrtp-1.8.0/demo'
&gt; g++ -DHAVE_CONFIG_H -I. -I../src    -fno-strict-aliasing -Wall -ansi -pedantic -I../src -g -O2 -D_GNU_SOURCE   -c -o rtpsend.o rtpsend.cpp
&gt; /bin/sh ../libtool --tag=CXX   --mode=link g++ -fno-strict-aliasing -Wall -ansi -pedantic -I../src -g -O2 -D_GNU_SOURCE   ../src/libccrtp1.la  -o rtpsend rtpsend.o  -L/lib64 -lgcrypt -lgpg-error
&gt; libtool: link: g++ -fno-strict-aliasing -Wall -ansi -pedantic -I../src -g -O2 -D_GNU_SOURCE -o .libs/rtpsend rtpsend.o  ../src/.libs/libccrtp1.so -L/lib64 -lgcrypt -lgpg-error -pthread
&gt; /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: rtpsend.o: undefined reference to symbol 'ost::IPV4Host::IPV4Host(char const*)'
&gt; /usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: note: 'ost::IPV4Host::IPV4Host(char const*)' is defined in DSO /usr/lib64/libccgnu2-1.6.so.0 so try adding it to the linker command line
&gt; /usr/lib64/libccgnu2-1.6.so.0: could not read symbols: Invalid operation
&gt; collect2: ld returned 1 exit status
&gt; make[1]: *** [rtpsend] Error 1

And I’m stuck here. Google hints at a solution at debian, but I don’t
understand it.

http://osdir.com/ml/debian-bugs-closed/2011-04/msg01603.html

What can I do?


Cheers / Saludos
Carlos E. R.