try to use a local website


i try to run a website with opensuse 11.1, apache

under /srv/www/htdocs i have a web site (who use cakephp)

i have a .htaccess file that its content

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /app/
RewriteRule ^$ webroot/ [L]
RewriteRule ^(.*) webroot/$1 [L]

i have in /etc/apache2/default-server.conf

<Directory "/srv/www/htdocs">
        AllowOverride All
        Order allow,deny
        Allow from all
<Directory />
    Options None
    AllowOverride None
    Order deny,allow
    Deny from all

in /etc/apache2/httpd.conf

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all

# List of resources to look for when the client requests a directory
DirectoryIndex index.html index.html.var indexp.php

i add rewrite to APACHE_MODULES in /etc/sysconfig/apache2

when i start the web site i get

Apache 403 Forbidden Error

any idea?

It’s a permissions problem.
There is a solution guide here change the paths as required


Lets do it via GUI (thanks to YaST) :wink:

Go to YaSt → Network Services → HTTP Server → Main Host → Directory → Edit

Options → Edit → Change “None” to “Indexes”
Allowoverride → Edit → Change “None” to “All”
Order → Edit → Change the order from “Deny,Allow” to “Allow,Deny”
Allow → Edit → “from all”

Restart Apache.