Truecrypt 6.1a on openSUSE 11.1

Hi, I’m a new openSuse user, and I need to use Truecrypt.

I couldn’t find it through Yast, so I have installed the rpm package on truecrypts homepage, version 6.1.a.

Everything went smooth, but when I try to mount/dismount a volume, truecrypts freezes, and stops working. This happens every time.

I do not get any kind of error messages, and I have no idea of, what the problem might be?

The encrypted volumes are in NTFS file format. In Ubuntu this didn’t seem to be a problem, is this different in Suse? I use KDE4 in Suse.

Has someone experienced a similar problem, and found a solution for this?

Besides that, thumbs up, I’m very impressed with openSUSE so far :slight_smile:

  • dsbahr

I have same problem.

It’s working perfect for me in Gnome SUSE 11.1, my first guess is that this is caused by KDE

Opensuse 11.1 x64, Gnome, truecrypt 6.1a don’t work. truecrypt stop when mount disk. It’s the same when is an external or internal disk.

Same for me !

A fix please :’(

Try contacting truecrypt about this, as it’s likely the problem is on their end. (Or they can find what in OS is causing it exactly to be fixed). I believe their unusual license clause prevents opensuse inclusion, so it wouldn’t hurt to bug them about that too – then opensuse could ensure compatibility directly :smiley:

Same problem. Truecrypt 6.1a doesn’t work on openSUSE 11.1 x64. But works perfectly on Ubuntu 8.10 x64 with the same kernel version (

Truecrypt 6.1a works fine for me on openSUSE 11.1 64-bit. I’m using a FAT volume (so I can use it on Windows too).

Working fine for me as well with the same setup as your’s.

I think the problem is the NTFS-Container!
When i create one container, i have only the possibility to select FAT, ext2 or ext3. And when i create one in FAT it is possible to use. The only thing is with my old container in NTFS.
Why i can not select NTFS when creating a container?

Greetings and Merry Xmas

so i have the solution:

The problem is the NTFS-3G DRIVER (v1.5012)!
I update the driver from this repository: Index of /repositories/home:/anubisg1/openSUSE_11.0

to the newest stable version 1.5130 and it works perfekt! :wink:

Greetings and Merry Christmas


PS: please tell if it is also working for you!

Upgrading to the NTFS-3G rpm in the repository you identified fixed the problem for me. It is NTFS specific as I also had no problems mounting from FAT volumes.

A workaround that works for me:

When mounting a NTFS truecrypt file, select under the mount options “Filesystem: Do not mount”
With that the truecrypt file is mounted to /dev/mapper/truecrypt1, however the filesystem is not mounted.

After that it is possible to mount the NTFS filesystem with
sudo ntfs-3g /dev/mapper/truecrypt1 /media/truecrypt -o user,gid=100,fmask=113,dmask=002

(Before mounting, /media/truecrypt must be created with sudo mkdir /media/truecrypt

it still doesn’t work for me, i mean when trying “do not mount” option and mounting it by the hand, mount still hangs (if i use only mount command),
if you use /bin/ntfs-3g or /sbin/mount.ntfs-3g (symlink to /bin/ntfs-3g) it works, in every ntfs-3g version, but if you make a symlink from /bin/ntfs-3g to /sbin/mount.ntfs*

mount /dev/mapper/truecrypt1 /media/truecrypt1 -o rw,noexec,nosuid,nodev,users,noatime,gid=100,fmask=133,dmask=022,locale=pl_PL.UTF-8,debug

will hang with something like this in ps fax:

12662 pts/0    S+     0:00  |       \_ mount /dev/mapper/truecrypt1 /media/truecrypt1 -o rw,noexec,nosuid,nodev,users,noatime,gid=100,fmask=133,dmask=022,locale=pl_PL.UTF-8,debug
12663 pts/0    S+     0:00  |           \_ /sbin/mount.ntfs /dev/mapper/truecrypt1 /media/truecrypt1 -o rw,noexec,nosuid,nodev,noatime,gid=100,fmask=133,dmask=022,locale=pl_PL.UTF-8,debug
12667 pts/0    S+     0:00  |               \_ /bin/mount -i -f -t fuseblk -o rw,nosuid,nodev,noexec,noatime,allow_other,default_permissions,blksize=4096 /dev/mapper/truecrypt1 /media/truecrypt1

unless i add -t ntfs-3g or -t ntfs explicitly or use /sbin/mount.ntfs symlink

tried it with no mount options, with gvfs* programs killed, with nepomuk & kerry/beagle shutdown etc , every time the same thing;/ it’s really annoying, because i don’t want to use console to mount it by hand using /bin/ntfs-3g or mount with -t flag, that’s why i changed distro to opensuse, that’s why i’m using GUI cryptographic program like truecrypt!

*otherwise mount will use kernel builtin driver instead of ntfs-3g, stock ntfs-3g package privides this symlink, but package from repository referred by cocolocko don’t, that’s why it worked for him, ntfs-3g wasn’t used;-)

maniel is right. I didn’t go back and check to see when I posted previously. ntfs-3g is not being used as he described in the package from the repository cocolocko referred to. I can reproduce the problem by creating the symlink from mount.ntfs->mount.ntfs-3g

Additionally, the hal policy is changed in from the default openSUSE 11.1 ntfs-3g policy for auto-mounting ntfs media, when using the repo referenced above, and may cause trouble. If you’ve gone this path, the fix is to restore the file /usr/share/hal/fdi/policy/10osvendor/21-storage-ntfs-3g.fdi from the openSUSE ntfs-3g package) if you want to keep the newer ntfs-3g driver.

I see this problem after an upgrade from 11.0. I tried previous versions of truecrypt, and different filesystems (reiser, ext2, fat).

Fat seems to work fine, but nothing else. I also saw the following error message in dmesg:

------------ cut here ]------------
kernel BUG at fs/fuse/dir.c:1162!
invalid opcode: 0000 #1] SMP
last sysfs file: /sys/devices/platform/dcdbas/smi_data_buf_phys_addr
Modules linked in: ext3 jbd mbcache aes_i586 aes_generic xts gf128mul dm_crypt ip6t_LOG xt_tcpudp xt_pkttype ipt_LOG xt_limit af_packet snd_pcm_oss snd_mixer_oss binfmt_misc snd_seq snd_seq_device ip6t_REJECT nf_conntrack_ipv6 ip6table_raw xt_NOTRACK ipt_REJECT xt_state iptable_raw iptable_filter ip6table_mangle nf_conntrack_netbios_ns nf_conntrack_ipv4 nf_conntrack cpufreq_conservative ip_tables cpufreq_userspace cpufreq_powersave acpi_cpufreq speedstep_lib ip6table_filter ip6_tables x_tables ipv6 microcode fuse loop dm_mod arc4 ecb crypto_blkcipher pcmcia iwl3945 rfkill snd_hda_intel mac80211 snd_pcm snd_timer snd_page_alloc led_class snd_hwdep tg3 iTCO_wdt video yenta_socket snd rsrc_nonstatic libphy i2c_i801 iTCO_vendor_support output ac sr_mod pcmcia_core button cfg80211 soundcore rtc_cmos battery dcdbas(X) intel_agp agpgart cdrom joydev i2c_core rtc_core pcspkr rtc_lib sg uinput sd_mod crc_t10dif uhci_hcd ehci_hcd usbcore edd reiserfs fan ide_pci_generic ide_core ata_generic ata_piix libata scsi_mod dock thermal processor thermal_sys hwmon
Supported: No

Pid: 4709, comm: loop0 Tainted: G ( #1)
EIP: 0060:<f9374460>] EFLAGS: 00010246 CPU: 0
EIP is at fuse_set_nowrite+0x1a/0xc2 [fuse]
EAX: f598da00 EBX: f5989040 ECX: 00000000 EDX: 00000000
ESI: f4dcb200 EDI: f541ac00 EBP: 00000000 ESP: f11bded0
DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process loop0 (pid: 4709, ti=f11bc000 task=f5983150 task.ti=f11bc000)
Stack: 00000000 00000000 ffffffff 7fffffff 00000000 f541ac00 f4dcb200 f59890ec
f9376bf2 00000001 00000001 f3a64560 00000000 00000000 f5989040 ffffffff
7fffffff 00000000 00020400 f9378cb0 f4dcb200 f59890ec 00000001 f9376ce3
Call Trace:
<f9376bf2>] fuse_fsync_common+0x72/0x154 [fuse]
<f9376ce3>] fuse_fsync+0xf/0x11 [fuse]
<f92658fd>] sync_file+0x3c/0x59 [loop]
<f9265a51>] do_bio_filebacked+0x137/0x14d [loop]
<f9265c29>] loop_thread+0x1c2/0x1ef [loop]
<c013f493>] kthread+0x38/0x5d
<c01060c7>] kernel_thread_helper+0x7/0x10

Code: 75 04 0f 0b eb fe 89 f0 e8 8a 41 da c6 90 5b 5e c3 57 56 53 89 c3 83 ec 14 8b 80 a0 00 00 00 83 7b 78 01 8b b8 90 01 00 00 75 04 <0f> 0b eb fe 89 f8 e8 f5 ef fd c6 8b 83 8c 01 00 00 85 c0 79 04
EIP: <f9374460>] fuse_set_nowrite+0x1a/0xc2 [fuse] SS:ESP 0068:f11bded0
— end trace caa31bfdcc8d1b42 ]—

i’ve found a solution, you have to rebuild fuse package with version changed to 2.7.4 in original opensuse specfile and ntfs-3g with wersion changed to 1.5130 in also original opensuse specfile [and remove patches and -Werrors from CFLAGS, otherwise the build will fail]
too bad that i can’t paste the specs here or attach srpms to the post

nope, it was false alarm, ntfs-3g package i build doesn’t provide /sbin/mount.ntfs link so mount used kernel builtin driver, that’s why i successfully mounted my partition:)

First of all a Happy New Year to you!

Has someone found a solution which does not imply recompiling any packages?

I’ve downgraded the ntfs-3g package back to the one from the openSUSE repository as we found out that the package from the Anubis repo doesn’t create the /sbin/mount.ntfs symlink which is the only reason why TrueCrypt is able to mount NTFS containers because it uses the old ntfs module (which has limited capabilities) in that case.

This combo (TrueCrypt + ntfs-3g) worked perfectly in Kubuntu 8.10.

Information for package ntfs-3g:

Repository: @System
Name: ntfs-3g
Version: 1.5012-2.10
Arch: i586
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 347.0 K
Information for package truecrypt:

Repository: @System
Name: truecrypt
Version: 6.1a-0
Arch: i586
Vendor: TrueCrypt Foundation
Installed: Yes
Status: up-to-date
Installed Size: 5.3 M

when using mount /dev/mapper/truecrypt1 /media/truecrypt1 ant the mount.ntfs symlink exists in /sbin, strace says something like that:

[pid 20499] open("/etc/mtab~20499", O_WRONLY|O_CREAT, 0600) = 6 
[pid 20499] close(6)                    = 0 
[pid 20499] gettimeofday({1232053319, 23978}, NULL) = 0 
[pid 20499] link("/etc/mtab~20499", "/etc/mtab~") = -1 EEXIST (File exists) 
[pid 20499] open("/etc/mtab~", O_WRONLY) = 6 
[pid 20499] gettimeofday({1232053319, 24183}, NULL) = 0 
[pid 20499] alarm(30)                   = 0 
[pid 20499] fcntl(6, F_SETLKW, {type=F_WRLCK, whence=SEEK_SET, start=0, len=0}

it looks like it’s stuck on /etc/mtab~*, it’s locked or what? it’s not the kernel fault IMHO [maybe opensuse patches are messing up?] because i’m encountering that on kernel too
tried glibc from factory [2.9-4.3, recompiled with my own flags] and still the same;/
devs! are you tere?!:slight_smile: